Bug 5497 - 6.1 Installer Errors (lilo.conf)
Summary: 6.1 Installer Errors (lilo.conf)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-04 17:27 UTC by Chris Kloiber
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-11 17:37:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Kloiber 1999-10-04 17:27:05 UTC
In dual-boot situations, if you change the default of 'dos' to 'win' it
appears to have made the change until you reboot. 'win' is not an
option, hitting <tab> reveals that the windows partition is still called
'dos'.

Chris Kloiber

Comment 1 Gene Czarcinski 1999-10-06 00:26:59 UTC
And if you do not select DOS at all and (in fact) are installing lilo
into a partition rather than the MBR, you still get DOS as a boot time
option.

Comment 2 Jay Turner 1999-10-20 15:55:59 UTC
This issue has been assigned to a developer for further action

Comment 3 Jay Turner 1999-10-25 17:15:59 UTC
*** Bug 6310 has been marked as a duplicate of this bug. ***

The latest installer updates (boot...1999044.img and
updates...1999045.img) still don't deal properly with
"other" boot partitions.

I'm far from experienced with installing Redhat Linux so
please bear with me. I've been using 6.0 successfully for
some time, but can't get 6.1 installed so that I can get to
the Windows system via LILO.

With 6.0 the possible boot partitions are:
/dev/sda1 linux
/dev/sdb1 win98
/dev/sdb3 dos

My system has 2 SCSI drives with Linux on sda, Win98 on one
partition of sdb and Dos on another partition of sdb.

The 6.0 installer recognizes sdb1 as "dos" and for sdb3 the
name field comes up blank, so I have to change "dos" to
"win98" and fill in the blank with "dos". After about 4
tries going back and forth between installing 6.0 and 6.1
with the "custom" option, LILO is always set up properly
with 6.0 and never set up properly with 6.1.

The 6.1 installer recognizes sdb1 as "dos" but does not give
an entry for sdb3 at all. When I change "dos" to "win98",
complete the installation and reboot, LILO shows both the
"linux" and "win98" options. Booting into linux works fine,
but booting into win98 goes off into never-never-land and I
have to reset the computer.

I hope this helps in working out the bugs. If you need more
info, I'm reachable by phone at:
914-627-2672 home
914-425-2000 ext. 3292 work (9-5 EST)

Alan Feuerbacher

Comment 4 Jay Turner 2000-02-11 17:37:59 UTC
Issue is resolved in the latest installer (available in beta)


Note You need to log in before you can comment on or make changes to this bug.