Bug 6310 - Other boot partitions not recognized
Other boot partitions not recognized
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-24 14:40 EDT by alanf
Modified: 2015-01-07 18:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-25 13:15:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description alanf 1999-10-24 14:40:04 EDT
The latest installer updates (boot...1999044.img and
updates...1999045.img) still don't deal properly with
"other" boot partitions.

I'm far from experienced with installing Redhat Linux so
please bear with me. I've been using 6.0 successfully for
some time, but can't get 6.1 installed so that I can get to
the Windows system via LILO.

With 6.0 the possible boot partitions are:
/dev/sda1 linux
/dev/sdb1 win98
/dev/sdb3 dos

My system has 2 SCSI drives with Linux on sda, Win98 on one
partition of sdb and Dos on another partition of sdb.

The 6.0 installer recognizes sdb1 as "dos" and for sdb3 the
name field comes up blank, so I have to change "dos" to
"win98" and fill in the blank with "dos". After about 4
tries going back and forth between installing 6.0 and 6.1
with the "custom" option, LILO is always set up properly
with 6.0 and never set up properly with 6.1.

The 6.1 installer recognizes sdb1 as "dos" but does not give
an entry for sdb3 at all. When I change "dos" to "win98",
complete the installation and reboot, LILO shows both the
"linux" and "win98" options. Booting into linux works fine,
but booting into win98 goes off into never-never-land and I
have to reset the computer.

I hope this helps in working out the bugs. If you need more
info, I'm reachable by phone at:
914-627-2672 home
914-425-2000 ext. 3292 work (9-5 EST)

Alan Feuerbacher
Comment 1 Jay Turner 1999-10-25 13:15:59 EDT
*** This bug has been marked as a duplicate of 5497 ***

Note You need to log in before you can comment on or make changes to this bug.