Bug 55000 - Initial boot after 7.2 upgrade on Athlon platform oopses kernel
Initial boot after 7.2 upgrade on Athlon platform oopses kernel
Status: CLOSED DUPLICATE of bug 55040
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-23 22:46 EDT by Tom Wood
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-24 03:10:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Wood 2001-10-23 22:46:15 EDT
Description of Problem: After a 7.2 upgrade from a 7.1 with kernel 2.4.12, Athlon mobo with Via chipset oopses during boot during rc.* startup.


Version-Release number of selected component (if applicable): kernel 2.4.7


How Reproducible: every time


Steps to Reproduce:
1.Upgrade 7.1 to 7.2 (I suspect this kernel won't work with an install either)
2. Boot machine.
3.During rc.* startup, usually rc.sysinit, kernel oopses in non-deterministic locations.
Actual Results: kernel oopses


Expected Results: It should have booted.


Additional Information:Abit KT7A motherboard - KT133A chipset from Via.

This is a well-known issue, discussed within the kernel mailing list for some time now.  I had hoped that the "extensively patched" 2.4.7 kernel with 7.2 included a fix for this, or at least installation of a PII or a PIII kernel instead of the Athlon kernel.  I'll have to boot into rescue mode and/or figure out grub enough to boot the 2.4.12 that's still there.
Comment 1 Arjan van de Ven 2001-10-24 03:10:02 EDT
There's no fix currently that we can ship, unfortionatly. 
However you can type "noathlon" after the kernel commandline (type "e" in grub
to edit an entry, then go to the second line, and edit that one to append
noathlon to it) and that makes it work again.
Comment 2 Arjan van de Ven 2001-11-04 17:10:41 EST
See also bug 55040

*** This bug has been marked as a duplicate of 55040 ***

Note You need to log in before you can comment on or make changes to this bug.