Bug 55040 - Red Hat Linux 7.2 locks up at boot time, athlon
Red Hat Linux 7.2 locks up at boot time, athlon
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
: 55000 55144 55496 58240 58369 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-24 14:34 EDT by grooved pavement
Modified: 2014-01-21 17:48 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-01 02:00:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description grooved pavement 2001-10-24 14:34:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; Win 9x 4.90)

Description of problem:
seems as though when bootup procedure gets to the loading of the usb 
support after the "Welcome to Red Hat Linux hit "I" for interactive 
startup" message it just throws a bunch of junk on the screen and 
complains about the interrupt handler or some sort of kernel error and 
locks up to the point that i have to power down. maybe this is a known 
problem?

Version-Release number of selected component (if applicable):

Red Hat 7.2
How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
	happens on bootup

Additional info:
Comment 1 Arjan van de Ven 2001-10-24 14:39:22 EDT
Is this an athlon cpu machine ?
If so, does it help if you type "noathlon" as extra kernel option in grub (or
add it to the lilo prompt if you use lilo)
Comment 2 grooved pavement 2001-10-24 14:46:03 EDT
yes it is an athlon machine

athlon 1.4 cpu
abit kt7-a mother board
and i have unplugged all usb devices and even disabled usb in the bios to no 
avail....
Comment 3 Arjan van de Ven 2001-10-24 14:50:52 EDT
ok please try the "noathlon" thing
in grub type "e" over the kernel, go down one and edit that line to add noathlon
to the end of the line, <enter> and then <b> for boot.
If that works, I'll help you make that permanent
Comment 4 grooved pavement 2001-10-24 15:06:27 EDT
ok!@##$ that worked, it got me booted up and led me to hardware mangaer where i
removed the VIA usb device.i sure would like to now more about this issue though :).
Comment 5 Arjan van de Ven 2001-10-24 15:16:28 EDT
ok the basic issue is that some bioses tune the VIA chipset beyond the memory
bandwith it can handle, and under certain uses it does things wrong then.
The kernel uses a very fast memory-copy routine optimized for athlons that
triggers this condition, the noathlon option avoids using this routine, and
hence avoids the "things go wrong".

We're talking with VIA about it for a while now, and people on the linux kernel
mailing list have found a setting in the chipset that makes a differnce,
unfortionatly this setting is undocumented in the chipset documentation so we
don't know if it's harmful or not.

For your situation there are 2 options: installing the i686 kernel instead of
the athlon kernel, or keep using "noathlon".

To do the later, open /boot/grub/grub.conf in a texteditor (as root) and add
noathlon in the place you used for booting before.
Comment 6 grooved pavement 2001-10-24 15:18:42 EDT
very good sir. i thank you dearly for your time

have a good day!
Comment 7 Bill Nottingham 2001-11-01 11:51:22 EST
*** Bug 55496 has been marked as a duplicate of this bug. ***
Comment 8 Arjan van de Ven 2001-11-04 17:10:35 EST
*** Bug 55000 has been marked as a duplicate of this bug. ***
Comment 9 Arjan van de Ven 2001-11-04 17:16:00 EST
*** Bug 55144 has been marked as a duplicate of this bug. ***
Comment 10 Arjan van de Ven 2002-01-18 13:40:04 EST
*** Bug 58369 has been marked as a duplicate of this bug. ***
Comment 11 Arjan van de Ven 2002-01-18 13:50:27 EST
*** Bug 58240 has been marked as a duplicate of this bug. ***
Comment 12 Need Real Name 2002-02-01 02:00:11 EST
wohoo helped me out...but how can I install with the i686 kernel? And why Red 
Hat gotta be playa haters? :P
Comment 13 Arjan van de Ven 2002-02-11 11:25:00 EST
Also note that the 2.4.9-21 kernel has a fix to undo the damage the bios has
done.

Note You need to log in before you can comment on or make changes to this bug.