Bug 550027 - repoquery -qf implies \n whereas rpm doesn't
repoquery -qf implies \n whereas rpm doesn't
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 590920 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-23 05:37 EST by Matěj Cepl
Modified: 2014-01-21 18:13 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-12 13:42:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2009-12-23 05:37:08 EST
Description of problem:

repoquery -qa --qf="%{NAME}\t%{SOURCERPM}\n" \*sync\* 

prints blank line between each entry whereas

rpm -qa --qf="%{NAME}\t%{SOURCERPM}\n" \*sync\* 

doesn't. It should be unified IMHO and given the age of rpm, I guess it should get precedence.

Version-Release number of selected component (if applicable):
yum-utils-1.1.24-2.fc12.noarch
Comment 1 seth vidal 2009-12-23 07:53:16 EST
given that panu wrote this code in repoquery, I'll leave it up to him. But I suspect it was written this way b/c the rpm --qf silliness just confused users.

And so rather than duplicate those errors he fixed it.
Comment 2 Matěj Cepl 2009-12-23 20:00:43 EST
(In reply to comment #1)
> given that panu wrote this code in repoquery, I'll leave it up to him. But I
> suspect it was written this way b/c the rpm --qf silliness just confused users.
> 
> And so rather than duplicate those errors he fixed it.  

Well, although I agree that repoquery behavior is more sane, but I believe that consistency is more important than sainty.

Panu?
Comment 3 Panu Matilainen 2010-01-04 03:02:06 EST
Can't remember for sure but I suspect the newline behavior was basically just for sanity's sake. While the queryformat strings of rpm and repoquery are similar, there are numerous incompatibilities between them, you can't expect to copy-paste between rpm and repoquery query formats anyway. Me thinks making such a fundamental change after at this point (repoquery is several years old too and widely used) would be far more pain than the consistency gain.
Comment 4 seth vidal 2010-01-12 13:42:33 EST
agreed
Comment 5 seth vidal 2010-05-10 22:00:54 EDT
*** Bug 590920 has been marked as a duplicate of this bug. ***
Comment 6 Matt McCutchen 2011-08-29 23:55:46 EDT
*** Bug 734259 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.