Bug 590920 - repoquery --qf adds \n
repoquery --qf adds \n
Status: CLOSED DUPLICATE of bug 550027
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
13
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-10 20:01 EDT by Roland McGrath
Modified: 2014-01-21 18:14 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-10 22:00:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland McGrath 2010-05-10 20:01:04 EDT
Description of problem:

repoquery --qf adds an implicit \n at the end of the string.
rpm --qf does not do this.  repoquery should match rpm.

Version-Release number of selected component (if applicable):
yum-utils-1.1.26-1.fc13.noarch

How reproducible:
100%

Steps to Reproduce:
1.diff -u <(rpm -q bash --qf '%{NAME}' | cat -AE) <(repoquery  -q bash --qf '%{NAME}' | cat -AE)
2.
3.
  
Actual results:

Differ in whether there is a trailing newline.

Expected results:

Both match.

Additional info:
Comment 1 seth vidal 2010-05-10 22:00:54 EDT

*** This bug has been marked as a duplicate of bug 550027 ***

Note You need to log in before you can comment on or make changes to this bug.