Bug 550054 - Feature Request: pptp
Feature Request: pptp
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-23 07:35 EST by Cepreu
Modified: 2011-06-27 10:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-27 10:43:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
New plugin & scripts (13.15 KB, application/x-bzip2)
2009-12-23 07:38 EST, Cepreu
no flags Details
New patch for latest HEAD (82.32 KB, patch)
2010-03-09 20:03 EST, Cepreu
no flags Details | Diff
Yet another new version of plugin (82.32 KB, patch)
2010-03-12 23:50 EST, Cepreu
no flags Details | Diff

  None (edit)
Description Cepreu 2009-12-23 07:35:45 EST
Description of problem:
There is no support of pptp-connections in system-config-network

Additional info:
See attachement. There is the patch to latest HEAD of system-config-network, which add this function, and iniscripts files: network-functions(just added strings 110-112) and ifup-pptp, ifdown-pptp.
Comment 1 Cepreu 2009-12-23 07:38:32 EST
Created attachment 380020 [details]
New plugin & scripts

There is .patch file for latest HEAD of system-config-network and scripts for initscripts package.
Comment 2 Dan Williams 2010-01-19 21:13:56 EST
No matter where this goes wtih s-c-n, we should probably make sure that the ifcfg file format is the same between NetworkManager's ifcfg-rh plugin and whatever ifcfg keys you're using.

PPTP is really about VPNs; I can't think off the top of my head why re-using the PPP options for PPTP will be an issue since ifcfg files don't describe multiple types of connection, but it may be an issue.

You probably want to file *another* bug for the ifup/ifdown/network-functions parts of this patch, and against the 'initscripts' component.  This bug is filed against system-config-network, which is only for the graphical pieces.  So basically you should have one bug for the command-line-only bits filed against 'initscripts' and then this bug for the GUI bits filed against system-config-network.

I think some of the reluctance is because we're slowly trying to kill s-c-n and replace it with nm-connection-editor and NetworkManager.  s-c-n doesn't deal with a bunch of connection types that NetworkManager does, and we're fixing up NetworkManager to handle the types that it doesn't yet handle (ADSL and ISDN).  So while the command-line pieces of the patch might well get added, the GUI bits may not...
Comment 3 Cepreu 2010-01-20 00:28:45 EST
Ok, i created appropriate bug report for initcscripts: https://bugzilla.redhat.com/show_bug.cgi?id=557010.
I understand, that you trying to kill s-c-n, but i think it is still good idea: add my patch to upstream. Because PPTP support in NetworkManager not good for all cases. There is still not any chance to establish pptp-connection from command line and/or without login in system, when machine starts, for example. There is still no way, to forbid control this type of connection for non-root users, which can be useful for some offices, for example. So, i think, there is good idea to add support of this connection to s-c-n.
And about ifcfg-rh i can say, that is no fucntion to create PPTP-connection shared for all users in NetworkManager. So, when you try to export or import this type of connection to/from file, NM just give an error.
Comment 4 Cepreu 2010-03-09 20:03:10 EST
Created attachment 398980 [details]
New patch for latest HEAD

There is new version of plug-in. Fixed problem with creating connection without any kind of encryption.
Comment 5 Cepreu 2010-03-12 23:50:20 EST
Created attachment 399808 [details]
Yet another new version of plugin

There is new version (0.3 lets say) of plugin. Fixed incorrect system name for connection. So now you can create fules for this connection in system-config-firewall. Also now correctly displays than connection are active or inactive.
Comment 6 Bug Zapper 2010-03-15 09:40:43 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 alien_life_form 2010-11-17 09:47:25 EST
Uhm. For what it's worth, I'd second the poster idea that killing s-c-n is not a particularly good idea, NM's state being what it is now. For pptp connections - for instance - it is not possible to add specific routes through the NM interface alone. Not to mention that ifup <iface> and ifdown <iface> do not work, etc.
Comment 8 Bug Zapper 2011-06-02 13:02:58 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2011-06-27 10:43:44 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.