Bug 55045 - Kickstart broken....
Summary: Kickstart broken....
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mkkickstart   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 55043 55044 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-24 19:58 UTC by Paul Lussier
Modified: 2007-04-18 16:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 00:19:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ks.config file (3.12 KB, text/plain)
2001-10-24 20:00 UTC, Paul Lussier
no flags Details
perl script to write out ks.cfg partition info (1.56 KB, text/plain)
2001-10-24 21:15 UTC, Paul Lussier
no flags Details

Description Paul Lussier 2001-10-24 19:58:02 UTC
Description of Problem:

A. mkkickstart fails to properly detect existing partitioning of disk
B. Even when proper partitioning info is manually added to ks.cfg file
   and a kickstart install (linux ks=floppy) fails with error message:

           Error opening: kicktart file /tmp/ks.cfg: no such file
           or directory

Version-Release number of selected component (if applicable):


How Reproducible:
Consistently

Steps to Reproduce:
1. build system manually with customized partitioning 
2. run 'mkkickstart > /mnt/floppy/ks.cfg
      a. open ks.cfg in editor (or use less) to verify 
         partioning info is incorrect
      b. manually correct all partitioning info
3. boot new system off cdrom with 'linux ks=floppy'
4. watch it break

Actual Results:
Total and complete failure to install OS on system

Expected Results:
Er, a working system maybe?

Additional Information:
You might want to check out Sun's JumpStart, it works.

Comment 1 Paul Lussier 2001-10-24 20:00:07 UTC
Created attachment 34902 [details]
ks.config file

Comment 2 Paul Lussier 2001-10-24 21:13:09 UTC
mkkickstart by default creates incorrect partitioning information.  This is
what I ended up for partitioning info with before manually correcting it:

        part swap --size 245
        part /home --size 488

I don't understand why this is so broken, it should be trivial to figure
out what the exising partitioning scheme is.  I've attached a simple perl
script you can use to figure this stuff out if you want it.

Comment 3 Paul Lussier 2001-10-24 21:15:32 UTC
Created attachment 34941 [details]
perl script to write out ks.cfg partition info

Comment 4 Paul Lussier 2001-10-26 20:07:22 UTC
Tested this same ks.cfg file on a new 7.2 install and it failed with
the same /tmp/ks.cfg: No such file or directory error as 7.1 does.

Comment 5 Paul Lussier 2001-11-05 19:18:48 UTC
Thump, Thump, Thump.  Hey, this thing working?  Testing 1...2...3...

Anyone here?  Anyone.  Is thing on?

Bueller? Bueller? Bueller?

Hmmm, maybe there's a minimum incubation period of 2 weeks before bug fixes hatch?



Comment 6 Paul Lussier 2001-11-05 20:53:21 UTC
Outstanding!  So now I've even succeeded to prove that 7.2 has the same bug.

I used the anaconda-ks.cfg file created during 7.2 install, saved it to a
floppy, booted an identical system using the 7.2 install CD and specified

        linux ks=floppy

and I get an error stating:

        Error opening: kickstart file /tmp/ks.cf: No such file ir directory

By the way, is anyone there even reading bug reports anymore?  I have yet to 
even get an acknowledgement that anyone is receiving these reports.

Comment 7 Matt Wilson 2002-12-15 00:15:15 UTC
*** Bug 55043 has been marked as a duplicate of this bug. ***

Comment 8 Matt Wilson 2002-12-15 00:15:21 UTC
*** Bug 55044 has been marked as a duplicate of this bug. ***

Comment 9 Matt Wilson 2002-12-15 00:19:27 UTC
Did you rename anaconda-ks.cfg ks.cfg?

And, mkkickstart is gone now, replaced by anaconda-ks.cfg being generated.


Note You need to log in before you can comment on or make changes to this bug.