Bug 55069 - Error when filesystem contains '$' character
Error when filesystem contains '$' character
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: diskcheck (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
: 55850 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-25 00:52 EDT by Chris Rode
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-26 12:03:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This patch fixes the problem for me. (444 bytes, patch)
2001-10-26 03:13 EDT, Alexandre Oliva
no flags Details | Diff

  None (edit)
Description Chris Rode 2001-10-25 00:52:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; Win 9x 4.90)

Description of problem:
Diskcheck gives the following traceback when run while filesystems (SMB 
shares) containing a '$' character are mounted.  When these filesystems 
are not mounted, no error occurs.  I don't know python well enough to 
provide a patch, however.

Traceback (innermost last):
  File "/etc/cron.hourly/diskcheck", line 65, in ?
    (volume, total, used, avail, pct, mountpt) = string.split(line)
ValueError: unpack list of wrong size

Mounted filesystems:
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/md2                253743    165635     75008  69% /
/dev/md1               1031960    298804    680736  31% /home
/dev/md0               3579936   2929628    468452  87% /usr
/dev/md3              16460968   8709320   6915464  56% /var
none                     47024         0     47024   0% /dev/shm
//BURT/win2k_hotfix$   4731136   2025856   2705280  43% /mnt/win2k_hotfix
//BURT/br_reps_audit$ 
                      20972544  12068352   8904192  58% /mnt/br_reps_audit


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Mount an SMB share with a '$' in the share name
2. Run diskcheck
3.
	

Actual Results:  Traceback (innermost last):
  File "/etc/cron.hourly/diskcheck", line 65, in ?
    (volume, total, used, avail, pct, mountpt) = string.split(line)
ValueError: unpack list of wrong size


Expected Results:  No traceback should have been produced.

Additional info:
Comment 1 Alexandre Oliva 2001-10-26 03:12:12 EDT
The problem is not the `$', but the fact that df breaks the output line if the
`Filesystem' field is too wide.  The solution is to use `df -P', so that it
doesn't do it.
Comment 2 Alexandre Oliva 2001-10-26 03:13:12 EDT
Created attachment 35163 [details]
This patch fixes the problem for me.
Comment 3 Chris Rode 2001-10-26 12:02:51 EDT
This patch fixes it here, too.  Thanks! :)
Comment 4 Preston Brown 2001-11-07 11:09:08 EST
fixed in an upcoming errata.
Comment 5 Preston Brown 2001-11-08 09:25:29 EST
*** Bug 55850 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.