Bug 55850 - diskcheck crashes when device names are long
diskcheck crashes when device names are long
Status: CLOSED DUPLICATE of bug 55069
Product: Red Hat Linux
Classification: Retired
Component: diskcheck (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-07 14:11 EST by John M O'Donnell
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-07 14:12:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John M O'Donnell 2001-11-07 14:11:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
if the device name is long then the diskcheck script produces
a cryptic error message.  This appears to be related to parsing
the output of the df command - which for a long device name will
produce one entry split across two lines.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.mount --bind /home/odonnell/lib/wnr /var/ftp/pub/wnr/lib/wnr
2./etc/cron.hourly/diskcheck
	

Actual Results:  Traceback (innermost last):
  File "/etc/cron.hourly/diskcheck", line 65, in ?
    (volume, total, used, avail, pct, mountpt) = string.split(line)
ValueError: unpack list of wrong size


Additional info:
Comment 1 Preston Brown 2001-11-08 09:25:37 EST

*** This bug has been marked as a duplicate of 55069 ***

Note You need to log in before you can comment on or make changes to this bug.