Bug 55075 - libpopt.so.0 not available for raid0start
Summary: libpopt.so.0 not available for raid0start
Status: CLOSED DUPLICATE of bug 54587
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: popt   
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-25 06:03 UTC by Erik Selberg
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-25 06:04:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Erik Selberg 2001-10-25 06:03:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
I upgraded my RH 7.1 to RH 7.2. After it booted, raid0start failed because 
it couldn't load libpopt.so.0. This file is in /usr/lib/libpopt.so.0, and 
on my system /usr (and /usr/lib) weren't mounted yet, as raid is started 
immediately after the root filesystem is mounted. Workaround: I copied 
libpopt.so.0 into /lib, which is on the root FS.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Use a software raid disk (/dev/md0)
2. Put /usr and / on different partitions
3. Upgrade from RH 7.1 to 7.2
4. Watch it crash

	

Actual Results:  raid0start halted, as did boot-up. Then got into maint 
mode. Wee!

Expected Results:  Either (a) raid0start would have found libpopt.so.0 in 
the root filesystem (/lib) or /usr would have been mounted before raid, 
so /usr/lib would be available for raid0start.

Random thought: this is /sbin/raid0start. Perhaps raid0start (symlink'd to 
mkraid) isn't STATIC like it should be in /sbin? :)

Additional info:

Comment 1 Bill Nottingham 2001-10-29 19:07:07 UTC

*** This bug has been marked as a duplicate of 54587 ***


Note You need to log in before you can comment on or make changes to this bug.