Bug 55091 - preun script causing error
preun script causing error
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: iptables (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
: 60671 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-25 09:52 EDT by Michael Schwendt
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-25 09:53:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch against spec file (224 bytes, patch)
2001-10-25 09:53 EDT, Michael Schwendt
no flags Details | Diff

  None (edit)
Description Michael Schwendt 2001-10-25 09:52:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
Iptables's pre-uninstall script is bad and prints

  /var/tmp/rpm-tmp.70505: [: /var/tmp/rpm-tmp.70505:
  integer expression expected

Fix attached.


Version-Release number of selected component (if applicable):
1.2.3-1

How reproducible:
Always

Steps to Reproduce:
1. rpm -e iptables
Comment 1 Michael Schwendt 2001-10-25 09:53:16 EDT
Created attachment 35061 [details]
patch against spec file
Comment 2 Stephen Samuel 2002-01-22 16:52:51 EST
This problen still exists (has resurrected?) in iptables-1.2.4-2.i386.rpm. I ran
into it doing an update from a relatively virgin 7.2 system.
Comment 3 Michael Schwendt 2002-01-22 17:17:45 EST
No, it hasn't. The original problem is in the iptables package being shipped
with Enigma. You see it when you erase/upgrade that package. Once you have
upgraded to the fixed 1.2.4-2 package, the problem is gone.
Comment 4 Ben Levenson 2002-03-04 15:47:57 EST
*** Bug 60671 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.