Bug 55123 - Iptables rules will not accept the word notice as a logging level.
Summary: Iptables rules will not accept the word notice as a logging level.
Status: CLOSED DUPLICATE of bug 54280
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: iptables   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-25 20:40 UTC by Tom Diehl
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-26 06:21:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (832 bytes, patch)
2001-10-26 05:32 UTC, Michael Schwendt
no flags Details | Diff

Description Tom Diehl 2001-10-25 20:40:44 UTC
Description of Problem:When trying to load the log-level of notice in an 
iptables rule iptables complains that this is not valid. Changing to log 
level 5 works. The man page states the following:
 --log-level level
              Level of logging (numeric or see syslog.conf(5)). 


Version-Release number of selected component (if applicable):1.2.3-1


How Reproducible:Every time


Steps to Reproduce:
1. Load the rule with LOg turned on with --log-level set to notice.
2. 
3. 

Actual Results:iptables gives an error that loglevel notice is invalid


Expected Results:Should load the rule.


Additional Information:These rules were working for a long time on a 7.0 
machine. Upon upgrade they refused to load.

Comment 1 Michael Schwendt 2001-10-26 05:24:17 UTC
iptables-1.2.3/extensions/libipt_LOG.c -> parse_level(..) is bad.

But this is fixed with iptables-1.2.4.


Comment 2 Michael Schwendt 2001-10-26 05:32:32 UTC
Created attachment 35161 [details]
patch

Comment 3 Tom Diehl 2001-10-26 05:35:36 UTC
Am I correct that there is no official redhat fix?


Comment 4 Michael Schwendt 2001-10-26 06:21:42 UTC
Btw, duplicate of bug #54280.

Comment 5 Bernhard Rosenkraenzer 2001-10-30 11:52:35 UTC

*** This bug has been marked as a duplicate of 54280 ***


Note You need to log in before you can comment on or make changes to this bug.