Bug 54280 - string_to_number buglets
string_to_number buglets
Status: CLOSED ERRATA
Product: Red Hat Raw Hide
Classification: Retired
Component: iptables (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
: 55123 55124 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-02 18:58 EDT by Geoffrey T. Dairiki
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-07 09:16:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patches for bug #54280 (3.11 KB, patch)
2001-10-02 19:00 EDT, Geoffrey T. Dairiki
no flags Details | Diff

  None (edit)
Description Geoffrey T. Dairiki 2001-10-02 18:58:31 EDT
Description of Problem:

Certain (mostly) numeric command line arguments are not correctly handled.

Version-Release number of selected component (if applicable):

iptables-1.2.3-1

How Reproducible:

Always.

Steps to Reproduce:

String values for the --log-level argument, for exaple
won't work.

 iptables -A INPUT -s 10.0.0.0/8 -j LOG --log-level info

Actual Results:

 "log-level `info' ambiguous"

Expected Results:

 A new iptables rule.

Additional Information:
	
 Patch attached.
Comment 1 Geoffrey T. Dairiki 2001-10-02 19:00:22 EDT
Created attachment 33278 [details]
Patches for bug #54280
Comment 2 Geoffrey T. Dairiki 2001-10-02 19:01:47 EDT
BTW, these fixes have already made their way into the CVS version of the
iptables code.
Comment 3 Bernhard Rosenkraenzer 2001-10-30 06:52:01 EST
Fixed in 1.2.4-1
Comment 4 Bernhard Rosenkraenzer 2001-10-30 06:52:29 EST
*** Bug 55123 has been marked as a duplicate of this bug. ***
Comment 5 Bernhard Rosenkraenzer 2001-10-30 06:53:08 EST
*** Bug 55124 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.