Bug 55128 - Support for br abnt2 is missing the ]} key
Support for br abnt2 is missing the ]} key
Status: CLOSED DUPLICATE of bug 70351
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-10-25 18:47 EDT by Alexandre Oliva
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-07-31 15:05:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2001-10-25 18:47:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
The ] key is ignored by X11 when the keyboard set up is configured for
model abnt2 layout br.  The problem is that, in
/usr/X11R6/lib/X11/xkb/geometry/pc, xkb_geometry "abnt2" mentions both
<AC12> and <BKSL>, in their correct positions, but
/etc/X11R6/lib/X11/xkb/keycodes/pc aliases AC12 to BKSL in xkb_keycodes
"basic", and then xkb_keycodes "abnt2" sets <BKSL> to 94, without setting
<AC12> to 51, that is the correct value for the `]' key.  I don't
understand why 51 is right, given that the scan code of the key is 0x2b,
but still, it works.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Get a br abnt2 keyboard.
2.Configure for a br abnt2 keyboard
3.Type the `]' key.

Actual Results:  It does nothing.

Expected Results:  A `]' should be generated.

Additional info:

Fix: in /usr/X11R6/lib/X11/xkb/keycodes/pc, add to the xkb_keycodes "abnt2"
section the following line:
    <AC12> = 51;
then restart X or get it to re-read the keyboard configuration.
Comment 1 Alexandre Oliva 2001-10-25 19:01:45 EDT
Oops, where I wrote .../keycodes/pc, I meant .../keycodes/xfree86, sorry.

BTW, apologies for not having caught this one in the beta :-(
Comment 2 Mike A. Harris 2001-10-27 17:52:46 EDT
I've added the proposed fix to XFree86-4.1.0-5, which should be
available shortly for testing.
Comment 3 Mike A. Harris 2002-03-07 01:56:26 EST
This file is now very weird, and I am sure it is broken, but have no
idea what is correct.  It currently shows:

    // Keys that are generated on Japanese and Brazillian keyboards
    alias <AC12> = <BKSL>;


// For brazilian ABNT2 keyboard. by Ricardo Y. Igarashi(iga@that.com.br)
xkb_keycodes "abnt2" {
    include "xfree86(basic)"
    <AC12> = 51;
    <BKSL> = 94;
    <AC12> = 51;

That is almost certainly incorrect.  I'm removing the patch for now
which will disappear in build 4.2.0-6.41.  Please let me know if this
breaks support, and we will try to find the correct fix.
Comment 4 Alexandre Oliva 2002-03-07 03:16:40 EST
The alias was already there back when I wrote the patch, but it was not
appropriate for abnt2, which is why both AC12 and BKSL were introduced.

Of course, the duplicate definition of AC12 in the abnt2 section is not
necessary.  Perhaps you installed my suggested fix, then the duplicate came in
in a merge from XFree86, since my patch made it to the XFree86 CVS tree as of 4.2.0?
Comment 5 Alexandre Oliva 2002-07-01 00:10:02 EDT
Unfortunately, on Red Hat Linux 7.3, the ]} key produces \|, whereas the \| key
produces <>.  Ouch!  I'm looking into fixing this.
(would it have been better to open a new bug report, so that queries on 7.3
would find this?)
Comment 6 Alexandre Oliva 2002-07-01 01:09:28 EDT
Hmm...  Could it be that the order of the entries matter, given that AC12 is
defined as an alias to BKSL earlier in the file?

This used to work in 7.2:

xkb_keycodes "abnt2" {
    include "xfree86(basic)"
    <AC12> = 51;
    <BKSL> = 94;

but this is what came with 7.3:

xkb_keycodes "abnt2" {
    include "xfree86(basic)"
    <BKSL> = 94;
    <AC12> = 51;

Unfortunately, I don't have easy access to abnt2 keyboards.  I should probably
buy one just to be able to test stuff like this.  It's a shame that, for every
release, I say the earlier problems were fixed, but new ones manage to creep in,
and they go unnoticed until I install non-betas at the uni, where such keyboards
are common.  :-(

Anyway, I'll ask people at the uni to give it a try and report back.
Comment 7 Alexandre Oliva 2002-07-01 12:23:23 EDT
unfortunately, changing the order of the keys didn't help.  I'm now at a loss of
what to try :-(  Suggestions?
Comment 8 Alexandre Oliva 2002-07-01 15:26:09 EDT
Found it.  The problem was that anaconda was generating the kbd configuration
with XkbModel "pc102", instead of "abnt2" that would have made it work.
Comment 9 Mike A. Harris 2002-07-29 21:25:39 EDT
I've no idea what the proper solution to this problem is.  Please
contact XFree86.org directly, as that is the speediest way to a proper
solution.  Closing bug WONTFIX.
Comment 10 Alexandre Oliva 2002-07-31 15:06:26 EDT

*** This bug has been marked as a duplicate of 70351 ***

Note You need to log in before you can comment on or make changes to this bug.