Bug 70351 - wrong XkbModel set up for Brazilian abnt2 keyboard
Summary: wrong XkbModel set up for Brazilian abnt2 keyboard
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: rhpl (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 55128 (view as bug list)
Depends On:
Blocks: 67218
TreeView+ depends on / blocked
 
Reported: 2002-07-31 18:52 UTC by Alexandre Oliva
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-11 13:44:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Diff to fix abnt2 mapping (940 bytes, patch)
2002-08-08 13:42 UTC, Jay Turner
no flags Details | Diff

Description Alexandre Oliva 2002-07-31 18:52:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020722

Description of problem:
When br-abnt2 is selected as the keyboard at install time, anaconda generates
XF86Config with XkbModel "pc102", instead of "abnt2".  This causes at least two
keys not to function properly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Choose Brazilian (br-abnt2) keyboard at install time
2.After installation, try to type ], }, \ or | in the X login screen.	

Actual Results:  You get \, |, < and >, respectively.  Oops.

Expected Results:  Just what I typed in :-)

Additional info:

Comment 1 Alexandre Oliva 2002-07-31 19:06:22 UTC
*** Bug 55128 has been marked as a duplicate of this bug. ***

Comment 2 Alexandre Oliva 2002-07-31 20:02:51 UTC
I failed to mention that this problem affects only XFree86, not text mode, which
is why I thought it was an anaconda problem, not a redhat-config-keyboard one. 
Jeremy has clarified that redhat-config-keyboard holds the config data, even
though it doesn't set up XF86Config itself.

Comment 3 Brent Fox 2002-08-01 16:11:54 UTC
Should be fixed in redhat-config-keyboard-0.9.7-2.  Anaconda has it's own way of
writing out the initial XF86Config file, but redhat-config-keyboards can now
change the values in XF86Config after install.  If anaconda is writing out the
wrong values, please open a new bug against it.

QA, please verify.

Comment 4 Jay Turner 2002-08-08 13:40:53 UTC
Still having issues with this one.  The bug is actually in rhpl, so changing
component and attaching diff.

Comment 5 Jay Turner 2002-08-08 13:42:09 UTC
Created attachment 69524 [details]
Diff to fix abnt2 mapping

Comment 6 Brent Fox 2002-08-11 13:36:22 UTC
Ah, the original bug was that redhat-config-keyboard wasn't modifying
XF86Config.  So I fixed that, only to find out that rhpl's keyboard list was
incorrect.  Will fix now.

Comment 7 Brent Fox 2002-08-11 13:44:10 UTC
Should be fixed in rhpl 0.34-1.  Thanks for the patch, Jay.

Comment 8 Jay Turner 2002-08-16 18:49:44 UTC
Fix confirmed in rhpl-0.39-1.


Note You need to log in before you can comment on or make changes to this bug.