Bug 551310 - update to kde-4.3.4 - X startup fails, xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call
update to kde-4.3.4 - X startup fails, xf86OpenConsole: VT_WAITACTIVE failed:...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
12
i586 Linux
low Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Triaged
: 551344 554480 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-29 18:08 EST by Jaroslav Franek
Modified: 2010-01-18 23:37 EST (History)
24 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-18 23:37:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log matching comment #31 (50.05 KB, text/plain)
2009-12-30 18:27 EST, Brad Hards
no flags Details

  None (edit)
Description Jaroslav Franek 2009-12-29 18:08:15 EST
Description of problem:

Upgraded to latest versions of KDE from fedora updates repo. When rebooted machine the system "hangs" at the end of the graphical boot, the X server does not pop up. The system hangs indefinitely in this state, no virtual console is accessible, the computer is unusable. The keys still work (CAPSLOCK), so I can only restart it for another try via CTR+ALT+DEL.

Tried all three kernels - no change, the kernel 2.6.30.10-105.fc11 installed via updates with the KDE seems to be innocent.

Booting into runlevel 3 without problems. So it is the X server who is not starting properly. Strange, there was no Xorg package in the last yum update.

Version-Release number of selected component (if applicable):
kdm-4.3.4-1.fc11.i586                       (updated from 4.3.3-7.fc11)
xorg-x11-server-Xorg-1.6.4-0.1.fc11.i586    (was not updated)

How reproducible:

always with graphical boot (KMS with Radeon 9000)
note that I use sun-flare theme from F10

Steps to Reproduce:
1. normal (graphical) boot
2.
3.
  
Actual results:

system hangs

Excerpt from dmesg:
-------------begin
Dec 29 22:23:22 localhost kdm[3410]: X server startup timeout, terminating
Dec 29 22:23:22 localhost kdm[3410]: X server for display :0 cannot be started, session disabled
-------------end

Excerpt from Xorg.0.log
-------------begin
Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call
-------------end


Expected results:

Xserver starts, KDE session usable


Additional info:

I can get to KDE only by choosing textual boot (via cursor keys), in which case the KDE sits on virtual terminal 7. Not much, just a workaround.
Comment 1 Phillip Lynn 2009-12-30 07:44:07 EST
Linux plynn55 2.6.31.9-174.fc12.x86_64 #1 SMP Mon Dec 21 05:33:33 UTC 2009 x86_64 x86_64 x86_64 GNU/Linux

X.Org X Server 1.7.1
Release Date: 2009-10-23
X Protocol Version 11, Revision 0
Build Operating System:  2.6.18-164.2.1.el5
Current Operating System: Linux plynn55 2.6.31.9-174.fc12.x86_64 #1 SMP Mon Dec 21 05:33:33 UTC 2009 x86_64
Kernel command line: ro root=/dev/mapper/vg_plynn55-lv_root  LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb quiet
Build Date: 05 November 2009  07:43:10PM
Build ID: xorg-x11-server 1.7.1-7.fc12
Current version of pixman: 0.16.4
        Before reporting problems, check http://bodhi.fedoraproject.org/
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Dec 30 07:18:26 2009
(II) Loader magic: 0x7c8560
(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.4
        X.Org Video Driver: 6.0
        X.Org XInput driver : 7.0
        X.Org Server Extension : 2.0
(++) using VT number 7


Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call


Please consult the The X.Org Foundation support
         at http://bodhi.fedoraproject.org/
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.
"Xorg.0.log" 34L, 1321C


Asus Laptop Support 0.42
Model reference    : N71Vn
SFUN value         : 0x1a18f7
DSDT length        : 49602
DSDT checksum      : 38
DSDT revision      : 1
OEM id             : N71Vx
OEM table id       : N71Vx202
OEM revision       : 0x202
ASL comp vendor id : INTL
ASL comp revision  : 0x20051117


after yum update new kdm  on 12/29/09

kdm-4.3.4-3.fc12.x86_64
Comment 2 Rex Dieter 2009-12-30 11:35:46 EST
Looks like the same issue on f11 and f12, rebasing to f12.

bummer too, almost 2 weeks of sitting in testing repos, and now we see this. :(

How sure are each of you it's kde causing this?  and no other updates that came along with it?  (See /var/log/yum.log for details).
Comment 3 Rex Dieter 2009-12-30 11:35:54 EST
*** Bug 551344 has been marked as a duplicate of this bug. ***
Comment 4 Phillip Lynn 2009-12-30 11:51:30 EST
I am not sure what is causing this.  I am not able to get it go past the splash screen.  I am able to log in through ssh .  My last main updates were the kde updates.  just a couple of different from kde.
Comment 5 Phillip Lynn 2009-12-30 12:01:06 EST
my yum.log from Dec 29th...

Dec 29 06:59:23 Updated: libgpod-0.7.2-6.fc12.x86_64
Dec 29 06:59:35 Updated: oxygen-icon-theme-4.3.4-1.fc12.noarch
Dec 29 06:59:36 Updated: kde-settings-4.3-15.1.noarch
Dec 29 06:59:37 Updated: kde-settings-kdm-4.3-15.1.noarch
Dec 29 06:59:38 Updated: xdg-utils-1.0.2-16.20091217cvs.fc12.noarch
Dec 29 06:59:39 Updated: 6:kdelibs-common-4.3.4-3.fc12.x86_64
Dec 29 06:59:40 Updated: fprintd-0.1-16.git04fd09cfa.fc12.x86_64
Dec 29 06:59:40 Updated: ksysguardd-4.3.4-3.fc12.x86_64
Dec 29 06:59:41 Installed: pywebkitgtk-1.1.6-2.fc12.x86_64
Dec 29 06:59:44 Updated: parted-1.9.0-17.2.fc12.x86_64
Dec 29 06:59:45 Installed: python-beaker-1.3.1-6.fc12.noarch
Dec 29 06:59:45 Updated: fprintd-pam-0.1-16.git04fd09cfa.fc12.x86_64
Dec 29 06:59:47 Updated: gir-repository-0.6.5-3.fc12.x86_64
Dec 29 06:59:48 Installed: python-mako-0.2.4-3.fc12.noarch
Dec 29 07:00:03 Updated: rhythmbox-0.12.6-2.fc12.x86_64
Dec 29 07:00:04 Updated: kde-settings-pulseaudio-4.3-15.1.noarch
Dec 29 07:00:05 Updated: phonon-4.3.80-2.fc12.x86_64
Dec 29 07:00:13 Updated: 6:kdelibs-4.3.4-3.fc12.x86_64
Dec 29 07:00:15 Updated: kdepimlibs-4.3.4-1.fc12.x86_64
Dec 29 07:00:16 Updated: kdelibs-experimental-4.3.4-1.fc12.x86_64
Dec 29 07:00:18 Updated: PyKDE4-4.3.4-1.fc12.x86_64
Dec 29 07:00:19 Updated: 7:kdegraphics-libs-4.3.4-1.fc12.x86_64
Dec 29 07:00:20 Updated: 7:kdenetwork-libs-4.3.4-1.fc12.x86_64
Dec 29 07:00:21 Updated: 6:kdebase-libs-4.3.4-1.fc12.x86_64
Dec 29 07:00:22 Updated: kdepimlibs-akonadi-4.3.4-1.fc12.x86_64
Dec 29 07:00:25 Updated: 6:kdepim-libs-4.3.4-1.fc12.x86_64
Dec 29 07:00:26 Updated: 6:kdeutils-libs-4.3.4-2.fc12.x86_64
Dec 29 07:00:27 Updated: 6:kdegames-libs-4.3.4-1.fc12.x86_64
Dec 29 07:00:28 Updated: 6:kdemultimedia-libs-4.3.4-1.fc12.x86_64
Dec 29 07:00:35 Updated: 6:kdepim-4.3.4-1.fc12.x86_64
Dec 29 07:00:38 Updated: 6:kdeutils-4.3.4-2.fc12.x86_64
Dec 29 07:00:39 Updated: phonon-backend-xine-4.3.80-2.fc12.x86_64
Dec 29 07:00:40 Updated: 7:kio_msits-4.3.4-1.fc12.x86_64
Dec 29 07:00:42 Updated: 7:kdegraphics-4.3.4-1.fc12.x86_64
Dec 29 07:00:50 Updated: 6:kdegames-4.3.4-1.fc12.x86_64
Dec 29 07:00:56 Updated: 7:kdenetwork-4.3.4-1.fc12.x86_64
Dec 29 07:00:57 Updated: 2:phonon-backend-gstreamer-4.3.80-2.fc12.x86_64
Dec 29 07:00:58 Updated: 7:system-config-printer-kde-4.3.4-1.fc12.x86_64
Dec 29 07:00:58 Updated: 6:kdeutils-printer-applet-4.3.4-2.fc12.x86_64
Dec 29 07:01:00 Updated: kdebase-workspace-libs-4.3.4-3.fc12.x86_64
Dec 29 07:01:06 Updated: kdebase-runtime-4.3.4-2.fc12.x86_64
Dec 29 07:01:13 Updated: kdebase-workspace-4.3.4-3.fc12.x86_64
Dec 29 07:01:14 Updated: kdeedu-marble-libs-4.3.4-1.fc12.x86_64
Dec 29 07:01:15 Updated: kdeplasma-addons-libs-4.3.4-1.fc12.x86_64
Dec 29 07:01:16 Updated: 1:kdeaccessibility-libs-4.3.4-1.fc12.x86_64
Dec 29 07:01:17 Updated: kdebase-runtime-libs-4.3.4-2.fc12.x86_64
Dec 29 07:01:20 Updated: kdeplasma-addons-4.3.4-1.fc12.x86_64
Dec 29 07:01:22 Updated: 6:kdemultimedia-4.3.4-1.fc12.x86_64
Dec 29 07:01:23 Updated: kdeartwork-kxs-4.3.4-1.fc12.x86_64
Dec 29 07:01:28 Updated: 6:kdebase-4.3.4-1.fc12.x86_64
Dec 29 07:01:33 Updated: 1:kdeaccessibility-4.3.4-1.fc12.x86_64
Dec 29 07:01:35 Updated: kdeartwork-screensavers-4.3.4-1.fc12.x86_64
Dec 29 07:01:37 Updated: kdm-4.3.4-3.fc12.x86_64
Dec 29 07:01:37 Updated: kdebase-workspace-python-applet-4.3.4-3.fc12.x86_64
Dec 29 07:01:41 Updated: kdeedu-marble-4.3.4-1.fc12.x86_64
Comment 6 Jaroslav Franek 2009-12-30 12:18:14 EST
Rex, this is the list of packages from the update that caused the issue. Most of them are KDE 4.3.4. I have tried to boot previous kernels as well, no difference. Other packages look innocent to me, so the KDE was obvious to blame, but frankly, one can never be sure.

I have installed another notebook few days ago (Fedora 12) then updated as well at the same time as the unlucky Fedora 11 notebook, but no issue experienced.

On another desktop with Fedora 12 I am using updates-testing, and KDE 4.3.4 packages since they were introduced in the repo, and also no issue.

The 'lucky' machines have Nvidia cards driven by nouveau. The 'unlucky' notebook has Radeon card. Could it make a difference?

Also the 'unlucky' notebook has graphical boot modified:
# yum install plymouth-plugin-space-flares plymouth-theme-solar plymouth-utils
# plymouth-set-default-theme solar
# /usr/libexec/plymouth/plymouth-update-initrd


updated 2009-12-29, 21:54 CET

=========================================================================
 Package                         Version                 Repository
=========================================================================
Installing:
 kernel                          2.6.30.10-105.fc11      updates
 kernel-devel                    2.6.30.10-105.fc11      updates
Updating:
 NetworkManager-openconnect      0.7.2-1.fc11            updates
 NetworkManager-openvpn          1:0.7.2-1.fc11          updates
 NetworkManager-vpnc             1:0.7.2-1.fc11          updates
 PolicyKit-kde                   4.3.4-1.fc11            updates
 PyKDE4                          4.3.4-1.fc11            updates
 authconfig                      6.0.0-2.fc11            updates
 authconfig-gtk                  6.0.0-2.fc11            updates
 cacti                           0.8.7e-3.fc11           updates
 deltarpm                        3.5-0.4.20090913git.fc11.1     updates
 gkrellm                         2.3.3-1.fc11            updates
 kde-l10n                        4.3.4-1.fc11            updates
 kde-l10n-Czech                  4.3.4-1.fc11            updates
 kde-l10n-French                 4.3.4-1.fc11            updates
 kde-settings                    4.2-14                  updates
 kde-settings-kdm                4.2-14                  updates
 kde-settings-pulseaudio         4.2-14                  updates
 kde-style-phase                 4.3.4-1.fc11            updates
 kdeaccessibility                1:4.3.4-1.fc11          updates
 kdeaccessibility-libs           1:4.3.4-1.fc11          updates
 kdeadmin                        7:4.3.4-2.fc11          updates
 kdeartwork                      4.3.4-1.fc11            updates
 kdeartwork-kxs                  4.3.4-1.fc11            updates
 kdeartwork-screensavers         4.3.4-1.fc11            updates
 kdeartwork-sounds               4.3.4-1.fc11            updates
 kdeartwork-wallpapers           4.3.4-1.fc11            updates
 kdebase                         6:4.3.4-1.fc11          updates
 kdebase-devel                   6:4.3.4-1.fc11          updates
 kdebase-libs                    6:4.3.4-1.fc11          updates
 kdebase-runtime                 4.3.4-2.fc11            updates
 kdebase-runtime-libs            4.3.4-2.fc11            updates
 kdebase-workspace               4.3.4-1.fc11            updates
 kdebase-workspace-devel         4.3.4-1.fc11            updates
 kdebase-workspace-googlegadgets 4.3.4-1.fc11            updates
 kdebase-workspace-libs          4.3.4-1.fc11            updates
 kdebase-workspace-python-applet 4.3.4-1.fc11            updates
 kdebase-workspace-wallpapers    4.3.4-1.fc11            updates
 kdebindings                     4.3.4-1.fc11            updates
 kdebindings-devel               4.3.4-1.fc11            updates
 kdeedu                          4.3.4-1.fc11            updates
 kdeedu-devel                    4.3.4-1.fc11            updates
 kdeedu-kstars                   4.3.4-1.fc11            updates
 kdeedu-kstars-libs              4.3.4-1.fc11            updates
 kdeedu-libs                     4.3.4-1.fc11            updates
 kdeedu-marble                   4.3.4-1.fc11            updates
 kdeedu-marble-libs              4.3.4-1.fc11            updates
 kdeedu-math                     4.3.4-1.fc11            updates
 kdegames                        6:4.3.4-1.fc11          updates
 kdegames-devel                  6:4.3.4-1.fc11          updates
 kdegames-libs                   6:4.3.4-1.fc11          updates
 kdegraphics                     7:4.3.4-1.fc11          updates
 kdegraphics-devel               7:4.3.4-1.fc11          updates
 kdegraphics-libs                7:4.3.4-1.fc11          updates
 kdelibs                         6:4.3.4-3.fc11          updates
 kdelibs-common                  6:4.3.4-3.fc11          updates
 kdelibs-devel                   6:4.3.4-3.fc11          updates
 kdelibs-experimental            4.3.4-1.fc11            updates
 kdemultimedia                   6:4.3.4-1.fc11          updates
 kdemultimedia-devel             6:4.3.4-1.fc11          updates
 kdemultimedia-libs              6:4.3.4-1.fc11          updates
 kdenetwork                      7:4.3.4-1.fc11          updates
 kdenetwork-devel                7:4.3.4-1.fc11          updates
 kdenetwork-libs                 7:4.3.4-1.fc11          updates
 kdepim                          6:4.3.4-1.fc11          updates
 kdepim-devel                    6:4.3.4-1.fc11          updates
 kdepim-libs                     6:4.3.4-1.fc11          updates
 kdepim-runtime                  4.3.4-1.fc11            updates
 kdepim-runtime-libs             4.3.4-1.fc11            updates
 kdepimlibs                      4.3.4-1.fc11            updates
 kdepimlibs-akonadi              4.3.4-1.fc11            updates
 kdepimlibs-devel                4.3.4-1.fc11            updates
 kdeplasma-addons                4.3.4-1.fc11            updates
 kdeplasma-addons-libs           4.3.4-1.fc11            updates
 kdesdk                          4.3.4-1.fc11            updates
 kdesdk-libs                     4.3.4-1.fc11            updates
 kdesdk-utils                    4.3.4-1.fc11            updates
 kdetoys                         7:4.3.4-1.fc11          updates
 kdeutils                        6:4.3.4-1.fc11          updates
 kdeutils-libs                   6:4.3.4-1.fc11          updates
 kdeutils-printer-applet         6:4.3.4-1.fc11          updates
 kdm                             4.3.4-1.fc11            updates
 kernel-doc                      2.6.30.10-105.fc11      updates
 kernel-firmware                 2.6.30.10-105.fc11      updates
 kernel-headers                  2.6.30.10-105.fc11      updates
 kio_msits                       7:4.3.4-1.fc11          updates
 kmod-ndiswrapper                1.54-4.fc11.23          rpmfusion-free-updates
 kross-python                    4.3.4-1.fc11            updates
 ksysguardd                      4.3.4-1.fc11            updates
 libdvdread                      4.1.4-0.2.svn1188.fc11  updates
 libsidplay                      1.36.57-21.fc11         updates
 oxygen-icon-theme               4.3.4-1.fc11            updates
 pam                             1.0.91-9.fc11           updates
 pam-devel                       1.0.91-9.fc11           updates
 soprano                         2.3.1-1.fc11            updates
 sqlite                          3.6.20-1.fc11           updates
 sqlite-devel                    3.6.20-1.fc11           updates
 system-config-printer-kde       7:4.3.4-2.fc11          updates
 unzip                           5.52-11.fc11            updates
 viewvc                          1.1.3-1.fc11            updates
 vte                             0.20.5-2.fc11           updates
 xdg-utils                       1.0.2-16.20091217cvs.fc11      updates
Removing:
 kernel                          2.6.30.9-96.fc11        installed
 kernel-devel                    2.6.30.9-96.fc11        installed
Installing for dependencies:
 kmod-ndiswrapper-2.6.30.10-105.fc11.i586    1.54-4.fc11.23     rpmfusion-free-updates
Removing for dependencies:
 kmod-ndiswrapper-2.6.30.9-96.fc11.i586      1.54-4.fc11.20     installed

Transaction Summary
==========================================================================
Install       3 Package(s)
Upgrade     100 Package(s)
Remove        3 Package(s)
Reinstall     0 Package(s)
Downgrade     0 Package(s)
Comment 7 Rex Dieter 2009-12-30 12:20:41 EST
One interesting diagnostic would be to disable plymouth (not sure how best to do that... boot with nomodeset?).
Comment 8 Jaroslav Franek 2009-12-30 12:39:00 EST
some tips what to do with Plymouth:
https://fedoraproject.org/wiki/Features/BetterStartup#User_Documentation
Comment 9 Rex Dieter 2009-12-30 13:02:17 EST
Cool thanks.

For completeness, the change/patch in kdm and kde-settings was

in kde-4.3.3, kdm was hard-coded to use vt1 always, ie, /etc/kde/kdm/kdmrc contained
ServerVTs=1

in kde-4.3.4, kdm checks for plymouth, 
  * if found, checks and uses the current/active vt for launch (using the same code gdm uses for this purpose), in practice, the active vt is usually vt1.
  * if not found, falls back to using the first free vt, ie, /etc/kde/kdm/kdmrc contains:
ServerVTs=-1

One other small change which *may* affect things here was a change in /etc/kde/kdm/kdmrc from
ConsoleTTYs=tty2,tty3,tty4,tty5,tty6
to
ConsoleTTYs=tty1,tty2,tty3,tty4,tty5,tty6
Comment 10 Jaroslav Franek 2009-12-30 13:06:10 EST
Playing with Plymouth

Actual results:

rhgb  nomodeset     result
Y     N             issue, unless cancelling graphical boot -> KDE on tty7
Y     Y             no issue, KDE on tty7
N     Y             no issue, KDE on tty7
N     N             no issue, KDE on tty7


Expected results:

rhgb  nomodeset     result
Y     N             KDE on tty1
Comment 11 Martin Kho 2009-12-30 13:14:28 EST
Hi,

Jaroslav's 'lucky'machine is my 'unlucky' system. I've a nvidia card and the
nouveau driver running on stock/updated F12. So it looks like it has nothing to
do with used video card.

And yes, it seems that the latest kdm has some trouble with Plymouth. When I
press <esc> the plymouth splash screen will disappear and I get the kdm log in
screen.

Martin Kho
Comment 12 Jaroslav Franek 2009-12-30 13:39:46 EST
Reverting ConsoleTTYs made the issue even worse: black screen instead of KDE when not using Plymouth graphical boot, the same hang otherwise.

But ServerVTs looks more promissing. After reverting it back to ServerVTs=1, the issue disappeared (at least for me).

Could you guys try it as well?

I consider it a workaround. The issue is probably in the code changes between 4.3.3 and 4.3.4.
Comment 13 Anne 2009-12-30 13:50:14 EST
I reported a problem on-list 10 days ago, so these details are as I recall
them.  My symptoms seemed to agree with this description.  In my case I did an
update that pulled in only a couple of packages, IIRC, then ran pre-upgrade. 
As others report, the installation appeared to complete, but the reboot hung
without X - the splash screen had appeared, but the next stage didn't appear.

No-one mentioned Plymouth at that time, so I don't know whether that would have
helped.  I did try nomodeset, after trying all available kernels.  The only way
I could get anywhere was to do a level 3 boot.  This laptop has an ATi Mobility
Radeon X600, and was using the Radeon driver.  I didn't resolve the problem,
and after struggling for 24 hours+ I gave in and did a clean install.
Comment 14 Martin Kho 2009-12-30 14:07:00 EST
Hi,

At this moment I'm running rawhide. /etc/kde/kdm/kdmrc contains: ServerVTs=-1
and have no problems. I'll try with F12.

Martin Kho
Comment 15 Kevin Kofler 2009-12-30 14:13:28 EST
> Jaroslav's 'lucky'machine is my 'unlucky' system. I've a nvidia card and the
> nouveau driver running on stock/updated F12. So it looks like it has nothing to
> do with used video card.

It does. Only video cards with kernel modesetting (KMS) are affected as those are the ones where KDE should show up on tty1. (Oh fun, first X11 is broken for all non-KMS cards, now we just broke all KMS cards.)

The thing is, Nouveau supports KMS on F12, but not on F11.
Comment 16 Martin Kho 2009-12-30 14:14:38 EST
Hi,

Just tried F12, and I can confirm that ServerVTs=1 is a working workaround.

Martin Kho
Comment 17 Kevin Kofler 2009-12-30 14:15:06 EST
IMHO, we should restore ServerVTs=1, push the update directly to stable to fix the regression and reopen the "KDM always starts on tty1" bug, as that was clearly the lesser evil!
Comment 18 Rex Dieter 2009-12-30 14:18:48 EST
To followup comment #9 , one more kdmrc modification
changed
ServerArgsLocal=-br
to 
ServerArgsLocal=-nr

This is one area where kdm is different than gdm.  gdm *only* uses this flag when plymouth is used, we're using it inconditionally.
Comment 19 Kevin Kofler 2009-12-30 14:25:11 EST
@Anne: If nomodeset didn't help, it's not the same problem (unless you used it with some vga=… flag to force Plymouth).

As for the -nr flag, I don't think that's it.
Comment 20 Jaroslav Franek 2009-12-30 14:36:05 EST
Just a note to my 'lucky' notebook: I forgot I had edited kdmrc right after F12 installation, so the update only created kdmrc.rpmnew and I was still using ServerVTs=1 and ServerArgsLocal=-br. After trying ServerVTs=-1 with F12, it turned the notebook to 'unlucky' piece of garbage till proper restart.
Comment 21 Jani Averbach 2009-12-30 14:38:45 EST
Same problem here. The symptoms go away when I boot the system without rhgb.
(Bug 323501)

Below is the log from failed startup. I am using kdm.

X.Org X Server 1.7.1
Release Date: 2009-10-23
X Protocol Version 11, Revision 0
Build Operating System:  2.6.18-164.2.1.el5 
Current Operating System: Linux xxx.xxx.xxx.xxx 2.6.31.9-174.fc12.x86_64 #1 SMP
Mon Dec 21 05:33:33 UTC 2009 x86_64
Kernel command line: ro root=/dev/mapper/vg_os-lv_root  LANG=en_US.UTF-8
SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb quiet
Build Date: 05 November 2009  07:43:10PM
Build ID: xorg-x11-server 1.7.1-7.fc12 
Current version of pixman: 0.16.4
 Before reporting problems, check http://bodhi.fedoraproject.org/
 to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
 (++) from command line, (!!) notice, (II) informational,
 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Dec 30 21:15:26 2009
(II) Loader magic: 0x7c8560
(II) Module ABI versions:
 X.Org ANSI C Emulation: 0.4
 X.Org Video Driver: 6.0
 X.Org XInput driver : 7.0
 X.Org Server Extension : 2.0
(++) using VT number 7


Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call


Please consult the The X.Org Foundation support 
  at http://bodhi.fedoraproject.org/
 for help. 
Please also check the log file at "/var/log/Xorg.0.log" for additional
information.
Comment 22 Rex Dieter 2009-12-30 14:48:30 EST
Comment #15 is a bit of an overstatement, this doesn't break *all* kms cards.

-nr may have something to do with it, after reading the "pressing ESC allowed kdm to start normally" in comment #11 (or not). ??
Comment 23 Kevin Kofler 2009-12-30 15:01:56 EST
Have you tested it on a system with working Plymouth? Does it work on any of them?
Comment 24 Anne 2009-12-30 15:05:42 EST
@kevin: I'll try to look back at any notes I might still have, and report back
Comment 25 Rex Dieter 2009-12-30 15:09:38 EST
Re comment #23
Yes, tested, on my f12/x86_64 intel945/kms laptop
Comment 26 Jaroslav Franek 2009-12-30 15:13:02 EST
Few more reboots (with Plymouth graphical plugin):

ServerVTs=1 and ServerArgsLocal=-br         OK
ServerVTs=1 and ServerArgsLocal=-nr         OK
ServerVTs=-1 and ServerArgsLocal=-br        issue
ServerVTs=-1 and ServerArgsLocal=-nr        issue

So -nr has apparently no effect.

ad #25 Are you sure you was not 'lucky' the same way as me (edited kdmrc and then forgetting about kdmrc.rpmnew)?
Comment 27 Rex Dieter 2009-12-30 15:29:17 EST
are you *sure* you're using plymouth?  

I ask because kdm's code/patch here basically says:
if using plymouth, ignore ServerVTs and use the "active/current" vt.

So, if changing ServerVTs helps , something is amiss.
Comment 28 Rex Dieter 2009-12-30 15:35:32 EST
Re: comment #26,

try the combo of 
ServerVTs=-1
and remove tty1 from
ConsoleTTYs= 
?
Comment 29 Jaroslav Franek 2009-12-30 15:47:00 EST
Re: comment #27:

The comment #26 results were produced under the same settings: kernel cmd line includes rhgb (which means Plymouth, right?) and nouveau or radeon implement KMS, hence there was some king of graphics (it is plymouth-theme-charge for F12 and plymouth-theme-solar for my F11). I have enjoyed a lot of Sun flares and charging animations during the endless reboots :-) Still in doubts?

Re: comment #28:

Oki, my notebook is going to love me, rebooting again...
Comment 30 Jaroslav Franek 2009-12-30 15:57:58 EST
Actually, it was without tty1. So I have added it and got no improvement. As a last resort I have dropped my kdmrc and copied kdmrc.rpmnew into his place to get clean configuration. No help though; It stuck as well.
Comment 31 Brad Hards 2009-12-30 18:24:51 EST
I'm also seeing this problem on Fedora 12.

The hardware is
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
        Subsystem: Dell Device 02ac                                                                                                        
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+                              
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-                               
        Latency: 0                                                                                                                         
        Interrupt: pin A routed to IRQ 27                                                                                                  
        Region 0: Memory at fe400000 (64-bit, non-prefetchable) [size=4M]                                                                  
        Region 2: Memory at d0000000 (64-bit, prefetchable) [size=256M]                                                                    
        Region 4: I/O ports at dc00 [size=8]                                                                                               
        Expansion ROM at <unassigned> [disabled]                                                                                           
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-                                                                         
                Address: fee0c00c  Data: 4199                                                                                              
        Capabilities: [d0] Power Management version 2                                                                                      
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)                                                 
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-                                                                     
        Capabilities: [a4] PCI Advanced Features                                                                                           
                AFCap: TP+ FLR+                                                                                                            
                AFCtrl: FLR-                                                                                                               
                AFStatus: TP-                                                                                                              
        Kernel driver in use: i915                                                                                                         
        Kernel modules: i915                                                                                                               

00:02.1 Display controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
        Subsystem: Dell Device 02ac                                                                   
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx- 
        Latency: 0                                                                                           
        Region 0: Memory at fe800000 (64-bit, non-prefetchable) [size=1M]                                    
        Capabilities: [d0] Power Management version 2                                                        
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)                   
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME

Will attach the X log.
Comment 32 Brad Hards 2009-12-30 18:27:31 EST
Created attachment 381025 [details]
Xorg.0.log matching comment #31

I don't see that same failed syscall though. Potentially this is a variation on the same issue.
Comment 33 Jani Averbach 2009-12-30 23:35:32 EST
I tried few different combos, actual results are below, 
but the short summary is that I have similar results than comment #26, #28 and #30

ServerLocalArgs=-br|-nr,  no effect
ServerVTs=1 , fixes problem
removing rhgb, fixes problem

Forgot from my comment #21: This is up a to date F12/x86_64 laptop, with intel graphics:
PCI:*(0:0:2:0) 8086:2a02:17aa:20b5 Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller rev 12

Test Results:
--------------------------------------------------------------
status: not working
rhgb enabled
ServerVTs=-1
ConsoleTTYs=tty1,tty2,tty3,tty4,tty5,tty6
ServerArgsLocal=-nr -nolisten tcp
Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

status: not working
rhgb enabled
ServerVTs=-1
ConsoleTTYs=tty2,tty3,tty4,tty5,tty6
ServerArgsLocal=-nr -nolisten tcp
Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

status: not working
rhgb enabled
ServerVTs=-1
ConsoleTTYs=tty2,tty3,tty4,tty5,tty6
ServerArgsLocal=-br -nolisten tcp
Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

status: OK
rhgb disabled
ServerVTs=-1
ConsoleTTYs=tty1,tty2,tty3,tty4,tty5,tty6
ServerArgsLocal=-nr -nolisten tcp

status: OK
rhgb enabled
ServerVTs=1
ConsoleTTYs=tty2,tty3,tty4,tty5,tty6
ServerArgsLocal=-br -nolisten tcp

status: OK
rhgb enabled
ServerVTs=1
ConsoleTTYs=tty2,tty3,tty4,tty5,tty6
ServerArgsLocal=-nr -nolisten tcp

status: OK
rhgb enabled
ServerVTs=1
ConsoleTTYs=tty1,tty2,tty3,tty4,tty5,tty6
ServerArgsLocal=-nr -nolisten tcp
Comment 34 Armands Liepins 2010-01-01 18:13:10 EST
Btw, I downgraded to kdm-4.3.2-1.fc12.i686 when updated kdm refused to start and this did not fixed the problem. This is because /etc/kde/kdmrc now is from updated one. My kdmrc contains:

ServerVTs=-1
ConsoleTTYs=tty1,tty2,tty3,tty4,tty5,tty6
ServerArgsLocal=-nr -nolisten tcp

If I exit plymouth with ESC or boot without rhgb, kdm starts. On VT7.
Comment 35 Rex Dieter 2010-01-03 09:54:30 EST
Symptoms smell a lot like past kdm/rhbg bug #323501 , pinging plymouth folks for comment/feedback.
Comment 36 peter 2010-01-04 15:39:08 EST
Hello,

I made an update to the latest version of KDE 4.3.4 and the kernel 2.6.31.9-174.fc12.x86_64 yesterday. When I rebooted the system login was no possible because kdm didn't start. Same symptoms like Jaroslav discribed. 
I'm using GeForce 7300 GS/PCI/SSE2 2.1.2 NVIDIA 190.42, 
X-Org Vers.:10,701,000 11.0
Now I removed the entry "vga=0x318" to desable Plymouth from /boot/grub/grub.conf.
KDM starts again.
At the weekend I updated two other systems. One of them fc12 x86 with nouveau driver made no trouble. Also fc11 x86_64 with nvidia 6-* no problem. I have no idea.
Comment 37 Thomas Janssen 2010-01-04 15:56:15 EST
(In reply to comment #36)
> Hello,
> 
> I made an update to the latest version of KDE 4.3.4 and the kernel
> 2.6.31.9-174.fc12.x86_64 yesterday. When I rebooted the system login was no
> possible because kdm didn't start. Same symptoms like Jaroslav discribed. 
> I'm using GeForce 7300 GS/PCI/SSE2 2.1.2 NVIDIA 190.42, 
> X-Org Vers.:10,701,000 11.0
> Now I removed the entry "vga=0x318" to desable Plymouth from
> /boot/grub/grub.conf.

Well, vga= forces a resolution. Removing that doesn't disable Plymouth. The difference is, with that forced reso you have the full glory of plymouth and without you get the tricolor.

> KDM starts again.

Would be interesting if you're able to reproduce it by adding the vga= option again. And as well, is that with the nvidia binary driver from rpmfusion or directly from nvidia.com.




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 38 Jaroslav Franek 2010-01-04 16:08:18 EST
Re comment #36:

No problem on fc11 is probably due to the fact that nouveau does not support KMS (kernel mode settings) there, and the issue is pertinent to KMS, see comment #10 nomodeset=Y.

On Fedora 12, please look at /etc/kde/kdm/kdmrc file for ServerVTs entry. If the line reads ServerVTs=-1 and you use graphical boot theme (rhgb + plymouth plugin, usually plymouth-theme-charge), you shall experience the issue. If not, you get lucky, and I or somebody else might have more questions...

I was speaking previously of two my 'lucky' systems, but one of them run with original kdmrc (the update only created kdmrc.rpmnew, I did not noticed, so the issue was averted). The other system, though updated weeks ago from updates-testing never experienced the issue since KMS does not work properly (another bug report) so there is nomodeset in kernel parameters to force UMS. Otherwise I would have reported weeks ago while still at testing. Life is full of nasty ways to get pass the real issues and let them strike at full on unsuspecting users.
Comment 39 Jaroslav Franek 2010-01-04 16:11:41 EST
sorry, with comment #10 I meant nomodeset=N
Comment 40 peter 2010-01-04 17:16:53 EST
(In reply to comment #37)
> (In reply to comment #36)
> > Hello,
> > 
> > I made an update to the latest version of KDE 4.3.4 and the kernel
> > 2.6.31.9-174.fc12.x86_64 yesterday. When I rebooted the system login was no
> > possible because kdm didn't start. Same symptoms like Jaroslav discribed. 
> > I'm using GeForce 7300 GS/PCI/SSE2 2.1.2 NVIDIA 190.42, 
> > X-Org Vers.:10,701,000 11.0
> > Now I removed the entry "vga=0x318" to desable Plymouth from
> > /boot/grub/grub.conf.
> 
> Well, vga= forces a resolution. Removing that doesn't disable Plymouth. The
> difference is, with that forced reso you have the full glory of plymouth and
> without you get the tricolor.
> 
> 
> > KDM starts again.
> 
> Would be interesting if you're able to reproduce it by adding the vga= option
> again. And as well, is that with the nvidia binary driver from rpmfusion or
> directly from nvidia.com.
> 
> Hello,

< Well, vga= forces a resolution. Removing that doesn't disable Plymouth. The
difference is, with that forced reso you have the full glory of plymouth and
without you get the tricolor.> 

I thougt, because the vga resolution shows the exploding sun theme and non vga option shows the loading line from left to right.
 
< Would be interesting if you're able to reproduce it by adding the vga= option
again. And as well, is that with the nvidia binary driver from rpmfusion or
directly from nvidia.com. >

I added the vga= option again and the system hung. So I removed it again. (Install DVD) I installed the nvidia binary driver from rpmfusion.
> 
> -- 
> Fedora Bugzappers volunteer triage team
> https://fedoraproject.org/wiki/BugZappers
Comment 41 Kevin Kofler 2010-01-05 08:51:00 EST
> Well, vga= forces a resolution. Removing that doesn't disable Plymouth.

vga= also enables the graphical Plymouth for drivers without KMS (or with nomodeset).
Comment 42 Rex Dieter 2010-01-05 10:54:09 EST
In a meeting this morning, we discovered an error in kdm packaging not owning /var/spool/gdm, which could cause even kms drivers to end up doing a needless vt switch.

(fixing this won't help any non-kms folks though)
Comment 43 Martin Kho 2010-01-05 11:11:05 EST
Hi,

Don't know if it's relevant, but on my F12 install I don't have /var/spool/gdm. gdm isn't installed.

Martin Kho
Comment 44 Fedora Update System 2010-01-05 11:39:25 EST
kde-settings-4.3-15.2 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/kde-settings-4.3-15.2
Comment 45 Fedora Update System 2010-01-05 11:40:01 EST
kde-settings-4.2-14.1 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/kde-settings-4.2-14.1
Comment 46 Jaroslav Franek 2010-01-05 11:57:28 EST
Neither I had the gdm installed (nor I plan to). But the non-existence of the file was probably the cause of the issue.

Tested (F12 only)
kde-settings-4.3-15.2.noarch.rpm
kde-settings-kdm-4.3-15.2.noarch.rpm
kde-settings-pulseaudio-4.3-15.2.noarch.rpm
with graphical Plymouth boot + KMS + ServerVTs=-1 and the result is success. I got the KDE login screen on terminal 1.

Good work guys, thanks.

There was only a glitch between plymouth and Xserver - garbage shown on the screen for about a second. But this is probably some other issue...
Comment 47 Martin Kho 2010-01-05 12:15:22 EST
Hi,

Confirm, fix works. Congrats!

Btw. Is the fix not a design failure in Plymouth?


Martin Kho
Comment 48 Rex Dieter 2010-01-05 12:30:30 EST
If the updated kde-settings-kdm fixes the issue for you, then it was just a packaging oversight on my part in implementing the integration properly (I inadvertantly tested everything on a box that had gdm installed).
Comment 49 Kevin Kofler 2010-01-05 12:40:37 EST
> There was only a glitch between plymouth and Xserver - garbage shown on the
> screen for about a second. But this is probably some other issue...

We tell X11 not to blank the screen because what Plymouth displays should be kept, if the driver is displaying garbage instead, that sounds like a driver issue.
Comment 50 Martin Kho 2010-01-05 13:02:09 EST
Re Comment #48

Ok, I understand :-) Thanks again.

Martin Kho
Comment 51 peter 2010-01-05 13:44:44 EST
I have updated kde-settings too from:
http://admin.fedoraproject.org/updates/kde-settings-4.3-15.2  
and it was successfull. I added the vga=0x318 option again to /boot/grub/grub.conf and the system starts as usual. Great job!
Comment 52 Sammy 2010-01-06 09:52:09 EST
I am sufffering a similar problem (perhaps the same) since upgrading to
KDE-4.3.4 on my Lenovo T61 laptop with nvidia 140m card and using binary
nvidia drivers. I am at Fedora 11 with all the updates and updates-testing
packages.

I do not have gdm installed and I do not have anything on the kernel boot
line.

The symptom is that kdm login works fine but if I choose shutdown or logout
and end up with a black (or dark purple!) screen and non functioning keyboard.
Only way to get out is to hold down the power button.

The same identical setup on my desktop machines, with the same nvidia
drivers, same packages, same kdmrc etc. works just fine with NVS290 card.

I tried all the remedies I could think of and find in news groups like
this one. Any suggestions woulf be appricated.
Comment 53 Sammy 2010-01-07 09:07:32 EST
Wrong diagnosis. I identified xorg-x11-drv-synaptics-1.1.3-2.fc11.x86_64
as the culprit leading to a crash every time for the above system. The
changelog of the -2 release says:

"synaptics-1.1.3-timer-fix.patch: Don't free the timer in DeviceOff, 
 since that happens on VT switch. (#540248)"

Since this update was around the time of the KDE-4.3.4 update I confused it
with this bug. I have made a comment to the synaptics bug mentioned above.
Thanks
Comment 54 Alan Lehman 2010-01-10 14:39:19 EST
Just updated my Fedora 12 (Xen guest on RHEL5 host) and started seeing this error. 
kernel 2.6.31.9-174.fc12.x86_64
xorg-x11-server-Xorg-1.7.1-7.fc12.x86_64

I updated kde-settings too from:
http://admin.fedoraproject.org/updates/kde-settings-4.3-15.2  
and it was successful.
Comment 55 Thomas Janssen 2010-01-12 06:15:13 EST
*** Bug 554480 has been marked as a duplicate of this bug. ***
Comment 56 Jimmy Wilson 2010-01-12 10:51:14 EST
I can confirm that the RPM described in Alan's comment on 1/10/2010 also fixed my problem (Bug 554480).
Comment 57 Fedora Update System 2010-01-12 18:28:23 EST
kde-settings-4.3-15.2 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 58 Fedora Update System 2010-01-12 18:53:29 EST
kde-settings-4.2-14.1 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 59 Anthony Messina 2010-01-18 23:32:06 EST
(In reply to comment #57)
> kde-settings-4.3-15.2 has been pushed to the Fedora 12 stable repository.  If
> problems still persist, please make note of it in this bug report.    

I confirm the version above fixes the problem.

Note You need to log in before you can comment on or make changes to this bug.