Bug 55135 - vncserver fails to start at boot
Summary: vncserver fails to start at boot
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vnc (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 58046 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-26 01:51 UTC by Bruce Friedman
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-28 17:59:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bruce Friedman 2001-10-26 01:51:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
On a clean 7.2 system running as a server, I am seeing vncserver fail to 
start at boot because it is leaving behind /tmp/.X11-unix/X1 from the 
previous execution which prevents any subsequent starts from working.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Manually delete /tmp/.X11-unix/X1; issue "/etc/rc.d/init.d vncserver 
start"
2.shut down system "shutdown -r now"
3.Check /var/log/messages at boot to see vncserver start failure.
	

Actual Results:  You will see the following entries in /var/log/messages:

Oct 25 20:12:27 dilbert vncserver: Starting VNC server: 1:root
Oct 25 20:12:27 dilbert su(pam_unix)[1112]: session opened for user root 
by (uid
=0)
Oct 25 20:12:28 dilbert su:
Oct 25 20:12:28 dilbert su: Warning: dilbert.valuepcnet.com:1 is taken 
because o
f /tmp/.X11-unix/X1
Oct 25 20:12:28 dilbert su(pam_unix)[1112]: session closed for user root
Oct 25 20:12:28 dilbert su: Remove this file if there is no X server 
dilbert.val
uepcnet.com:1
Oct 25 20:12:28 dilbert su: A VNC server is already running as :1
Oct 25 20:12:28 dilbert vncserver:
Oct 25 20:12:28 dilbert vncserver: Warning: dilbert.valuepcnet.com:1 is 
taken be
cause of /tmp/.X11-unix/X1
Oct 25 20:12:28 dilbert vncserver: Remove this file if there is no X 
server dilb
ert.valuepcnet.com:1
Oct 25 20:12:28 dilbert vncserver: A VNC server is already running as :1
Oct 25 20:12:28 dilbert vncserver: vncserver start failed
Oct 25 20:12:28 dilbert vncserver:
Oct 25 20:12:28 dilbert rc: Starting vncserver:  failed


Expected Results:  vncserver should succeed in starting

Additional info:

Comment 1 Tim Waugh 2001-10-26 10:18:44 UTC
After 'echo -n "${display} "' I will add this to the initscript:

  rm -f "/tmp/.X11-unix/${display%%:*}"



Comment 2 Tim Waugh 2001-10-26 10:19:51 UTC
Ahem, I mean 'rm -f "/tmp/.X11-unix/X${display%%:*}"'.


Comment 3 Tim Waugh 2001-10-27 22:28:43 UTC
Actually, I won't add that line.  The underlying problem is that Xvnc is 
crashing before removing that file when the service is stopped.  I am testing 
a fix.


Comment 4 Tim Waugh 2001-11-04 10:20:37 UTC
Fixed in 3.3.3r2-21.


Comment 5 Tim Waugh 2002-01-07 10:28:57 UTC
*** Bug 58046 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.