Bug 55140 - init.d/pppoe, adsl-setup, man5/pppoe.conf.5 are missing from rp-pppoe
init.d/pppoe, adsl-setup, man5/pppoe.conf.5 are missing from rp-pppoe
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rp-pppoe (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Aaron Brown
:
: 55209 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-26 02:32 EDT by Russell Stuart
Modified: 2007-04-18 12:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-02 05:29:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Stuart 2001-10-26 02:32:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.17-14.ext3 i686)

Description of problem:
I assume this is a mistake.  The usr/sbin/adsl-setup script and
man5/pppoe.conf.5.gz files are missing from rp-pppoe-3.2-3.i386.rpm.  They
were in rp-pppoe-2.6-5 shipped with 7.1.  They are also in the rp-ppoe-3.3
rpm on the roaringpenguin web site.

adsl-connect requires pppoe.conf, so not shipping any doco about it makes
the thing unusable.

You also don't ship etc/rc.d/init.d/pppoe.  Again it is in all the other
versions.


Version-Release number of selected component (if applicable):
rp-pppoe-3.2-3.i386.rpm

How reproducible:
Always

Steps to Reproduce:
rpm -q -l -p rp-pppoe-3.2-3.i386.rpm

Actual Results:  A list of files.


Expected Results:  These files weren't in the list (taken from rp-pppoe-2.6
shipped with 7.1):
/etc/rc.d/init.d/pppoe
/etc/ppp/pppoe.conf
/usr/share/man/man5/pppoe.conf.5.gz
/usr/share/doc/rp-pppoe-2.6/CHANGES
/usr/share/doc/rp-pppoe-2.6/HOW-TO-CONNECT
/usr/share/doc/rp-pppoe-2.6/LICENSE
/usr/share/doc/rp-pppoe-2.6/README
/usr/share/doc/rp-pppoe-2.6/README_T-DSL

Additional info:
Comment 1 Michael Schwendt 2001-10-26 04:48:37 EDT
Some food for thought is in the spec file:

  # remove some stuff, Users should use netconf to setup xDSL
connection          
  rm -f $RPM_BUILD_ROOT%{_sbindir}/adsl-setup
\                                   
        $RPM_BUILD_ROOT%{_mandir}/man8/adsl-setup*
\                              
       
$RPM_BUILD_ROOT%{_mandir}/man5/pppoe.conf*                                
                                                                                
I don't like it when documentation is removed.
Comment 2 Ngo Than 2001-10-26 09:46:20 EDT
adsl-setup and pppoe.conf are obsolete in RHL 7.2. It does not make sense to
include them in package.

The only tool to setup DSL connection is redhat-config-network.
Comment 3 Michael Schwendt 2001-10-26 23:52:53 EDT
> The only tool to setup DSL connection is redhat-config-network.

Am I right that this tool is GUI-only? Does that mean, I have to keep XFree86
libs on a remote router just to be able to connect to a remote display in order
to configure rp-pppoe?
Comment 4 Russell Stuart 2001-10-28 16:21:41 EST
Having an alternet config tool is a good reason not to distribute the adsl-
setup.  It is a not a good reason for deleting doco on the config file.  (I 
presume it is still used by redhat-config-network.)  As it happens I am setting 
up a router that does not have X installed, so redhat-config-network is not 
available to me.  I am happy enough to edit the config file directly on a 
router, but it is a bit difficult with neither doco nor an example!

Also, you have removed the HOW-TO-CONNECT in /usr/share/doc/rp-pppoe-.../.  
That's fine, but putting a short note in there saying something like "under 
redhat pppoe is now configured using netconf" would have sayed me some time.  
And why remove the change log (doc/.../CHANGES)?
Comment 5 Josi Romildo Malaquias 2001-10-29 06:53:14 EST
I second the concerns about making a GUI application the only tool
to setup DSL conncection. Also bad was the dropping of documentation
from the rp-pppoe package. Yet no new documentation on how the new
setup works was added.

Now ads-status (and companion tools) does not work out of the box
(that is, without any arguments), given an error message:

# adsl-status
/usr/sbin/adsl-status: Cannot read configuration file '/etc/ppp/pppoe.conf'
Comment 6 Andreas Thienemann 2001-10-29 07:16:20 EST
I have to admit not being happy at all with the current redhat-config-network
tool being used to setup ADSL.

I do not want to have all the different pygnome libraries and a full
gtk-installation just to be able to setup an ADSL connection.

As long as /usr/share/doc/rp-pppoe or /usr/share/doc/initscripts-x.x/ contains
an example configuration and/or documentation I'd be happy with the current
situation.

If not, I'd like to see an ncurses-based *TEXT-MODE* utility to configure the
ifcfg-ppp0 script.
Comment 7 Todd Tibbetts 2001-10-29 07:59:21 EST
I agree that this is a bug.  Upgrading from RH 7.1 to 7.2 made my DSL stop 
working.  I had to resort to Windows to connect to the internet and search 
for info on what had happened.  I eventually figured out that init.d/pppoe, 
adsl-setup were missing and that my pppoe.conf file had been deleted.  No 
information was given in the upgrade to warn me that this was going to 
happen, and no obvious solution was evident.  I eventually "fixed" the 
problem by copying said files from another system that I had not upgraded 
yet.  

Regardless of whether you are moving to a new configuration utility, the 
upgrade process should not break an existing installation without at least 
explaining what the new configuration utility is and perhaps even migrating 
the settings.  Just deleting the config file without asking is unacceptable.
Comment 8 Bill Nottingham 2001-10-29 14:29:00 EST
*** Bug 55209 has been marked as a duplicate of this bug. ***
Comment 9 Need Real Name 2001-11-22 09:03:18 EST
This IS a bug.  One of the great strengths of Linux is I don't need a GUI to
make a perfectly usable server or firewall.  Another great thing is the large
amount of useful documentation available on-line in man pages etc.  I suggest
you put depreciated or distribution-incompatible components out of the way, so
someone would have to search for them (and find the README.redhat at the same
time).

Please don't take lightly any decision to remove traditional and text-mode
functionality and documentation!  Some of us need that stuff from time to time!
Comment 10 DIanne Skoll 2001-11-23 08:28:20 EST
I believe this really is a bug.  I know rp-pppoe is GPL'd, but I think it's
vital that Red Hat leaves some decent option for non-graphical configuration. 
It would also be courteous on their part to inform me (the rp-pppoe author) of
major changes like this, because I get many questions and bug reports about the
Red Hat version, and it was not until fairly recently that I realized the bug
reports were due to Red Hat's changes.

--
David F. Skoll
Comment 11 Ngo Than 2001-11-24 06:29:02 EST
I will fixed adsl-setup so that it should work with ifup and ifdown. The new
adsl-setup will save pppoe config
in /etc/sysconfig/network-scripts/ifcfg-pppX instead /etc/ppp/pppoe.conf.

I don't want include /etc/ppp/pppoe.conf /etc/init.d/pppoe in rp-pppoe package,
because it will confuse with 2 pppoe config files. It's bad!

To start/stop pppoe the user should run ifup/ifdown or /etc/init.d/network
start/stop.

I hope it's a fix for this problem for you.
Comment 12 DIanne Skoll 2001-11-24 21:13:04 EST
I downloaded the Red Hat version of rp-pppoe, and it strikes me that some of the
changes are rather gratuitious, especially this one:

 # If DNSTYPE is SERVER, we must use "usepeerdns" option to pppd.
 if test "$DNSTYPE" = "SERVER" ; then
-       USEPEERDNS=yes
+       PEERDNS=yes
 fi

That kind of thing just makes my life harder.  I've now put a notice on my Web
site that I will not offer technical support unless people run the original
version downloaded from my site.  Red Hat is obviously free to do what it wants,
but you're on your own as far as support goes now.

--
David.
Comment 13 Michael Schwendt 2001-11-24 22:07:00 EST
PEERDNS is also used in Red Hat Linux /etc/sysconfig/network-scripts/ which
explains that change with regard to integrating rp-pppoe scripts.

But the primary reason of this bug report should not be forgotten. It is bad
when original documentation files (such as man pages) and config scripts are
removed because a GUI-only config tool is available, and when there is not even
a short README which explains this.
Comment 14 Russell Stuart 2001-11-25 16:57:01 EST
/etc/ppp/pppoe.conf contains a lot of documentation, as did many of the other 
files you removed.  Without that doco the rp-pppoe package is hard 
(impossible?) to use on a non-gui system.  The easiest solution under those 
circumstances is to delete the RH 7.2 rpm and install the rpm on the roaring 
penguin site.  I did not like having to do that and I guess most others dont 
as well.

You could of avoided much of this agro by making it much easier to use the new 
system instead of the old, but still leaving the old system mostly intact for a 
couple of releases.  In the next release of the rpm why not do this:

  1.  Add a Readme to /usr/share/doc/rp-pppoe that explains how to configure 
the thing using the new system.
  2.  Move the doco that explained how to configure the package in the old way 
to /usr/share/rp-pppoe-.../old_config/.
  3.  For files like /etc/ppp/pppoe.conf, create them under a new name 
like "/etc/ppp/pppoe.conf.obselete", and put a comment at the top explaining 
where to find doco on how to use the new system.
  4.  If you don't want to do that for some files (such 
as /etc/rc.d/init.d/pppoe), put them under /usr/share/doc/rp-pppoe-
.../old_config/.

The old pppoe system did not integrate with the RH networking at all and that 
was a problem.  I am sure the new system fixes that, but until I have the tools 
and/or the doco to use it on a text only setup I won't be using it.  And by 
doco I mean the stuff under /usr/share/man or /usr/share/doc, not some chapter 
in a RH manual.

When you have that in place by all means remove the old system ...

Comment 15 darkeye 2001-12-02 05:29:55 EST
I just want to aggree that having a GUI-only configuration method is _bad_.
I also had the experience when upgrading from 7.1 to 7.2 that I couldn't connect
to my ADSL connection. And guess what: the GUI-based wonder didn't work either
(it did not recognize the type of ethernet card to use).

With the old adsl-setup and adsl-connect, all worked fine.

"Don't fix what is not broken"

And I also resent the idea to have a GUI-only solution, when there was a nice
and clean CLI solution. Can't these live side by side?
Comment 16 Ngo Than 2001-12-17 05:54:16 EST
It's fixed in rp-pppoe-3.3-3. This release rpm includes man pages and
adsl-scripts, which are adapted for RHL (for example pppoe.conf -> ifcfg-pppX,
adsl-setup writes config file in /etc/sysconfig/network-scripts/ifcfg-ppp0)


Note You need to log in before you can comment on or make changes to this bug.