This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 55143 - rpm ignoring noscripts option
rpm ignoring noscripts option
Status: CLOSED DUPLICATE of bug 51108
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-26 04:48 EDT by Neil Forsyth
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-26 04:48:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neil Forsyth 2001-10-26 04:48:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.16-3 i686)

Description of problem:
I often install RealPlayer from the RPM as part of a setup script.
I don't want to start and register it so I use the --noscripts
option to rpm. The latest version of rpm that comes with RH7.2 just ignores
this flag.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm --noscripts -Uvh rp8_linux20_libc6_i386_cs2.rpm
2.
3.
	

Actual Results:  The postinstall.sh script from the rpm is run.

Expected Results:  The package should be installed and no scripts run.
(I can then modify the postinstall.sh script to register MIME
types but not run RealPLayer)

Additional info:

This works OK in RH7.1
Comment 1 Jeff Johnson 2001-10-26 08:54:45 EDT
Yup. The mode needs to be first, before --noscripts.
This is gonna be needed to support multimode command
line operations in the future.

*** This bug has been marked as a duplicate of 51108 ***

Note You need to log in before you can comment on or make changes to this bug.