Bug 51108 - --nodeps is position sensitive, needs rpm mode first
Summary: --nodeps is position sensitive, needs rpm mode first
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 53703 55143 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-07 12:36 UTC by Tim Waugh
Modified: 2007-04-18 16:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-02 19:16:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Waugh 2001-08-07 12:36:52 UTC
Description of Problem:
Both --nodeps and --force are broken.

How Reproducible:
100%

Steps to Reproduce:
1. Try to downgrade a package or remove a package that has dependencies.

Actual Results:
Fails.

Expected Results:
Should succeed.

Additional Information:

Comment 1 Jeff Johnson 2001-08-07 12:46:28 UTC
Multimode options like --nodeps became single mode
sometime after rpm-4.0.3-0.57 for a while. This is fixed
in the latest (since -0.79 anyways) rpm builds.

I'm assuming that's the problem. If not, please reopen with
an explicit rpm package version-release and I'll take a
look.

Comment 2 Tim Waugh 2001-08-07 12:54:09 UTC
[root@cyberelk root]# rpm -q rpm
rpm-4.0.3-0.84
[root@cyberelk root]# rpm --nodeps -e eel
error: removing these packages would break dependencies:
        eel >= 1.0.1-10 is needed by nautilus-1.0.4-24
        libeel.so.0   is needed by nautilus-1.0.4-24


Comment 3 Jeff Johnson 2001-08-07 13:18:46 UTC
Hmmm, this works for me
	rpm -e popt --nodeps
but this does not
	rpm --nodeps -e popt
There's a sanity check that's gone awry ...

Comment 4 Jeff Johnson 2001-09-16 13:27:07 UTC
*** Bug 53703 has been marked as a duplicate of this bug. ***

Comment 5 Jeff Johnson 2001-10-26 12:54:39 UTC
*** Bug 55143 has been marked as a duplicate of this bug. ***

Comment 6 Craig Kelley 2001-10-29 23:22:08 UTC
This is a very nasty bug.  My development server is offline until its fixed. 
Should I get rpm from rpm.org and manually build it, or is there going to be a
fix soon?

Comment 7 Craig Kelley 2001-10-29 23:24:54 UTC
Ahh, I just changed the order of my args and it worked -- no urgency, just
annoying now.  :)

Comment 8 Dan Anderson 2001-11-02 19:16:01 UTC
This also applies to the --force option, and probably other options.

Comment 9 Jeff Johnson 2002-08-07 20:02:03 UTC
Options are no longer position sensitive with mode needed
first in rpm-4.1.


Note You need to log in before you can comment on or make changes to this bug.