Bug 55171 - installer loads wrong i2o module
installer loads wrong i2o module
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
: 55088 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-26 11:52 EDT by Gert Dewit
Modified: 2007-04-18 12:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-30 15:27:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kudzu-0.99.23-1 pcitable patch (596 bytes, patch)
2001-10-26 11:54 EDT, Gert Dewit
no flags Details | Diff
patch to add adaptec i2o RAID module to anaconda module-info (265 bytes, patch)
2001-10-27 05:10 EDT, Gert Dewit
no flags Details | Diff

  None (edit)
Description Gert Dewit 2001-10-26 11:52:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.10-ac10 i686)

Description of problem:
because of a wrong mapping in the kudzu pcitable file the installer loads
the i2o_block module instead of dtp_i2o for an adaptec 2100S RAID
controller.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
just try to install on a system with an Adaptec 2100S RAID controller
and no other disks

Additional info:

this is a diff -Nu patch for /usr/share/kudzu/pcitable, I'll add it as an
attachment also

--- /usr/share/kudzu/pcitable	Thu Sep  6 23:50:34 2001
+++ pcitable	Fri Oct 26 16:59:47 2001
@@ -587,7 +587,7 @@
 0x1044	0x1012	"unknown"	"Distributed Tech|Domino RAID Engine"
 0x1044	0xa400	"eata"	"Distributed Tech|SmartCache/Raid I-IV Controller"
 0x1044	0xa500	"ignore"	"Distributed Tech|PCI Bridge"
-0x1044	0xa501	"i2o_block"	"Distributed Tech|SmartRAID V Controller"
+0x1044	0xa501	"dpt_i2o"	"Distributed Tech|SmartRAID V Controller"
 0x1045	0xa0f8	"unknown"	"OPTi Inc.|82C750 [Vendetta] USB Controller"
 0x1045	0xc101	"unknown"	"OPTi Inc.|92C264"
 0x1045	0xc178	"ignore"	"OPTi Inc.|92C178"
Comment 1 Gert Dewit 2001-10-26 11:54:52 EDT
Created attachment 35201 [details]
kudzu-0.99.23-1 pcitable patch
Comment 2 Gert Dewit 2001-10-27 05:10:37 EDT
Created attachment 35223 [details]
patch to add adaptec i2o RAID module to anaconda module-info
Comment 3 Bill Nottingham 2001-10-29 14:10:50 EST
*** Bug 55088 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2001-10-29 23:19:39 EST
kudzu will be fixed in 0.99.28 or later. assigning to anaconda for the
module-info fix.
Comment 5 Jeremy Katz 2001-10-30 15:36:29 EST
Added to module-info in CVS
Comment 6 Henry Ritzlmayr 2001-11-14 08:10:00 EST
Just a simple question. Can U post (or send by mail) a description how I can apply this patch?
wkr Henry
Comment 7 Anthony Rumble 2001-12-22 03:58:21 EST
Is there going to be any "hot fix" for this bug?
I tried making a driver update disk.. but of course
it loads the dpt_i2o that I back ported to 2.4.7-10BOOT but then
loads i2o_block over the top.. stuffing it again

I had to go and fix all the pcitable's in the install set and module.cgz's
and burn my own custom install set.. 

Is there no other way? I have customers whining about this all the time,
and im sure there are others who would be turned off Redhat/Linux by this bug.

Anthony

Note You need to log in before you can comment on or make changes to this bug.