Bug 55198 - boot fails when try to start /usr raid
boot fails when try to start /usr raid
Status: CLOSED DUPLICATE of bug 54587
Product: Red Hat Linux
Classification: Retired
Component: raidtools (Show other bugs)
7.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Matt Wilson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-26 18:49 EDT by Juan Pablo Giménez
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-28 19:33:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juan Pablo Giménez 2001-10-26 18:49:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
raidstart is linked against libpopt, libpopt.so is located in /usr/lib, but
my /usr partition is a raid level 0... so RH linux dies booting!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.make /usr a raid particion with RH 7.1
2.upgrade to RH 7.2
3.just boot...
	

Additional info:
Comment 1 Donald Maner 2001-10-28 03:11:21 EST
I also have this problem with a /data raid...  The boot process tries to mount 
my raid0 parition (/data) BEFORE it mounts /usr, so it drops me to a maint. 
prompt.
Comment 2 Need Real Name 2001-10-28 19:33:10 EST
Confirmed, but it's actually worse than that.  raidstart tries to run after
having mounted only /, which means it will fail if /usr is on a separate
partition, regardless of whether it is itself a raid partition.  The only
solution I found was to repartition so that /usr was on /.

-dtalk@prairienet.org
Comment 3 Bill Nottingham 2001-10-29 11:46:15 EST

*** This bug has been marked as a duplicate of 54587 ***
Comment 4 Juan Pablo Giménez 2001-10-29 13:45:37 EST
I'm now using:
ftp://ftp.redhat.com/pub/redhat/linux/rawhide/i386/RedHat/RPMS/raidtools-0.90-24.i386.rpm
and have the problem fixed:
[root@kang root]# rpm -q --changelog raidtools
* mii sep 26 2001 Bill Nottingham <notting@redhat.com>

- link popt in statically

Note You need to log in before you can comment on or make changes to this bug.