Bug 55206 - Install [text] crashes, diag floppy routine trashes CDR drive
Install [text] crashes, diag floppy routine trashes CDR drive
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.2
i686 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-26 23:18 EDT by steven filling
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-01 12:19:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump from fatal crash of installer (72.18 KB, text/plain)
2001-10-26 23:19 EDT, steven filling
no flags Details

  None (edit)
Description steven filling 2001-10-26 23:18:07 EDT
Description of Problem:

The install has a fatal crash after selecting "install everything".  This
is true regardless of whether text or graphic install is attempted.



Version-Release number of selected component (if applicable):
7.2

How Reproducible:

always

Steps to Reproduce:
1. insert CD
2. boot system
3. select all

Actual Results:
fatal crash.  anaconda dump is attached.

Expected Results:

proper installation of the software


Additional Information:
Comment 1 steven filling 2001-10-26 23:19:21 EDT
Created attachment 35221 [details]
Anaconda dump from fatal crash of installer
Comment 2 steven filling 2001-10-27 00:08:26 EDT
Important!

When the failed install wrote the anacdump.txt file attached to this bug and
restarted it seems to have overwritten something on the CDROM firmware.  The
boot sequence, which previously recognized the drive as a 36X Creative drive,
now displays a string of unprintable characters and after booting the CDROM
drive cannot be mounted.  Note that the anacdump.txt file is from an attempted
install [without formatting] over a 7.1 installation.  I got the same result
from an attempted install on fresh [literally new, unwritten] drives.

Being a stupid as well as trusting linux user, I swapped the trashed CDR drive
out and replaced it with a DVD ROM drive from my spouse's system.  After another
failed install, and writing a another floppy with the error log, you guessed it,
the DVDROM drive is no longer recognized as a Compaq DVD drive and can no longer
be mounted.

This system is a newly assembled Tyan Tiger 2507D dual with 2 PIII 800EBs, 1GB
RAM, 2 40GB Western Digital drives, a floppy, a FORMERLY functional CD ROM
drive, and a G400 video card.

I'm now in really deep shit for zapping my spouse's DVD drive, and still no
closer to installing 7.2 .   Please Please Please give me a clue how to restore
these drives to functionality and why 7.2 is so difficult when 7.1 installs like
a charm.  I have *never* come across software that can trash read-only drives. 
How is that possible?

Sinking below the surface of the kim chee,
Steven
Comment 3 Brent Fox 2001-10-27 10:11:54 EDT
I'm not sure how to respond...there is no code in the installer that overwrites
the cdrom firmware....it just doesn't exist.  This is truly bizarre.  

Okay, first of all, does the BIOS see the devices any more?  Second, can you
boot from the 7.1 cd?

Also, I think that something is not right with the cd's that you burned.  The
traceback that you attached looks exactly like bug #39283, which was caused by
bad media.  Did you verify the md5sums of the ISOs before you burned them?
Comment 4 Brent Fox 2001-10-27 10:14:40 EDT
What kind of floppy drive do you have?  Is it on the floppy controller, or do
you have an LS-120 or something like that on the IDE controller?
Comment 5 steven filling 2001-10-27 10:42:04 EDT
Floppy drive is a standard 3.5" generic attached to the standard floppy
controller.  ide0 has a 40GB WD drive, ide1 has a 40GB WD drive and a CDR drive
[and my daughter says I'd better not trash it like I did Mom's DVD drive ;^(]. 

I am using official Red Hat produced CDs - these are not discs I burnt.  Maybe
the disc is defective?  I'm afraid to try installing it on another system for
fear of trashing yet another CDR drive.  I've put the install 1 CD into my
laptop: it reads directory structures okay, and I can view the readme files.  Is
there a specific file I can try accessing with the disc mounted?  I'm not
conversant enough with python to parse the error msg.
Comment 6 steven filling 2001-10-27 10:48:29 EDT
>I'm not sure how to respond...there is no code in the installer that overwrites
> the cdrom firmware....it just doesn't exist.  This is truly bizarre. 

Agreed.  My intuition was that there should not be any way the installer could
do that, but the only evidence I've got is working CD and DVD drives pre 7.2
install attempt and non-working drives post 7.2 install attempt.  I'd be really
happy to find myself wrong, as this just destroys my basic "the worst that can
happen is I have to reinstall" philosphy. 

> Okay, first of all, does the BIOS see the devices any more?  Second, can you
> boot from the 7.1 cd?

BIOS knows 'something' is there, the identifier is no longer "Creative 36X CD
drive" or "Compaq DVD drive" but a string of non-alphanumeric characters.  I
can't boot/read from those drives.  Having replaced them with a still-functional
CD Drive, I can now boot from the 7.1 or 7.2 CDs as well as mount them for
reading.

> Also, I think that something is not right with the cd's that you burned.  The
> traceback that you attached looks exactly like bug #39283, which was caused by
> bad media.  Did you verify the md5sums of the ISOs before you burned them?


I didn't create these CDs - they're the $59.95 items from CompUSA.

 Additional comment by
Comment 7 steven filling 2001-10-27 11:55:09 EDT
I've cobbled together another system [K300, generic m/b, fujitsu drives] to try
an install on:

text install
selected everything

another fatal crash - here is the unhandled exception:
=========================================
File "/usr/bin/anaconda", line 620, in ?
intf.run(id,dispatch,configFileData
File "/usr/lib/anaconda/text.py", line 408, in run
dispatch.gotoNext()
File "/usr/lib/anaconda/dispatch.py", line 143, in gotoNext
self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
rc = apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/packages.py", line 520, in doInstall
instLog = open(instLogName, "w+")
IOError: [Errno 2] No such file or directory: '/mnt/sysimage/tmp/install.log'

It seems clear that this issue is not hardware specific - maybe the disc?
Comment 8 Brent Fox 2001-10-27 12:02:10 EDT
I didn't know you had the retail cd's.  Many reports we get are from people who
downloaded Red Hat Linux and frequently the ISO images get corrupted during the
download.

I must admit that I'm baffled by this report.  One thing I can think of is that
the IDE controller (the secondary controller, I presume) has gone bad, and
therefore can't talk to the drives correctly anymore.  One way to test this is
to take one of the drives you think might be damaged (the DVD perhaps), and put
it in another machine and see if the BIOS recognizes it.  If so, see if you can
boot off the 7.1 cd.  You don't need to do a full install, just see if the drive
can boot.

If that works, then the drives aren't damaged and the problem could lie with the
IDE controller.  I've had IDE controllers fail on me before twice.  Both times I
thought my hard drives had died, but both times it turned out to be the
controller.  I had to replace the motherboard and then things were fine.
Comment 9 Brent Fox 2001-10-27 12:05:57 EDT
It isn't unheard of for the retail cd's to be damaged, and it seems likely that
yours are damaged somehow.  I would recommend exchanging them with another set
from CompUSA.
Comment 10 steven filling 2001-10-27 12:56:54 EDT
I sat down and thought it through.  I have been selecting custom -> everything
installs, and not the default packages.  I restarted the install, and noticed
that using custom install and fdisk, one must manually select format with ext3,
something I had not done on the previous install attempts.  I decided to retry
the graphic installation.  The only difference this time is that I selected
format ext3 for all partitions, and voila! I'm sitting now watching packages
install. ;^)))))

Apparently the problem is related to trying to install on ext2 partitions?

I've also managed to get the DVD drive functional again, not sure what I did
other than let it sit for a day, wave chicken bones over it, and then attach it
to a different system.

The Creative CDR drive is still non-functional on any system, maybe those bones
are only good for one revival a day...   I guess I'll just be glad my
significant other at least has her DVD back.

Thanks for the assistance!  If I can give you any more information about this
that might help in figuring out why ext2/ext3 react differently, or what the
issue is with CD drives, please let me know.  In the interim, I'll close this
bug as I suspect you're overloaded as is and my install is into the 2nd disc.
Comment 11 Brent Fox 2001-10-27 19:27:33 EDT
I've been trying to get Marketing to include some chicken bones in the
Professional box set, but they won't listen.  ;)

Using ext2 or ext3 should make no difference.  ext3 is just ext2 except that it
has journalling capability.  Other than that, it is no different at all.  I'm
still suspicious of the IDE controller.  Often, they don't fail all the way. 
Instead, they start behaving strangely and will then fail completely later on. 
I wouldn't be surprised to see some problems reappear in the future with this
machine, but let's hope not.

Anyway, I'm glad things are working for you now.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.