Bug 5521 - "ne2000 compatible" card problems
"ne2000 compatible" card problems
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-04 18:24 EDT by eckman
Modified: 2008-05-01 11:37 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-14 12:17:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description eckman 1999-10-04 18:24:32 EDT
When telling the 6.1 installer that I had an ne2000
compatible isa card, it gave me the following error message:

"/tmp/ne.o: init_module: Device or resource busy"

Translation:  I am an old isa card, please tell me what my
settings are.

The average Jill or Joe wouldn't know what is going on.  A
more descriptive error message would be nice.

I'm also like to see the "autoprobe" option again, which was
in the last several redhat versions.  It makes better
guesses then I do.  :)

Thanks!

Eric


------- Additional Comments From   10/11/99 13:53 -------
Do you mean I/O and irq settings? Did enter those manually and still
wouldn't work.

------- Additional Comments From   10/11/99 14:06 -------
When I manually entered the io and irq it worked fine.  I was lucky
enough to have a redhat 6.0 boot disk laying around and that let me
know what the correct settings were.  :)


------- Additional Comments From   10/11/99 19:12 -------
The card is set to I/O 300 and irq 10. Both RH6.0 and Mandrake don't
have problems with that, though Mandrake didn't like I/O 220 and irq
5 (selected by "auto configuration" as described next). I can set the
card to pretty much any setting using a W98 boot disk and the card's
configuration disk, which allows setting the card in either NE2000
mode along with either manual or automatic settings for I/O and irqs,
or in PnP mode. Is it possible that bootnet.img likes a particular
combo of settings? The machine is sorta ancient ... DEC XL590 .. with
SCSI disk (disconnected and disabled in BIOS), 854 meg IDE, 16 meg,
Stealth video, P90 on plug-in board (has room for 2 (CPUs) but 2nd not
used). Anyone else have any thoughts on this?

Werner

------- Additional Comments From   10/12/99 00:50 -------
Most ISA ne2000 cards have to be installed with the ne driver (as
opposed to the ne2000 driver, which is really for pci cards) if you
can't find it in the config menu change your ifcfg-eth0 file to read
alias eth0 ne
options eth0 io=0x280 irq=5  (replace these options with your io's)
also if you have 2 of the same ne cards you will need
alias eth0 ne
alias eth1 ne
options eth0 -o ne-0 io=0x280 irq=5
options eth1 -o ne-0 io=0x300 irq=7

(note this was stolen directly from the ethernet how-to. just
remembered this because I too had problems getting a ne200 compatible
isa card working) if still have problems.. email me.. as I don't check
this often
Comment 1 johnlar 1999-10-12 00:54:59 EDT
arg I meant to say
options eth0 -o ne-0 io=0x280 irq=5
options eth1 -o ne-1 io=0x300 irq=7

johnlar@tfn.net
Comment 2 Jay Turner 1999-10-20 12:24:59 EDT
This issue has been forwarded to a developer for further action.
Comment 3 Jay Turner 1999-10-20 12:25:59 EDT
*** Bug 5491 has been marked as a duplicate of this bug. ***

using bootnet with a NE2000 CARD ISA, did not allow to
specify an IO PORT for the card, so, install REDHAT 6.1
Over the Network using a NE2000 ISA CARD IS NOT POSSIBLE

------- Additional Comments From gafton@redhat.com  10/05/99 02:36 -------
msw is wnjoying these types of bugs :-)


------- Additional Comments From bugfix@freemail.hu  10/11/99 11:48 -------
RH 6.1 BOOTNET using NE2000 ISA Card, THERE IS IO PORT Option
Use the additional option or something similar .... it just
worked for me but it was a pain to figure out what the IO was
Comment 4 Jay Turner 1999-10-20 12:29:59 EDT
*** Bug 5685 has been marked as a duplicate of this bug. ***

On machines with Tulip and VIA-Rhine LAN cards I have
successfully installed 6.1 for i386, and the installer has
auto-detected the LAN card. When I try on machines with
NE2000 cards, the card is not auto-detected. When I manually
select the NE2000 driver I get a "resource busy" message.

Another point. When I reach the point of setting the FTP
parameters for install, the option to set a specific login
ID and password (rather than anonymous FTP) seems to have
disappeared in 6.1

Like a lot of others reporting here, I also get lots of
Python errors when trying an upgrade. Only a fresh install
seems to work, but this is hardly a fresh bug report.
Comment 5 Jay Turner 1999-10-20 12:30:59 EDT
*** Bug 5811 has been marked as a duplicate of this bug. ***

Hi

I have the problem on install the redhat 6.1 on network
install.
My network adapter is a PCI NE2000, but the module not is in
network image.
Why I do in this case?

Thanks

Claudio Jr.

------- Additional Comments From jturner@redhat.com  10/11/99 08:17 -------
The NE2000 module is indeed in the installer image.  If it is not
getting loaded automatically, then you will want to run in the
installer in expert mode and specify your hardware manually.  To run
the installer in expert mode, just type "expert" at the boot prompt.
Reopen this bug if you continue to have problems.

------- Additional Comments From csjunior@din.uem.br  10/12/99 16:50 -------
Hi

Yes, on my test I load the module with the expert mode on install of
redhat 6.1, but there is the option of ne2000 and pci ne2000 on normal
install of redhat 6.1.
It is a bug?

------- Additional Comments From   10/17/99 13:05 -------
"NE1000, NE2000, and compatible" option doesn't work on my isa-NE2000-
card, here's the error:

"/tmp/ne.o: init_module: Device or resource busy"

Redhat 6.0 ftp-installation worked just fine. The card is from Edimax
and plug'n'play is off and it works on 6.0. Haven't tried the expert
mode yet, but defining the settings(irq, resource) didn't help.
Comment 6 Jay Turner 1999-10-21 13:18:59 EDT
*** Bug 5851 has been marked as a duplicate of this bug. ***

  This is a new problem that did not exist in 6.0 installer
because the installation program _always_ allowed you to
tell it you had a network card and worked with you until it
was recognized.

  the current system will _never_ ask you if you have a
network card, even when you are doing a server install, if
it does not see your network card.  The auto detection
routines are broken.  They weren't this broken in redhat
6.0, as they recognized the card when I pointed them to the
card.  Under the expert option in RH 6.1, I had to fill in
the card parameters, something I _did_ _not_ have to do in
RH 6.0.  I just told it that was the card.

  Under the Expert option, it is not clear that the network
card you tried to enter was rejected, as no POP UP appears
to indicate this to you.  A pop up only appears when you
get it right.  I was thrown by this the first time, as a
small error message showed up at the bottom of the screen
and did not register.

  All in all, I am disappointed by this one thing. It will
cause me much grief for me and my customers (I'm a
consultant).


------- Additional Comments From   11/01/99 04:53 -------
Yes. Had that problem. Compiles isa ne into a kernel and it came up
fine. With the ne, lp0, pppd hassles, Redhat can do better. 5.2 is
still Redhat's best release.
Comment 7 udippel 1999-11-11 10:17:59 EST
Have the same problem with Accton 166X ISA card. RH6.0 finds it
without any problem; in RH6.1 it doesn't install at all.
Same proposal as usual: why not ask for netcard if you set up server
or networked workstation and the installer doesn't see the netcard?
Comment 8 Jay Turner 2000-02-11 13:15:59 EST
Issue has been put on a features request list.
Comment 9 Michael Fulbright 2000-09-19 19:04:29 EDT
Does RH 6.2 or the Pinstripe beta help with this issue?
Comment 10 Michael Fulbright 2000-09-26 12:10:24 EDT
Moving to RESOVLED - DEFERRED from CLOSED - DEFERRED
Comment 11 Michael Fulbright 2000-09-26 12:56:06 EDT
Moving to RESOVLED - DEFERRED from CLOSED - DEFERRED
Comment 12 Michael Fulbright 2001-09-14 12:17:15 EDT
Closing because this issue should be resolved by the current release.

Note You need to log in before you can comment on or make changes to this bug.