Bug 552405 - kickstart fails on perl package
Summary: kickstart fails on perl package
Status: CLOSED DUPLICATE of bug 610134
Alias: None
Product: Spacewalk
Classification: Community
Component: Clients
Version: 0.7
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Milan Zázrivec
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: space16
TreeView+ depends on / blocked
 
Reported: 2010-01-04 22:02 UTC by Johnny Mirza
Modified: 2011-09-02 12:36 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
staging
Last Closed: 2011-09-02 12:36:28 UTC


Attachments (Terms of Use)

Description Johnny Mirza 2010-01-04 22:02:00 UTC
Description of problem:
kickstart installation fails on perl-libwww-perl-5.805-1.1.1.noarch.rpm.
Have successfully created the kickstart profile and distro tree in spacewalk, and used cobbler buildiso to create a boot iso. Successfully booted from the iso and kickstart works (completes the format partitions section) and gets to the install section after checking package dependencies, but fail on the above mentioned perl packed. (need to press "crt-f3" to see the error).
The full path of the file is http://servername/ks/dist/fd-centos-5/CentOS/perl-libwww-perl-5.805-1.1.1.noarch.rpm

when trying directly hitting that link via a web browser I get a spacewalk "File Download Failed" error page.

The package perl-libwww-perl-5.805-1.1.1.noarch.rpm exsists and can be found both via the spacewalk package search section and via the commandline, (I have even cksum the file and it looks correct to the cd version).


Version-Release number of selected component (if applicable):
0.7.

How reproducible:
not sure, this looks to be a type of tomcat caching issue, but I cannot find the referenced file anywhere.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
this dynamically generated link http://servername/ks/dist/fd-centos-5/CentOS/perl-libwww-perl-5.805-1.1.1.noarch.rpm does not link to the file
Expected results:
should be able to download the file from this link

Additional info:
The package that required the perl-libwww-perl-5.805-1.1.1.noarch.rpm comes from the postfix package I have added to the software section and looks to be only and issue with this package.

I have created a test kickstart profile without the postfix package and the linux build works fine using the same boot iso.

Comment 1 Johnny Mirza 2010-01-04 23:08:05 UTC
I think I have resolved the issue and would like to confirm if it is a known bug in spacewalk.

The perl-libwww-perl-5.805-1.1.1.noarch.rpm was in two spacewalk channels and I assume spacwalk would be able to pick any of the files as they were the same but this is not the case. After deleted one of the packages in one of the channels the kickstart build completed successfully and didn't dont warn or error for the perl package.

I am not sure if this is a satellite known fact or a bug.

thanks

Comment 2 Jan Pazdziora 2010-11-19 16:02:49 UTC
Mass-moving to space13.

Comment 3 Miroslav Suchý 2011-04-11 07:31:19 UTC
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.

Comment 4 Miroslav Suchý 2011-04-11 07:36:22 UTC
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.

Comment 5 Jan Pazdziora 2011-07-20 11:48:56 UTC
Aligning under space16.

Comment 6 Jan Pazdziora 2011-09-02 12:36:28 UTC
(In reply to comment #1)
> I think I have resolved the issue and would like to confirm if it is a known
> bug in spacewalk.
> 
> The perl-libwww-perl-5.805-1.1.1.noarch.rpm was in two spacewalk channels and I
> assume spacwalk would be able to pick any of the files as they were the same
> but this is not the case. After deleted one of the packages in one of the
> channels the kickstart build completed successfully and didn't dont warn or
> error for the perl package.
> 
> I am not sure if this is a satellite known fact or a bug.

This was fixed by commit a342b5f3f447811989b3e31f9104e5c004214cc8.

*** This bug has been marked as a duplicate of bug 610134 ***


Note You need to log in before you can comment on or make changes to this bug.