Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 610134 - Two RPMS, same name, different md5 results in a failed kickstart
Two RPMS, same name, different md5 results in a failed kickstart
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
:
: 552405 (view as bug list)
Depends On:
Blocks: space16
  Show dependency treegraph
 
Reported: 2010-07-01 11:42 EDT by Mark Chappell
Modified: 2011-09-02 08:36 EDT (History)
4 users (show)

See Also:
Fixed In Version: spacewalk-java-1.1.31-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-19 05:15:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
catalina.out (39.49 KB, text/plain)
2010-07-01 11:42 EDT, Mark Chappell
no flags Details

  None (edit)
Description Mark Chappell 2010-07-01 11:42:00 EDT
Created attachment 428479 [details]
catalina.out

CentOS have managed to upload two copies of the same package with different md5sums to the Core OS RPMS directory and the updates directory

I keep the updates in a child channel of the original OS



$ wget
http://www.mirrorservice.org/sites/mirror.centos.org/5.5/updates/x86_64/RPMS/gnome-python2-extras-2.14.2-6.el5.x86_64.rpm
http://www.mirrorservice.org/sites/mirror.centos.org/5.5/os/x86_64/CentOS/gnome-python2-extras-2.14.2-6.el5.x86_64.rpm



$ md5sum gnome-python2-extras-2.14.2-6.el5.x86_64.rpm*

32cdd6f2214de1fb5306e2900140bb3b
gnome-python2-extras-2.14.2-6.el5.x86_64.rpm

24ec62561cc77b07234eef140fdec2e8
gnome-python2-extras-2.14.2-6.el5.x86_64.rpm.1



When downloading the RPMs during a kickstart we get the attached in catalina.out and an error returned on the machine kickstarting
Comment 1 Jan Pazdziora 2010-11-19 11:03:03 EST
Mass-moving to space13.
Comment 2 Miroslav Suchý 2011-04-11 03:31:35 EDT
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.
Comment 3 Miroslav Suchý 2011-04-11 03:36:27 EDT
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.
Comment 4 Jan Pazdziora 2011-07-20 07:49:17 EDT
Aligning under space16.
Comment 5 Michael Mráka 2011-08-19 05:15:42 EDT
This issue has been fixed some time ago by
commit a342b5f3f447811989b3e31f9104e5c004214cc8
    making kickstarts not fail if multiple of the same NVREA are in the same channel


Closing. If you disagree feel free to reopen bug.
Comment 6 Jan Pazdziora 2011-09-02 08:36:28 EDT
*** Bug 552405 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.