Bug 552453 - Add init script to also start dhcpd for IPv6.
Add init script to also start dhcpd for IPv6.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
12
All Linux
low Severity low
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
: 552799 (view as bug list)
Depends On:
Blocks: 558825
  Show dependency treegraph
 
Reported: 2010-01-05 01:07 EST by Frank Crawford
Modified: 2010-01-26 09:24 EST (History)
6 users (show)

See Also:
Fixed In Version: 4.1.0p1-17.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 558825 (view as bug list)
Environment:
Last Closed: 2010-01-20 19:06:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dhcpd6 start up script (3.21 KB, application/octet-stream)
2010-01-06 03:47 EST, Frank Crawford
no flags Details
Diff between /etc/init.d/dhcpd and /etc/init.d/dhcpd6 (3.19 KB, patch)
2010-01-06 03:50 EST, Frank Crawford
no flags Details | Diff

  None (edit)
Description Frank Crawford 2010-01-05 01:07:44 EST
Description of problem:
There is no obvious way to start 'dhcpd -6" with the distributed init script for dhcpd, as by default it creates a separate lease file (dhcpd6.leases) and pid file (dhcpd6.pid), and the configuration test step fails.

In addition, it is not possible to run both dhcpd and dhcpd -6 on the same server, as the current script does not correctly handle multiple processes with the same name.

Version-Release number of selected component (if applicable):
dhcp-4.1.0p1-13.fc12.i686

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
If you want it, I have a modified script for /etc/rc.d/init.d/dhcpd that will invoke dhcpd -6.  The changes as minor one to the standard.
Comment 1 Jiri Popelka 2010-01-06 02:39:59 EST
*** Bug 552799 has been marked as a duplicate of this bug. ***
Comment 2 Jiri Popelka 2010-01-06 02:41:54 EST
Thank you for the report Frank.
Can you post your modified script for /etc/rc.d/init.d/dhcpd that will invoke dhcpd -6.
Comment 3 Catalin BOIE 2010-01-06 02:51:23 EST
I think we should have separate init.d scripts for v4 and v6. Right?
Comment 4 Jiri Popelka 2010-01-06 03:09:29 EST
Yes, I think we need separate init.d scripts.
Comment 5 Frank Crawford 2010-01-06 03:47:44 EST
Created attachment 381936 [details]
dhcpd6 start up script
Comment 6 Frank Crawford 2010-01-06 03:50:42 EST
Created attachment 381938 [details]
Diff between /etc/init.d/dhcpd and /etc/init.d/dhcpd6

While the diff is obvious, it is primarily aimed at using the PID file to select the correct process and the add a different confguration file, since the default would use the same as for IPv4.
Comment 7 David Cantrell 2010-01-06 08:46:44 EST
I'm not sure a second init script is necessary.  Personally, I'd like to see a single dhcpd init script and adding variables to /etc/sysconfig/dhcpd along the lines of:

IPV4_MODE=[yes|no]
IPV6_MODE=[yes|no]

Two daemons have to be running if you want both IPv4 support and IPv6 support.  Then modify the existing dhcpd script to support launching dhcpd in -4 and/or -6 mode and keeping track of those pids.

restart and condrestart would require restarting both daemons, but I don't see that as a problem because they would both be reading the same configuration file and restarting both on a config file is really safer than not.
Comment 8 Frank Crawford 2010-01-06 20:15:05 EST
One or two scripts isn't too much of a problem, but given the differences in options within the configuration file, I don't think you can really share them.  I suspect for all practical purposes you need to have two separate config files.

Also, while playing with the daemon's lately, I've noticed that it is normally only necessary to restart one or the other.  Rarely do you restart both at the same time, again, mainly due to the differences in options to be specified.
Comment 9 David Cantrell 2010-01-08 15:13:30 EST
(In reply to comment #8)
> One or two scripts isn't too much of a problem, but given the differences in
> options within the configuration file, I don't think you can really share them.
>  I suspect for all practical purposes you need to have two separate config
> files.
> 
> Also, while playing with the daemon's lately, I've noticed that it is normally
> only necessary to restart one or the other.  Rarely do you restart both at the
> same time, again, mainly due to the differences in options to be specified.  

That's reasonable.  In that case, the init script for dhcpd -6 should force the use of a different configuration file on the system.

The dhcpd package should also make sure it's providing both the dhcpd and dhcpd6 services as well.
Comment 10 Fedora Update System 2010-01-16 21:53:14 EST
dhcp-4.1.0p1-16.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dhcp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12048
Comment 11 Fedora Update System 2010-01-18 19:56:28 EST
dhcp-4.1.0p1-17.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dhcp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12048
Comment 12 Fedora Update System 2010-01-20 19:06:01 EST
dhcp-4.1.0p1-17.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Miroslav Grepl 2010-01-21 11:52:54 EST
SELinux changes for this fix was added to selinux-policy-3.6.32-72.fc12.noarch. The update is available from updates-testing repo.

su -c 'yum --enablerepo=updates-testing update selinux-policy-targeted'

Note You need to log in before you can comment on or make changes to this bug.