Bug 55298 - Linux install Boot-20000407 + Updates-disk-20000419 does not work on Compaq server proliant DL360 wtih 2 NIC and RAID harddisk
Linux install Boot-20000407 + Updates-disk-20000419 does not work on Compaq s...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-29 09:41 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-31 08:47:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-29 09:41:39 EST
Description of Problem:
I'm trying to install Linux Red Hat 6.2 on a Compaq Proliant DL360 server 
with 2 NIC. 
When I try to install from the RedHat 6.2 CDROM I have the same problem 
than BUG10687. So I made a boot disk with the file "boot-20000407.img" and 
an anaconda update disk with "update-disk-20000419.img".
Then when I try to install from those 2 disks, just before using FDISK to 
partition my RAID disk, I get the message :  "An error has occured - no 
valid devices were found on which to create new file systems. Please check 
your hardware for the cause of this problem".
I checked my hardware and it is OK. (Anyway, the installation from the 
RH6.2 CDROM works fine during the fdisk part ...).

Version-Release number of selected component (if applicable):


How Reproducible:
To reproduce the bug, you ned to create a RH6.2 boot disk form the 
file "boot-20000407.img" and an anaconda update disk from the 
file ""update-disk-20000419.img".
Then try to install Linux RH6.2 on a compaq server with 2 NIC an a RAID 
disk.

Steps to Reproduce:
1. Insert the "RH6.2 boot" floppy in the floppy drive
2. Turn on your compaq server
3. At the linux prompt type : "linux updates"
4. When asked insert your "anaconda updates floppy disk" in the floppy 
drive, then press enter
5 . Go on with the installation program untill the screen : "Installation 
type"
6 . Select  "custom installation" and "use Fdisk", then click "next"

Actual Results:
7. you get the error message : "An error has occured - no valid devices 
were found on which to create new file systems. Please check your hardware 
for the cause of this problem"


Expected Results:
7. drop you to the fdisk windows ...

Additional Information:
Comment 1 Brent Fox 2001-10-29 11:24:01 EST
Are you using a Compaq Smart Array controller?  If so, you will need to use
either the firmware on the card or the Compaq SmartStart cd to create the
logical RAID devices on the controller.  

I think you are seeing the error from the installer because it doesn't see any
logical devices attached to the RAID controller.  Does that help?
Comment 2 Need Real Name 2001-10-29 11:41:35 EST
Yes, we are using a Compaq Smart Array controller, and the logical RAID device 
is allready created. 
And the drive is correctly found by anaconda when I install Linux directly from 
the RedHat6.2 CDROM (In this case, I can use "fdisk" and create my partitions, 
and go on with the installation untill the "bug10687" caused by my 2 NIC).
To avoid the "bug10687", I try to install Linux from the boot diskette "boot-
20000407.img" and "update-disk-20000419.img" downloaded from your support site, 
and in this case, the drive is not found by anaconda and I get the error 
message just before using fdisk.
(Sorry for my English, I hope my explanations are clear enought).
Comment 3 Brent Fox 2001-10-29 15:08:39 EST
Can you tell me what kind of Smart Array you are using?  We have a lot of
ProLiant equipment in our test lab, so I'd like to reproduce your situation with
the same hardware.

Also, are you interested in trying a newer version of Red Hat Linux?  I believe
that these problems have been fixed in the more recent releases.
Comment 4 Need Real Name 2001-10-30 02:50:26 EST
The Smart Array version we are using is "1.42". with 2 18,6 Gb disks.
We are currently not interested in another version of Linux as all our other 
servers are running Linux Redhat 6.
Comment 5 Brent Fox 2001-10-30 15:33:56 EST
I think you are giving me the number of the firmware revision on the SmaryArray,
not the model number for the array.  SmaryArray model numbers are like 5300,
5302, 4250ES, 532, etc.
Comment 6 Need Real Name 2001-10-31 05:29:36 EST
Ok. 1.42 is the firmaware version.
I had Compaq support on the phone. For my DL360 proliant server, the Smart 
Array controller is an "Integrated Smart Array Controller" (no model number).
Comment 7 Brent Fox 2001-10-31 08:35:01 EST
Ok, I know what that is.  We have the hardware for that, and I'll test it today.
Comment 8 Need Real Name 2001-10-31 08:47:43 EST
Thank you, I'm waiting for your answer.
Regards

Comment 9 Brent Fox 2001-11-05 15:34:40 EST
Sorry, I've been sick for a few days.  I tried testing this today and I
duplicated the behavior.  Unfortunately, there's not much we can do about it. 
The integrated Smart Array uses the cciss driver instead of the cpqarray driver
that the more conventional SmartArray cards use.  6.2 predates the release of
the integrated SmaryArray, so the installer doesn't know anything about the
card, nor does it have a driver to load even if it could identify the card. 

I then tried 7.2, which worked fine.  I know that you are using 6.2 on your
other servers, but there's not much we can do to make this hardware work under
6.2 without pretty significant engineering work, and we can't afford to spend
that kind of time on a release that is almost two years old.

Note You need to log in before you can comment on or make changes to this bug.