Bug 553256 - Eclipse crashing when adding addons.
Eclipse crashing when adding addons.
Status: CLOSED DUPLICATE of bug 522187
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-07 09:39 EST by Fabian Deutsch
Modified: 2010-01-07 09:46 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-07 09:43:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Eclipse logfile. (55.69 KB, application/octet-stream)
2010-01-07 09:39 EST, Fabian Deutsch
no flags Details

  None (edit)
Description Fabian Deutsch 2010-01-07 09:39:52 EST
Created attachment 382246 [details]
Eclipse logfile.

Description of problem:
Eclipse crashes when I try to add addons.

Version-Release number of selected component (if applicable):
F12 Galileo
$ rpm -qa | grep eclipse
icu4j-eclipse-4.0.1-4.fc13.i686
tomcat5-jasper-eclipse-5.5.27-7.4.fc12.noarch
eclipse-platform-3.5.1-24.fc13.i686
eclipse-swt-3.5.1-24.fc13.i686
eclipse-subclipse-1.6.5-3.fc13.noarch
eclipse-svnkit-1.3.2-1.fc13.noarch
eclipse-jdt-3.5.1-24.fc13.i686
eclipse-emf-2.5.0-4.fc12.noarch
eclipse-rcp-3.5.1-24.fc13.i686

How reproducible:
Always.

Steps to Reproduce:
1. Open eclipse.
2. Menu "Help" -> Entry "Install New Software ..."
3. (Dialog opens)
4. Press on Button "Cancel"
  
Actual results:
Eclipse crashes.

Expected results:
Eclipse closes the dialog.

Additional info:
This also happens when i try to add another addon source.
Comment 1 Andrew Overholt 2010-01-07 09:43:13 EST

*** This bug has been marked as a duplicate of bug 522187 ***
Comment 2 Andrew Overholt 2010-01-07 09:46:17 EST
Thanks for the report.  The koji build that I mention in bug #522187 comment #38 should fix this issue.  It's caused by an upstream bug in SWT when GNOME accessibility is enabled.

Note You need to log in before you can comment on or make changes to this bug.