This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 522187 - SWT crash with GTK 2.18 and GNOME accessibility
SWT crash with GTK 2.18 and GNOME accessibility
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
: Reopened
: 531186 547557 553256 (view as bug list)
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-09-09 13:28 EDT by Mark
Modified: 2010-01-27 04:47 EST (History)
14 users (show)

See Also:
Fixed In Version: 3.5.1-22.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-26 20:10:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
the error attachement (57.12 KB, text/plain)
2009-09-09 13:28 EDT, Mark
no flags Details
OpenJDK Client VM Droppings (62.95 KB, text/plain)
2009-09-14 12:01 EDT, Mat Booth
no flags Details
error log, after crash. (70.97 KB, text/plain)
2009-09-24 07:21 EDT, Fabian Deutsch
no flags Details
the last log with 3.5.1 (95.21 KB, text/plain)
2009-10-17 04:16 EDT, Michael Stoykov
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 285749 None None None Never
Eclipse Project 291128 None None None Never

  None (edit)
Description Mark 2009-09-09 13:28:11 EDT
Eclipse 3.5 crashes. As I understand the problem is with java and libpango (pango_layout_new). 

OS: Fedora 12 Alpha (last updated on 9.9.2009 from rawhide) (OS:Fedora release 11.91 (Rawhide))

Java: tried on many versions e.g. j2sdk1.4.2_19, jdk1.5.0_20, jdk1.6.0_16 and even jdk1.7.0M4 (7.0 milestone 4).

To reproduce the problem open in Eclipse: Help -> Install New Software -> and just press "Cancel". What I get is: 

(That was produced using java 7.0 M4 but as I wrote it can be reproduced using older java vesions too):
 
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00e04059, pid=13953, tid=3086444224
#
# JRE version: 7.0-b66
# Java VM: Java HotSpot(TM) Client VM (16.0-b06 mixed mode, sharing linux-x86 )
# Problematic frame:
# C  [libpango-1.0.so.0+0x23059]  pango_layout_new+0x39
#
# An error report file with more information is saved as:
# /home/mel/hs_err_pid13953.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Comment 1 Mark 2009-09-09 13:28:51 EDT
Created attachment 360285 [details]
the error attachement
Comment 2 Mat Booth 2009-09-14 12:01:35 EDT
Created attachment 360967 [details]
OpenJDK Client VM Droppings

I am seeing this using the current OpenJDK in Rawhide too about every quarter of an hour or so.

java-1.6.0-openjdk-devel-1.6.0.0-31.b16.fc12.i686
pango-1.25.5-1.fc12.i686

Its making Eclipse pretty unusable.
Comment 3 Fabian Deutsch 2009-09-24 07:21:22 EDT
Created attachment 362472 [details]
error log, after crash.

I'm also experiencing those pango/java/crahs problems with eclipse. Also attaching a log.
Comment 4 Mat Booth 2009-09-24 11:20:47 EDT
CC'ing the Eclipse brothers to see if they know anything about this.
Comment 5 Andrew Overholt 2009-09-24 11:29:38 EDT
I saw this in my rawhide VM (been having a hard time installing it on bare metal) and was going to try to reproduce.
Comment 6 Behdad Esfahbod 2009-09-26 00:06:37 EDT
There's no way a legit crash can happen in pango_layout_new().  Here's the code for that function:

PangoLayout * 
pango_layout_new (PangoContext *context) 
{ 
  PangoLayout *layout; 
 
  g_return_val_if_fail (context != NULL, NULL); 
 
  layout = g_object_new (PANGO_TYPE_LAYOUT, NULL); 
 
  layout->context = context; 
  g_object_ref (context); 
 
  return layout; 
} 


So, either context passed to it is NULL, or this is a memory corruption happening somewhere else.  I can't do anything about it.
Comment 7 Mark 2009-09-28 14:10:58 EDT
After updating to rawhide on 28.09.2009 I have not noticed previous behaviour since then. I cannot reproduce any more Java (Eclipse) crash with these new rpms.
Comment 8 Matthias Clasen 2009-09-29 13:50:11 EDT
Could you reproduce them reliably before that update ?
Comment 9 Mark 2009-09-29 14:32:18 EDT
Tell me what do you need. I have been updating every day but I did not check every day if all is ok with Java and Eclipse. I am sure that before that update Eclipse crashed but after that update doing the same things as I described above does not crash Eclipse.
Comment 10 Matthias Clasen 2009-09-29 16:17:20 EDT
Sounds good to me. I'm sure you'll open another bug if it starts crashing again...
Comment 11 Jeff Johnston 2009-10-09 16:55:40 EDT
I'm seeing this with pango-1.26.0-1.fc12 and gtk2-2.18.2-1.fc12 and eclipse-swt-3.5.0-2.fc12
Comment 12 Michael Stoykov 2009-10-12 20:51:51 EDT
I as Jeff am seeing this bug on the same versions. A good way to reproduce this bug is to try to create (java) project. It usually happens when you click finish:)
Comment 13 Alexander Kurtakov 2009-10-13 13:24:05 EDT
Can someone try whether http://koji.fedoraproject.org/koji/taskinfo?taskID=1743496 fixes the problem?
Comment 14 Jeff Johnston 2009-10-13 13:39:52 EDT
(In reply to comment #13)
> Can someone try whether
> http://koji.fedoraproject.org/koji/taskinfo?taskID=1743496 fixes the problem?  

It works for my scenario which was to go into the New Project menu, select a C/C++ GNU Autotools project type but hit cancel before doing anything.  This works now with the 3.5.1 build.
Comment 15 Mat Booth 2009-10-14 07:18:27 EDT
That 3.5.1 build seems to be working for me too, nice one.
Comment 16 Michael Stoykov 2009-10-17 04:14:56 EDT
it doesn't for me :
$ rpm -ql eclipse* 
package eclipse* is not installed
[mstoikov@ltm ~]$ rpm -qa eclipse*
eclipse-subclipse-1.6.5-1.fc12.noarch
eclipse-swt-3.5.1-1.fc12.x86_64
eclipse-changelog-2.6.7-3.fc12.x86_64
eclipse-jdt-3.5.1-1.fc12.x86_64
eclipse-cdt-6.0.0-10.fc12.x86_64
eclipse-dtp-1.7.0-5.fc12.noarch
eclipse-valgrind-0.3.0-1.fc12.x86_64
eclipse-cdt-sdk-6.0.0-10.fc12.x86_64
eclipse-rse-3.1-2.fc12.noarch
eclipse-gef-3.5.0-3.fc12.noarch
eclipse-svnkit-1.3.0-1.fc12.noarch
eclipse-platform-3.5.1-1.fc12.x86_64
eclipse-linuxprofilingframework-0.3.0-2.fc12.x86_64
eclipse-rpmstubby-0.3.0-1.fc12.noarch
eclipse-birt-2.5-1.fc12.noarch
eclipse-emf-2.5.0-4.fc12.noarch
eclipse-pydev-1.4.7-3.fc12.x86_64
eclipse-rpm-editor-0.4.3-1.fc12.x86_64
eclipse-rcp-3.5.1-1.fc12.x86_64

$ rpm -qa *pango*
pango-1.26.0-1.fc12.i686
pangomm-2.26.0-1.fc12.x86_64
pango-1.26.0-1.fc12.x86_64
pango-devel-1.26.0-1.fc12.x86_64
ruby-pango-0.19.3-2.fc12.x86_64
pangomm-devel-2.26.0-1.fc12.x86_64


$ eclipse
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007fc278920dfa, pid=4144, tid=140473951749904
#
# JRE version: 6.0-b16
# Java VM: OpenJDK 64-Bit Server VM (14.0-b16 mixed mode linux-amd64 )
# Distribution: Custom build (Thu Sep 10 17:06:47 EDT 2009)
# Problematic frame:
# C  [libpango-1.0.so.0+0x24dfa]  pango_layout_new+0x2a
#
# An error report file with more information is saved as:
# /home/mstoikov/hs_err_pid4144.log
#
# If you would like to submit a bug report, please include
# instructions how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
 


The same way of testing this time the buttons didn't get highlighted and nothing happens but a second after I create the project and it shows in the left it crashes.And I am on x86_64
Comment 17 Michael Stoykov 2009-10-17 04:16:30 EDT
Created attachment 365116 [details]
the last log with 3.5.1

THis is the last log I get with 3.5.1
Comment 18 Adam Williamson 2009-10-23 13:08:58 EDT
This was discussed at the blocker review meeting today. As it seems clear this is a bug (or bugs) in Eclipse, not Pango or Java, we can't consider it a blocker for the final release, as it's not critical functionality and can just as easily be fixed as an update. Releng will accept a tag request to have a build included in F12 final to try and address these issues if you would like to do that, though.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 Andrew Overholt 2009-10-27 12:51:28 EDT
*** Bug 531186 has been marked as a duplicate of this bug. ***
Comment 20 Andrew Overholt 2009-10-27 16:46:53 EDT
This puzzles me:

/home/mstoikov/.eclipse/793567567/configuration/org.eclipse.osgi/bundles/594/1/.cp/libswt-gnome-gtk-3555.so

The SWT .so files should be extracted into /usr/lib{,64}/eclipse and not get extracted (or re-extracted) at runtime.

Michael, did you happen to try with an eclipse.org download expanded into a read-only (to the running user) location at some point?  Can you try to see if you can duplicate with a clean ~/.eclipse?

Ben, do you have any SWT .so files in ~/.eclipse?
Comment 21 Andrew Overholt 2009-10-27 16:47:26 EDT
For information, upstream and Ubuntu bugs related to this:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=285749
https://bugs.launchpad.net/ubuntu/+source/eclipse/+bug/174759
Comment 22 Andrew Overholt 2009-10-28 10:41:08 EDT
Jim Hayward reports on fedora-devel-java-list [1]:

> I cannot reproduce that bug at all on a fully updated F12(rawhide) x86
> system. I don't currently have an x86_64 install to try. Eclipse 3.5.1
> has been working great since the dialog issue was fixed. I have been
> using 3.5.1 daily for Java/C/C++ projects with no issues at all.

I'm in the process on setting up an x86_64 system to see if I can track it down.

[1]
https://www.redhat.com/archives/fedora-devel-java-list/2009-October/msg00052.html
Comment 23 Ben Konrath 2009-10-28 11:28:49 EDT
(In reply to comment #20)
> Ben, do you have any SWT .so files in ~/.eclipse?  

No, the SWT shared libraries aren't in ~/.eclipse on my system.
Comment 24 Andrew Overholt 2009-10-28 14:30:30 EDT
I *finally* got rawhide x86_64 installed.  So far, I can't duplicate the problem.  I've tried adding the Pydev update site and it didn't crash (it didn't add the content but that's another issue :).  I've also created and deleted a bunch of Java projects and haven't had any issues.
Comment 25 Mat Booth 2009-10-28 14:44:27 EDT
(In reply to comment #24)
> I *finally* got rawhide x86_64 installed.  So far, I can't duplicate the
> problem.  I've tried adding the Pydev update site and it didn't crash (it
> didn't add the content but that's another issue :).  I've also created and
> deleted a bunch of Java projects and haven't had any issues.  


Does the test case attached to the upstream Eclipse ticket work on Fedora?
Comment 26 Ben Konrath 2009-10-28 14:55:08 EDT
(In reply to comment #24)
> I *finally* got rawhide x86_64 installed.  So far, I can't duplicate the
> problem.  

The crash happened for me on i686 so it may not be a 64-bit issue.

> I've tried adding the Pydev update site and it didn't crash (it
> didn't add the content but that's another issue :).

I had problems adding update sites too. Is there a bug report for this?
Comment 27 Andrew Overholt 2009-10-28 14:58:38 EDT
(In reply to comment #26)
> (In reply to comment #24)
> > I *finally* got rawhide x86_64 installed.  So far, I can't duplicate the
> > problem.  
> 
> The crash happened for me on i686 so it may not be a 64-bit issue.

Odd.

> > I've tried adding the Pydev update site and it didn't crash (it
> > didn't add the content but that's another issue :).
> 
> I had problems adding update sites too. Is there a bug report for this?  

No, I'd appreciate you filing one.  Thanks.
Comment 28 Andrew Overholt 2009-10-28 15:41:57 EDT
(In reply to comment #25)
> (In reply to comment #24)
> > I *finally* got rawhide x86_64 installed.  So far, I can't duplicate the
> > problem.  I've tried adding the Pydev update site and it didn't crash (it
> > didn't add the content but that's another issue :).  I've also created and
> > deleted a bunch of Java projects and haven't had any issues.  
> 
> 
> Does the test case attached to the upstream Eclipse ticket work on Fedora?  

No.  I've commented there.  Thanks for pointing that out, Mat.
Comment 29 nh2 2009-11-03 08:03:16 EST
See Ubuntu Bug 445009 (https://bugs.launchpad.net/bug/445009) for a possible workaround (turn of "Assistive Technologies").
Comment 30 nh2 2009-11-03 08:05:14 EST
Sorry, a typo. The URL is https://bugs.launchpad.net/bugs/445009.
Comment 31 Mads Kiilerich 2009-12-14 18:54:27 EST
*** Bug 547557 has been marked as a duplicate of this bug. ***
Comment 32 Mads Kiilerich 2009-12-14 19:03:09 EST
Quick note after looking briefly at the discussion above and the pending needinfo: I can reproduce the duplicate on bug 547557 on x86 and after having moved .eclipse away.
Comment 33 Andrew Overholt 2009-12-22 15:55:20 EST
I'm building some updated RPMs with a patch for this issue back-ported from
upstream:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1887104

If anyone can give those a shot with accessibility enabled and see if there are
still crasher bugs, I'd appreciate it.

I think bug #547056 is a dupe of this one.
Comment 34 Andrew Overholt 2009-12-22 16:56:17 EST
Oops, there was an issue with my SRPM.  Here's a better koji build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1887224
Comment 35 Mads Kiilerich 2009-12-25 12:43:33 EST
Re testing eclipse-*-3.5.1-27.fc13:

On f12 it also needs a new jetty. I tried with the one from http://koji.fedoraproject.org/koji/buildinfo?buildID=144142

It seems like the f12 pydev doesn't work with the new eclipse builds? I can only reproduce the crash with pydev.
Comment 36 Ben Konrath 2009-12-26 02:04:24 EST
I'm having the same problems as Mads - pydev is not working with 3.5.1-27.f13 and I needed to install a new version of jetty to get this eclipse version to install on f12. I see this problem with accessibility on and off.
Comment 37 Andrew Overholt 2010-01-04 08:59:06 EST
I'll try to get an F-12 build with these fixes.
Comment 38 Andrew Overholt 2010-01-05 09:06:04 EST
Please try the RPMs from this koji build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1901359

You'll have to click the link for your architecture (i686 or x86_64, for example) and then download all the RPMs listed at the bottom of that page.  Upgrade your existing package with something like:

# rpm -Uvh eclipse*3.5.1-22*.rpm

It fixes the "open update manager, click cancel -> crash" bug for me.  I'd appreciate more feedback.  Thanks.
Comment 39 Andrew Overholt 2010-01-07 09:43:13 EST
*** Bug 553256 has been marked as a duplicate of this bug. ***
Comment 40 Fabian Deutsch 2010-01-07 10:36:46 EST
Sorry, I'am on the CC list but did not receive any updates on this bug.

The koji build does not solve the problem for me.
Comment 41 Fabian Deutsch 2010-01-07 10:40:41 EST
I meant: It _does_ solve this problem.
Comment 42 Fedora Update System 2010-01-07 10:48:26 EST
eclipse-3.5.1-22.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/eclipse-3.5.1-22.fc12
Comment 43 Andrew Overholt 2010-01-07 10:55:02 EST
Thanks, Fabian.

All:  I've proposed a Bodhi update and would appreciate you providing feedback in the form of a comment and karma there:

https://admin.fedoraproject.org/updates/eclipse-3.5.1-22.fc12

Note that you must be logged in with your Fedora account for the karma to get logged with the +3 required to push the update.
Comment 44 Fedora Update System 2010-01-08 15:13:50 EST
eclipse-3.5.1-22.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update eclipse'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0353
Comment 45 Fedora Update System 2010-01-26 20:10:31 EST
eclipse-3.5.1-22.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 46 Michael Stoykov 2010-01-27 04:47:47 EST
It works for me and it had for maybe two months I obviously forgot to reported it. But I'm using rawhide and current version is 3.5.1-28.fc13.x86_64. And From the timestamp on .eclipse I have tried the 'move .eclipse folder' move more then a month before my post. Thanks for the good work :)

Note You need to log in before you can comment on or make changes to this bug.