This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 553680 - [abrt] crash in imsettings-0.107.4-5.fc12
[abrt] crash in imsettings-0.107.4-5.fc12
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: imsettings (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
abrt_hash:7bf953636d82eb0945a4a5c38e4...
:
: 564195 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-08 11:34 EST by John Watzke
Modified: 2010-02-18 17:33 EST (History)
4 users (show)

See Also:
Fixed In Version: imsettings-0.107.4-7.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-18 17:33:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (7.17 KB, text/plain)
2010-01-08 11:34 EST, John Watzke
no flags Details
.imsettings.log from user home directory (426 bytes, text/plain)
2010-01-14 14:34 EST, John Watzke
no flags Details
coredump from crash (1.10 MB, application/octet-stream)
2010-01-18 09:33 EST, John Watzke
no flags Details
File: screenshot of popup error (9.23 KB, image/png)
2010-01-18 21:27 EST, John Watzke
no flags Details
SELinux Settings (25.99 KB, image/png)
2010-02-08 12:20 EST, John Watzke
no flags Details
Backtrace of imsettings-0.107.4-5.1.fc12.x86_64 (8.63 KB, text/plain)
2010-02-08 23:10 EST, John Watzke
no flags Details
.imsettings.log for imsettings-0.107.4-5.1.fc12.x86_64 (1.70 KB, text/plain)
2010-02-08 23:15 EST, John Watzke
no flags Details
.xsession-errors from imsettings-0.107.4-5.1.fc12.x86_64 (2.15 KB, text/plain)
2010-02-08 23:18 EST, John Watzke
no flags Details
New .imsettings.log for imsettings-0.107.4-5.1.fc12.x86_64 (426 bytes, text/plain)
2010-02-10 12:06 EST, John Watzke
no flags Details
New .xsession-errors from imsettings-0.107.4-5.1.fc12.x86_64 (2.29 KB, text/plain)
2010-02-10 12:08 EST, John Watzke
no flags Details

  None (edit)
Description John Watzke 2010-01-08 11:34:23 EST
abrt 1.0.3 detected a crash.

How to reproduce
-----
1. Started machine and logged into Gnome

Comment: All I did was login to Gnome after  booting my laptop
Attached file: backtrace
cmdline: /usr/libexec/im-settings-daemon
component: imsettings
executable: /usr/libexec/im-settings-daemon
kernel: 2.6.31.9-174.fc12.x86_64
package: imsettings-0.107.4-5.fc12
rating: 4
reason: Process was terminated by signal 11 (Segmentation fault)
Comment 1 John Watzke 2010-01-08 11:34:25 EST
Created attachment 382494 [details]
File: backtrace
Comment 2 Akira TAGOH 2010-01-14 05:05:21 EST
Can you give me more information such as $HOME/.imsettings.log file and the result of "ls /etc/X11/xinit/xinput.d".

Thanks,
Comment 3 John Watzke 2010-01-14 14:34:09 EST
Created attachment 384428 [details]
.imsettings.log from user home directory
Comment 4 John Watzke 2010-01-14 14:36:18 EST
[jwatzke@jwatzke ~]$ ls -Fal /etc/X11/xinit/xinput.d/
total 20
drwxr-xr-x 2 root root 4096 2010-01-07 13:42 ./
drwxr-xr-x 5 root root 4096 2010-01-07 13:42 ../
-rw-r--r-- 1 root root  353 2009-10-13 22:09 ibus.conf
-rw-r--r-- 1 root root  249 2010-01-04 04:04 none.conf
-rw-r--r-- 1 root root 1164 2010-01-04 04:04 xim.conf
Comment 5 Akira TAGOH 2010-01-18 05:06:05 EST
Thanks.

Well, I guess from the backtrace you've experienced this crash at the startup time, but I can't reproduce this. can you 100% reproduce this? or is it just a kind of one-time error?

If you still have a core file in abrt cache, attaching it here would speeds up to investigate this issue.
Comment 6 John Watzke 2010-01-18 09:32:17 EST
It happens almost every time I boot my laptop.  I told ABRT to upload the core file so I'm surprised it didn't do that already.  I'll attach the core from the cache directory.
Comment 7 John Watzke 2010-01-18 09:33:27 EST
Created attachment 385103 [details]
coredump from crash
Comment 8 John Watzke 2010-01-18 10:34:38 EST
Okay, I booted my laptop a few times this morning.  Each time I got a crash report for imsettings.  The crash count for this morning is up to 4 now.  I've been getting them since I submitted this bug but I have been deleting the new crash reports since I've already submitted this one.
Comment 9 John Watzke 2010-01-18 21:26:53 EST
In addition to startup, I get a crash everytime I start the Input Method program from the Preferences menu.  I also get an error message.  I will attach a screenshot of the error message that pops up.  I don't get this popup on a crash caused by a system restart.
Comment 10 John Watzke 2010-01-18 21:27:31 EST
Created attachment 385300 [details]
File: screenshot of popup error
Comment 11 Akira TAGOH 2010-01-18 23:51:06 EST
(In reply to comment #9)
> In addition to startup, I get a crash everytime I start the Input Method
> program from the Preferences menu.  I also get an error message.  I will attach
> a screenshot of the error message that pops up.  I don't get this popup on a
> crash caused by a system restart.    

Apparently you didn't update im-chooser. which version do you use?
Comment 12 John Watzke 2010-01-19 09:45:36 EST
im-chooser-1.2.7-1.fc12.x86_64

I checked info and it seems this version is what came off the Fedora 12 64bit DVD.  I keep up to date so this is the latest I think.

Installed Packages
Name       : im-chooser
Arch       : x86_64
Version    : 1.2.7
Release    : 1.fc12
Size       : 252 k
Repo       : installed
From repo  : anaconda-InstallationRepo-200911081904.x86_64
Summary    : Desktop Input Method configuration tool
URL        : http://fedorahosted.org/im-chooser/
License    : GPLv2+
Description: im-chooser is a GUI configuration tool to choose the Input Method
           : to be used or disable Input Method usage on the desktop.
Comment 13 Akira TAGOH 2010-01-21 04:18:37 EST
When you saw the above error, did you try to restart the desktop after upgrading right? im-settings-daemon in imsettings-0.107.4-5.fc12 and im-chooser-1.2.7-1.fc12 is compatible and that error shouldn't happen.

To make sure, kill im-settings-daemon first and run im-chooser. it should works. I guess it may be the root cause of this problem? though it's supposed to not work with the incompatible version of the applications. so the version check as you saw should normally prevents to proceed next though.
Comment 14 John Watzke 2010-01-21 11:39:37 EST
I'm not sure what you mean about restarting the desktop after upgrading.  I typically will upgrade things during the day while I'm at work.  When I go home, I shut my laptop down and restart it in the morning.  I don't see what that has to do with the error though.

I did a ps for im-settings-daemon and it isn't running:

[jwatzke@jwatzke Desktop]$ ps -ef | grep im-settings
jwatzke   2667  2535  0 10:29 pts/0    00:00:00 grep im-settings

I executed im-chooser from the CLI and in addition to the popup message I also got the following errors output:

[jwatzke@jwatzke Desktop]$ im-chooser 

(im-chooser:2777): IMSettings-WARNING **: Failed to invoke a method `GetVersion' on com.redhat.imsettings:
  Process /usr/libexec/im-settings-daemon received signal 11

(im-chooser:2777): IMSettings-WARNING **: Failed to invoke a method `GetVersion' on com.redhat.imsettings:
  Process /usr/libexec/im-settings-daemon received signal 11
Comment 15 Akira TAGOH 2010-01-21 20:51:59 EST
Ah, okay. thanks. that explains why you've seen the error dialog. I see.
Comment 16 Akira TAGOH 2010-01-22 02:02:03 EST
What if you run /usr/libexec/xinputinfo.sh?
Comment 17 John Watzke 2010-01-22 11:28:51 EST
[jwatzke@jwatzke ~]$ /usr/libexec/xinputinfo.sh
AUXILIARY_PROGRAM=
AUXILIARY_ARGS=""
GTK_IM_MODULE=ibus
ICON=/usr/share/icons/hicolor/scalable/apps/ibus.svg
IMSETTINGS_IGNORE_ME=
LONG_DESC=""
QT_IM_MODULE=
PREFERENCE_PROGRAM=/usr/bin/ibus-setup
PREFERENCE_ARGS=""
SHORT_DESC="IBus"
XIM=ibus
XIM_PROGRAM=/usr/bin/ibus-daemon
XIM_ARGS="--xim"
IMSETTINGS_IS_SCRIPT=1
Comment 18 Akira TAGOH 2010-02-05 03:23:22 EST
Hmm, I got confused. the above result doesn't explain why you saw XMODIFIERS: @im=none in your .imsettings.log. guess you have made any changes there?

Anyway I can't still reproduce this issue here. give me more information to build similar environment here:

1. what LANG do you use?
2. do you have $HOME/.xinputrc?
3. as per Comment #17, your /etc/X11/xinit/xinputrc points to /etc/X11/xinit/xinput.d/ibus.conf right?


FWIW I have built testing package at http://koji.fedoraproject.org/koji/taskinfo?taskID=1964273
I don't think this actually helps this issue but would just hide it. you may see some warnings in $HOME/.imsettings.log or $HOME/.xsession-errors instead of crashes.
Comment 19 John Watzke 2010-02-05 10:47:09 EST
No, I haven't modified anything related to imsettings.  This just started happening on its own one day.

Here's the answer to your questions:

1) [jwatzke@jwatzke Desktop]$ echo $LANG
en_US.UTF-8

2) [jwatzke@jwatzke Desktop]$ ls -Fal $HOME/.xinputrc
ls: cannot access /home/jwatzke/.xinputrc: No such file or directory

3) [jwatzke@jwatzke Desktop]$ ls -Fal /etc/X11/xinit/xinputrc
lrwxrwxrwx 1 root root 26 2010-02-05 08:51 /etc/X11/xinit/xinputrc -> /etc/alternatives/xinputrc

So I don't have an .xinputrc and /etc/X11/xinit/xinputrc doesn't appear to point to /etc/alternatives/xinputrc.

This is the contents of my xinputrc:

XIM=ibus
XIM_PROGRAM="/usr/bin/ibus-daemon"
ICON="/usr/share/icons/hicolor/scalable/apps/ibus.svg"
XIM_ARGS="--xim"
PREFERENCE_PROGRAM=/usr/bin/ibus-setup
SHORT_DESC="IBus"
GTK_IM_MODULE=ibus

if test -f /usr/lib/qt4/plugins/inputmethods/libqtim-ibus.so || \
   test -f /usr/lib64/qt4/plugins/inputmethods/libqtim-ibus.so;
then
    QT_IM_MODULE=ibus
fi

I can try out your test package sometime.  I'd rather not cover up the errors just yet while we try to debug the problem.  I've been watching ABRT to see if it magically goes away after a typical Fedora update flurry.
Comment 20 Akira TAGOH 2010-02-08 07:55:26 EST
FWIW does it work if you disable or change to the permissive mode on SELinux?
Comment 21 John Watzke 2010-02-08 12:20:19 EST
I'll attach a screenshot of the SELinux admin panel so you can see my settings.  I have SELinux disabled because I run wine for a bunch of different applications and SELinux can cause issues with wine.
Comment 22 John Watzke 2010-02-08 12:20:46 EST
Created attachment 389580 [details]
SELinux Settings
Comment 23 John Watzke 2010-02-08 12:22:44 EST
Okay, I attached the screenshot.  Let me know if you want me to change any of these settings (and what you want me to set them to) and test if this issue goes away.
Comment 24 Akira TAGOH 2010-02-08 21:02:28 EST
Hmm, so you see "Disabled" when you run "getenforce" command at the terminal but you still see this problem right?

how about the testing package at Comment #18 btw?
Comment 25 John Watzke 2010-02-08 22:40:08 EST
This is what I get when I run that command:

[jwatzke@jwatzke ~]$ getenforce
Disabled

I can try this test package.  I will see if I get errors when it starts up.
Comment 26 John Watzke 2010-02-08 23:09:32 EST
I installed the test package and when I restart my system or try to start the input settings application I get a crash and I get warnings in these logs.  I am going to upload the new backtrace and log files with warnings in it.
Comment 27 John Watzke 2010-02-08 23:10:55 EST
Created attachment 389667 [details]
Backtrace of imsettings-0.107.4-5.1.fc12.x86_64
Comment 28 John Watzke 2010-02-08 23:15:15 EST
Created attachment 389668 [details]
.imsettings.log for imsettings-0.107.4-5.1.fc12.x86_64
Comment 29 John Watzke 2010-02-08 23:18:25 EST
Created attachment 389669 [details]
.xsession-errors from imsettings-0.107.4-5.1.fc12.x86_64
Comment 30 Akira TAGOH 2010-02-09 01:46:51 EST
Hmm, could you please keep consistency on the information you provided? I'm getting confused with:

IMSettings[1826]: WARNING **: Broken config file or unable to read: /etc/X11/xinit/xinput.d/scim.conf

Since we have confirmed at comment #4 you have only ibus and built-in config files in imsettings installed. I want to see the result for that...
Comment 31 Akira TAGOH 2010-02-09 02:25:24 EST
To make sure, I hope you don't see any outputs with rpm -V imsettings ibus scim say.
Comment 32 John Watzke 2010-02-09 14:47:24 EST
I am keeping the environment consistent.  If you recall from comment 19, I didn't want to touch even the imsettings test package because I didn't want to change the environment but you insisted that I try it.  I don't know why you see that message in .imsettings.log but I have not touched scim.conf at all or anything else.  I was just as surprised as you are that there are new warnings in this log file that were not there before.  You stated that I might see new warnings in these particular logs (see comment 18) when I install the test package which is why I presented these logs to you.  That new message just started showing up in the log and I haven't modified anything related to imsettings other than updating to the test package you asked me to use.  I have picked up bug fixes from fedora-updates as time goes on but none of these updates were imsettings updates.

Here is the output of 'rpm -V imsettings ibus scim'.  There are imsettings changes which are probably expected since I updated to the test package.  There is an ibus and scim-panel-gtk which might have been a result of something coming from fedora-updates.

[jwatzke@jwatzke Desktop]$ rpm -V imsettings ibus scim
prelink: /usr/bin/imsettings-applet: at least one of file's dependencies has changed since prelinking
S.?......    /usr/bin/imsettings-applet
prelink: /usr/bin/imsettings-info: at least one of file's dependencies has changed since prelinking
S.?......    /usr/bin/imsettings-info
prelink: /usr/bin/imsettings-list: at least one of file's dependencies has changed since prelinking
S.?......    /usr/bin/imsettings-list
prelink: /usr/bin/imsettings-reload: at least one of file's dependencies has changed since prelinking
S.?......    /usr/bin/imsettings-reload
prelink: /usr/bin/imsettings-restart: at least one of file's dependencies has changed since prelinking
S.?......    /usr/bin/imsettings-restart
prelink: /usr/bin/imsettings-start: at least one of file's dependencies has changed since prelinking
S.?......    /usr/bin/imsettings-start
prelink: /usr/bin/imsettings-stop: at least one of file's dependencies has changed since prelinking
S.?......    /usr/bin/imsettings-stop
prelink: /usr/bin/imsettings-xim: at least one of file's dependencies has changed since prelinking
S.?......    /usr/bin/imsettings-xim
prelink: /usr/libexec/gconf-im-settings-daemon: at least one of file's dependencies has changed since prelinking
S.?......    /usr/libexec/gconf-im-settings-daemon
prelink: /usr/libexec/im-settings-daemon: at least one of file's dependencies has changed since prelinking
S.?......    /usr/libexec/im-settings-daemon
prelink: /usr/bin/ibus-daemon: at least one of file's dependencies has changed since prelinking
S.?......    /usr/bin/ibus-daemon
prelink: /usr/libexec/ibus-gconf: at least one of file's dependencies has changed since prelinking
S.?......    /usr/libexec/ibus-gconf
prelink: /usr/libexec/ibus-x11: at least one of file's dependencies has changed since prelinking
S.?......    /usr/libexec/ibus-x11
prelink: /usr/lib64/scim-1.0/scim-panel-gtk: at least one of file's dependencies has changed since prelinking
S.?......    /usr/lib64/scim-1.0/scim-panel-gtk

   Do you need me to rerun prelink?
Comment 33 John Watzke 2010-02-09 14:53:54 EST
I redid the command I had in comment #4.

[jwatzke@jwatzke Desktop]$ ls -Fal /etc/X11/xinit/xinput.d/
total 24
drwxr-xr-x 2 root root 4096 2010-02-08 21:53 ./
drwxr-xr-x 5 root root 4096 2010-02-08 21:53 ../
-rw-r--r-- 1 root root  353 2009-10-13 22:09 ibus.conf
-rw-r--r-- 1 root root  249 2010-02-05 02:11 none.conf
-rw-r--r-- 1 root root  749 2008-10-05 07:03 scim.conf
-rw-r--r-- 1 root root 1164 2010-02-05 02:11 xim.conf

So there is an scim.conf now.  I didn't knowingly install this.  The date is really old (older than this new laptop) so I would guess this was placed here by a package install.  Perhaps I installed some other tool and this was pulled in as a dependency?  I don't know what xim and scim are so it is possible that I wasn't aware that this dependency was being installed.  As I said before, I'm not currently using any input method functionality so the configuration for all of this is as it would be in a vanilla install of Fedora 12 x84_64.

If it is safe and you would recommend it, I can remove scim if it isn't being forced as a dependency by something else.
Comment 34 Akira TAGOH 2010-02-09 23:34:20 EST
Okay. I should explain earlier what exactly I changed in the testing package. the main purpose of this package is to gather more information and see what exactly happened on your machine. new warnings are introduced by this change. so no wonder even if it's new.  what I meant at comment #30 is, the warning message complained about scim.conf which didn't appears at comment #9. which is unlikely unless you copy-and-paste it partially or install it later. so I didn't expect if it's there and didn't test it at all. since I'm hard working to reproduce your problem here, missing/inaccurate information makes it harder.

Anyway, the result of 'rpm -V' might be a good information. you better rerun prelink.

(In reply to comment #33)
> So there is an scim.conf now.  I didn't knowingly install this.  The date is
> really old (older than this new laptop) so I would guess this was placed here
> by a package install.  Perhaps I installed some other tool and this was pulled
> in as a dependency?  I don't know what xim and scim are so it is possible that
> I wasn't aware that this dependency was being installed.  As I said before, I'm
> not currently using any input method functionality so the configuration for all
> of this is as it would be in a vanilla install of Fedora 12 x84_64.
> 
> If it is safe and you would recommend it, I can remove scim if it isn't being
> forced as a dependency by something else.    

Since you don't use any Input Methods anymore, you can safely remove any IM packages though, FYI our default IM is now ibus. so you can get rid of scim unless you particularly need it.
Comment 35 John Watzke 2010-02-10 11:39:47 EST
Okay, let me remove SCIM.  I think I know what might have added SCIM.  I was playing around with pinyin (I was trying to learn Chinese) and I added a few different on-screen keyboards to my system.  I work with many people in China and I wanted to be able to type "Thank you" and "You are welcome" in my notes.  I think one of these on-screen keyboards may have pulled in SCIM.  Let me remove SCIM and get us back to where we were when we started.  I will also rerun prelink.

I don't really understand what XIM, IBUS, and SCIM actually do.  I was just trying to get an onscreen keyboard with Chinese characters in them.  Once we figure out this issue, I can experiment with the on-screen keyboards later.
Comment 36 John Watzke 2010-02-10 12:05:10 EST
Okay, I have removed SCIM and prelinked everything.  I don't get a crash now.  Let me show the commands you wanted to see previously:

[jwatzke@jwatzke ~]$ rpm -V imsettings ibus scim
package scim is not installed

[jwatzke@jwatzke ~]$ ls -Fal /etc/X11/xinit/xinput.d/
total 20
drwxr-xr-x 2 root root 4096 2010-02-10 10:46 ./
drwxr-xr-x 5 root root 4096 2010-02-10 10:46 ../
-rw-r--r-- 1 root root  353 2009-10-13 22:09 ibus.conf
-rw-r--r-- 1 root root  249 2010-02-05 02:11 none.conf
-rw-r--r-- 1 root root 1164 2010-02-05 02:11 xim.conf

And I will upload new .imsettings and .xsession-errors logs.
Comment 37 John Watzke 2010-02-10 12:06:08 EST
Created attachment 390056 [details]
New .imsettings.log for imsettings-0.107.4-5.1.fc12.x86_64
Comment 38 John Watzke 2010-02-10 12:08:26 EST
Created attachment 390058 [details]
New .xsession-errors from imsettings-0.107.4-5.1.fc12.x86_64
Comment 39 John Watzke 2010-02-10 12:10:20 EST
The .xsession-errors logs suggests that I run "imsettings-reload -f" to fix the errors.  Would you recommend this or do you have any other ideas before I run this?
Comment 40 John Watzke 2010-02-11 11:31:11 EST
As an update, although I don't get a crash at startup, I still cannot run the Input Method application under "Preferences".
Comment 41 Akira TAGOH 2010-02-11 23:46:02 EST
That looks like im-settings-daemon is still segfaulting. please try this and see how it goes:

1. run "gdb --args /usr/libexec/im-settings-daemon --replace"
2. "run" at the gdb prompt.
3. run im-chooser
4. "thread apply all bt" at the gdb prompt when the segfault happens.
Comment 42 Akira TAGOH 2010-02-11 23:54:44 EST
*** Bug 564195 has been marked as a duplicate of this bug. ***
Comment 43 John Watzke 2010-02-12 12:26:16 EST
   I get a segfault as soon as I enter "run" in gdb.  There appears to be an issue in the daemon itself.  I guess ABRT isn't catching the segfault that happens when the daemon starts.  I couldn't get a debuginfo for libudev so if you know where to find one I can install that if it will help debug this problem further.

Detaching after fork from child process 3016.
sh: /usr/libexec/xinputinfo.sh[23]: syntax error: `(' unexpected
Detaching after fork from child process 3017.
sh: /usr/libexec/xinputinfo.sh[23]: syntax error: `(' unexpected

Program received signal SIGSEGV, Segmentation fault.
0x0000000000404989 in imsettings_monitor_add_file (monitor=
    0x621810 [IMSettingsMonitor], filename=
    0x62a6b0 "/etc/X11/xinit/xinput.d/none.conf", force=0) at monitor.c:846
846			if (strcmp(name, IMSETTINGS_NONE_CONF) == 0 &&
Missing separate debuginfos, use: debuginfo-install libudev-145-14.fc12.x86_64
(gdb) thread apply all bt

Thread 1 (Thread 0x7ffff7fc37c0 (LWP 3012)):
#0  0x0000000000404989 in imsettings_monitor_add_file (monitor=
    0x621810 [IMSettingsMonitor], filename=
    0x62a6b0 "/etc/X11/xinit/xinput.d/none.conf", force=0) at monitor.c:846
#1  0x0000000000406837 in _imsettings_monitor_start_for_xinputdir (monitor=
    0x621810 [IMSettingsMonitor]) at monitor.c:566
#2  imsettings_monitor_start (monitor=0x621810 [IMSettingsMonitor])
    at monitor.c:1109
#3  0x000000000040732e in main (argc=1, argv=0x7fffffffe5a8) at factory.c:1502
Comment 44 Akira TAGOH 2010-02-14 23:34:31 EST
Thanks. hmm, I see same error when running xinputinfo.sh with dash though, I don't know why you got the syntax error in it even though the shebang specifies /bin/bash.

Have you changed anything related to the shell?
Comment 45 John Watzke 2010-02-15 11:33:18 EST
Not that I'm aware of.  It's just the plain bash that comes with FC12.
Comment 46 Akira TAGOH 2010-02-15 21:36:51 EST
how about /bin/sh?
Comment 47 John Watzke 2010-02-15 22:12:24 EST
Bash and sh are the same as what is currently packaged with FC12.  The only thing I've added that is remotely related to shells is pdksh.  I had to add the i686 version to my system so I could install Oracle 11g for development purposes.  I don't think installing another shell would cause a problem with the other two shells especially when it's not related to the other shells.  PDKSH is the public domain Korne shell.  If it were to mess up a shell I would expect it to interfere with ksh or mksh.
Comment 48 Akira TAGOH 2010-02-16 00:57:32 EST
Hmm. but as the prefix says, that error came from /bin/sh though. can you give more details for that?

1. ls -l /bin/sh
2. getent passwd <yourusername>|cut -d: -f7

FWIW changing /bin/sh to mksh say, I can finally reproduce this issue though.
Comment 49 Akira TAGOH 2010-02-16 02:27:17 EST
should be fixed in imsettings-0.107.4-7.fc12.
Comment 50 Fedora Update System 2010-02-16 02:29:27 EST
imsettings-0.107.4-7.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/imsettings-0.107.4-7.fc12
Comment 51 John Watzke 2010-02-16 12:13:45 EST
Good to see you have a patch.  I'll try it out.  Here is the info you requested:

[jwatzke@jwatzke ~]$ ls -l /bin/sh
lrwxrwxrwx 1 root root 3 2009-12-17 14:34 /bin/sh -> ksh
[jwatzke@jwatzke ~]$ getent passwd jwatzke | cut -d: -f7
/bin/bash

All I can say is "What the heck?"  I guess installing pdksh actually modified /bin/sh to point to ksh?  I didn't expect that and it annoys me that it would change the shell like that.  But, it does sound like this upsets imsettings.  Good to have made some progress here.
Comment 52 John Watzke 2010-02-16 17:10:02 EST
I've tested out the new packages.  I am able to start imchooser without a problem and I don't get any errors related to starting it.

imsettings information
==========================
Is DBus enabled:yes
Is imsettings enabled:yes
Is GTK+ supported:yes
Is Qt supported:no
DESKTOP_SESSION: gnome
DISABLE_IMSETTINGS:
IMSETTINGS_DISABLE_DESKTOP_CHECK:
DBUS_SESSION_BUS_ADDRESS: unix:abstract=/tmp/dbus-9UCMmTSEfF,guid=495bab4d19b3a7a23833c7ff4b7b1674
GTK_IM_MODULE:
QT_IM_MODULE: xim
XMODIFIERS: @im=none
IMSETTINGS_MODULE: none
IMSETTINGS_INTEGRATE_DESKTOP: yes


IM-Settings-Daemon[2116]: WARNING **: Unable to monitor /home/jwatzke/.xinputrc: Error stating file '/home/jwatzke/.xinputrc': No such file or directory
IM-Settings-Daemon[2116]: INFO: Current IM is: none
===========================

The errors that were present in .xsession-errors for imsettings have also gone away.  Looks good.  Nice job!
Comment 53 Fedora Update System 2010-02-17 03:48:51 EST
imsettings-0.107.4-7.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/imsettings-0.107.4-7.fc12
Comment 54 Fedora Update System 2010-02-18 17:33:47 EST
imsettings-0.107.4-7.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.