Bug 553889 - [abrt] crash detected in compiz-0.8.2-21.fc12 #0 videoDrawWindow () at video.c:516 (after root authentication in gpk-application)
[abrt] crash detected in compiz-0.8.2-21.fc12 #0 videoDrawWindow () at video...
Status: CLOSED DUPLICATE of bug 550897
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
abrt_hash:9ca7c7c9fab254939c22cef9421...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-09 05:34 EST by Loki
Modified: 2010-01-11 01:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-11 01:39:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (19.25 KB, text/plain)
2010-01-09 05:34 EST, Loki
no flags Details

  None (edit)
Description Loki 2010-01-09 05:34:37 EST
abrt 1.0.0 detected a crash.

How to reproduce
-----
1.  have compiz running
2.  open the package manager GUI, select some packages to install and click apply
3.  compiz crashes after root auth

Comment
-----
happens with either window decorator
doesn't seem to happen every single time, still trying to figure out when it does and doesn't

Attached file: backtrace
cmdline: compiz --replace --sm-disable --ignore-desktop-hints ccp
component: compiz
executable: /usr/bin/compiz
kernel: 2.6.31.9-174.fc12.x86_64
package: compiz-0.8.2-21.fc12
rating: 4
reason: Process was terminated by signal 11
Comment 1 Loki 2010-01-09 05:34:42 EST
Created attachment 382628 [details]
File: backtrace
Comment 2 Hamidou Dia 2010-01-11 01:39:17 EST
Hi Loki,

Many thanks for the report and the detailed description:

Indeed, so far for what I saw : 

It looks like there is definitively a bug around - a kind of race condition (that why maybe it is difficult to trigger):

https://bugzilla.redhat.com/show_bug.cgi?id=550897 reported exactly the same issue as your

"
Comment: Using apk-application, I was trying to install a package. The
authentication dialog appeared, and compiz crashed.
"

But the interesting thing is that the backtrace is not exactly the same :

"
#0  obsDrawWindow (w=0x2cd9220, transform=0x7fff11dd9fc0, 
    attrib=0x7fff11dd9f60, region=0x63c180, mask=196608) at obs.c:250
250		if (ow->customFactor[i] != 100)
" 

while your one
"
#0  videoDrawWindow (w=0x556c600, transform=<value optimized out>, attrib=
    0x7fff15f03330, region=0x63c180, mask=196608) at video.c:516
516		    CompTexture *texture = &vw->context->source->texture->texture;

"
but with the call to obsDrawWindow at frame #3.

FYI:

https://bugzilla.redhat.com/show_bug.cgi?id=548312 which is one of the BZ#550897 's  duplicate (exactly same backtrace) got:

"Comment: Closed terminal window with Compiz running.  Unsure of what caused
the
issue, running multiple things at once."

So this comment might give a hint about how to trigger this.

I am closing your ticket as duplicate of 550897.

Regards.
And happy new year 2010.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 550897 ***

Note You need to log in before you can comment on or make changes to this bug.