Bug 553945 - F12 - KDE - Gstreamer backend works, Xine (the default) doesn't
Summary: F12 - KDE - Gstreamer backend works, Xine (the default) doesn't
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: phonon
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 558311 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-09 17:20 UTC by Gerald Cox
Modified: 2010-02-26 07:23 UTC (History)
10 users (show)

Fixed In Version: 4.3.80-5.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-28 00:57:52 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 223662 None None None Never

Description Gerald Cox 2010-01-09 17:20:51 UTC
Description of problem:
Just upgraded to F12 and noticed some weirdness with my sound, long
story short, the Gstreamer backend appears to work fine, the Xine
doesn't.  If I select the Xine backend, no sound.  If I select the Gstreamer backend, sound appears fine.  


Version-Release number of selected component (if applicable):

phonon-backend-gstreamer-4.3.80-2.fc12.x86_64
phonon-backend-xine-4.3.80-2.fc12.x86_64
phonon-4.3.80-2.fc12.x86_64

and my xine levels are:

xine-plugin-1.0.2-3.fc12.x86_64
xine-lib-extras-1.1.16.3-5.fc12.x86_64
xine-lib-extras-freeworld-1.1.16.3-2.fc12.x86_64
xine-ui-skins-0.99.5-16.fc12.noarch
xine-lib-1.1.16.3-5.fc12.x86_64
xinetd-2.3.14-28.fc12.x86_64
xine-lib-devel-1.1.16.3-5.fc12.x86_64
phonon-backend-xine-4.3.80-2.fc12.x86_64
xine-ui-0.99.5-16.fc12.x86_64

How reproducible:
Use the KDE interface to switch backend between Xine and Gstreamer

Steps to Reproduce:
1. Switch backend to Xine (which was the default)

  
Actual results:  No sound


Expected results:  Sound


Additional info:

lsmod output:

Module                  Size  Used by
fuse                   62064  2      
sunrpc                191912  1      
ipv6                  298896  36     
cpufreq_ondemand        7824  1      
powernow_k8            17332  1      
freq_table              4864  2 cpufreq_ondemand,powernow_k8
dm_multipath           17304  0                             
uinput                  9248  0                             
snd_hda_codec_realtek   281380  1                           
lgdt330x                9268  1                             
cx88_dvb               22884  0                             
cx88_vp3054_i2c         2896  1 cx88_dvb                    
videobuf_dvb            7380  1 cx88_dvb                    
dvb_core               89712  3 lgdt330x,cx88_dvb,videobuf_dvb
tuner_simple           13476  2                               
tuner_types            18208  1 tuner_simple                  
tda9887                10836  2                               
tda8290                11716  0                               
tuner                  19996  2                               
snd_hda_intel          30360  5                               
cx8800                 33836  0                               
cx88_alsa              12392  2                               
cx8802                 16036  1 cx88_dvb                      
snd_hda_codec          72832  2 snd_hda_codec_realtek,snd_hda_intel
firewire_ohci          23332  0                                    
cx88xx                 77900  4 cx88_dvb,cx8800,cx88_alsa,cx8802   
snd_seq                58080  0                                    
snd_usb_audio          97200  2                                    
ir_common              44980  1 cx88xx                             
snd_usb_lib            17664  1 snd_usb_audio                      
v4l2_common            16800  3 tuner,cx8800,cx88xx
snd_pcm                83144  5 snd_hda_intel,cx88_alsa,snd_hda_codec,snd_usb_audio
snd_rawmidi            24032  1 snd_usb_lib
uvcvideo               58972  0
tveeprom               13828  1 cx88xx
snd_seq_device          7620  2 snd_seq,snd_rawmidi
snd_timer              22608  2 snd_seq,snd_pcm
snd_hwdep               9224  2 snd_hda_codec,snd_usb_audio
amd64_edac_mod         29632  0
firewire_core          47880  1 firewire_ohci
videobuf_dma_sg        12292  5 cx88_dvb,cx8800,cx88_alsa,cx8802,cx88xx
edac_core              43516  1 amd64_edac_mod
videodev               36160  5 tuner,cx8800,cx88xx,v4l2_common,uvcvideo
snd                    67592  29 snd_hda_codec_realtek,snd_hda_intel,cx88_alsa,snd_hda_codec,snd_seq,snd_usb_audio,snd_usb_lib,snd_pcm,snd_rawmidi,snd_seq_device,snd_timer,snd_hwdep
forcedeth              54764  0
v4l1_compat            13892  2 uvcvideo,videodev
videobuf_core          16612  5 videobuf_dvb,cx8800,cx8802,cx88xx,videobuf_dma_sg
v4l2_compat_ioctl32    10736  1 videodev
crc_itu_t               2080  1 firewire_core
k8temp                  5344  0
btcx_risc               4712  4 cx8800,cx88_alsa,cx8802,cx88xx
snd_page_alloc          9568  2 snd_hda_intel,snd_pcm
i2c_nforce2             9048  0
soundcore               7328  1 snd
ata_generic             5924  0
pata_acpi               5152  0
pata_jmicron            4016  0
3w_9xxx                33684  4
pata_amd               14260  0
radeon                514128  2
ttm                    41952  1 radeon
drm_kms_helper         25376  1 radeon
drm                   172416  4 radeon,ttm,drm_kms_helper
i2c_algo_bit            6020  3 cx88_vp3054_i2c,cx88xx,radeon
i2c_core               28928  15 lgdt330x,cx88_vp3054_i2c,tuner_simple,tda9887,tda8290,tuner,cx8800,cx88xx,v4l2_common,tveeprom,videodev,i2c_nforce2,radeon,drm,i2c_algo_bit

Comment 1 Anne 2010-01-09 18:47:15 UTC
I had no sound problems with F12 until I upgraded to KDE 4.3.90 (4.4 RC1).  At that point sound notifications stopped.  I discovered that feedback howl happened with volumes =>50% and in found that the optimum level was 41% (checked in alsamixer text mode).  I had been using he xine backend.  Changing it to gstreamer brought back notifications, but the low volume problem persists.

Comment 2 Steven M. Parrish 2010-01-12 14:02:42 UTC
Thank you for taking the time to report this issue to us.  This is an issue which is best addressed by the upstream developers.

Please file a report at bugs.kde.org , and when done add the upstream report info to this report.

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.

This bug has been triaged

Steven M. Parrish
KDE & Packagekit Triager 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Rex Dieter 2010-01-21 12:59:39 UTC
Looks like we can track the issue here,
https://bugs.kde.org/show_bug.cgi?id=223662

Comment 4 Rex Dieter 2010-01-21 13:54:41 UTC
See also,
http://qa.mandriva.com/show_bug.cgi?id=56807

Comment 5 Rex Dieter 2010-01-21 14:11:46 UTC
Sorry, the mandriva link was meant for bug #539297 as it pertains to gstreamer, not xine.

Comment 6 Kevin Kofler 2010-01-22 01:13:24 UTC
4.3.80-5 has the patch from upstream which should fix this (thanks Rex).

Comment 7 Anne 2010-01-22 10:36:24 UTC
Confirmed that xine backend is now working (and amarok output restored).  Thanks

Comment 8 Fedora Update System 2010-01-22 14:16:41 UTC
phonon-4.3.80-5.fc12,kdebase-runtime-4.3.4-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/phonon-4.3.80-5.fc12,kdebase-runtime-4.3.4-3.fc12

Comment 9 Rex Dieter 2010-01-24 22:17:10 UTC
*** Bug 558311 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2010-01-26 01:00:26 UTC
phonon-4.3.80-5.fc12, kdebase-runtime-4.3.4-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update phonon kdebase-runtime'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1030

Comment 11 Anne 2010-01-26 16:10:18 UTC
Running phonon-4.3.80-5.fc12, kdebase-runtime-4.3.4-3.fc12, the xine backend works perfectly.  What's more it has cured the problem I had in Amarok where only one track at a time would play, so that it was necessary to start each track manually.  Now the tracks play consecutively without intervention, as they used it.

Thanks for the fix

Comment 12 Kornienko Sergey 2010-01-27 22:38:59 UTC
su -c 'yum --enablerepo=updates-testing update phonon kdebase-runtime'
Thanks, this fix work fo me too ! :)

Comment 13 Fedora Update System 2010-01-28 00:57:43 UTC
phonon-4.3.80-5.fc12, kdebase-runtime-4.3.4-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Pekka Savola 2010-02-26 07:23:42 UTC
After the initial update, my sound with xine (when run from command line) was lost, and did not come back after the latest update.  It works if I force audio driver to alsa instead of pulseaudio.

This may be a different issue so I reported it as #568630.


Note You need to log in before you can comment on or make changes to this bug.