Bug 554210 - request: flex 2.5.33 or newer
Summary: request: flex 2.5.33 or newer
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: flex
Version: 5.4
Hardware: All
OS: Linux
Target Milestone: rc
: ---
Assignee: Petr Machata
QA Contact: qe-baseos-tools
Depends On:
Blocks: 5.6RelNotes
TreeView+ depends on / blocked
Reported: 2010-01-10 23:06 UTC by Todd
Modified: 2015-05-05 01:35 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Clone Of:
Last Closed: 2013-03-13 04:11:20 UTC
Target Upstream Version:

Attachments (Terms of Use)

Description Todd 2010-01-10 23:06:35 UTC
Hi All,

I am coming from the CentOS 5.4 side.

As of wine-1.1.36.tar.bz2, the "Wine" folks have added a requirement for "flex 2.5.33 or newer" to their requirements list to compile Wine.

They will not budge on backing off on the requirement.  See: http://bugs.winehq.org/show_bug.cgi?id=21288#c3

Would you please consider doing a more modern RPM of "flex" so we can compile wine-1.1.36.tar.bz2 under CentOS 5.4?

The RPM from Fedora Core 7 (flex-2.5.33-9.fc7.i386.rpm) works perfectly with CentOS 5.4.  It should be pretty easy to migrate to RHEL 5.4.  

Many thanks,

Wine Installer v1.0
checking whether flex is recent enough... no
configure: error: Your flex version is too old. Please install flex version 2.5.33 or newer.

# yum install flex
Package flex-2.5.4a-41.fc6.i386 already installed and latest version
Nothing to do

Comment 1 Petr Machata 2010-01-11 18:03:26 UTC
I agree that flex-2.5.4a is quite ancient and lacks important features.  flex 2.5.30+ has been in Fedora since Jan 2007, which is three years now.  By that time the 2.5.30 line wasn't even recent anymore.

Still, several bugs were reported during the fallout of the rebase and fixed, meaning the rebase wasn't "seamless" and software wasn't universally ready to deal with newer version of flex.  Some packages were likely adapted to new flex without my knowing, working around stuff that doesn't work or that changed.

So while I'm backing the proposal to rebase flex to newer version, I also maintain that we have to ship compat-flex package with the original version of flex.  FWIW that's the setup seen in Fedora distros, and that's what will most probably be in RHEL 6.

Comment 3 Thomas E. Dickey 2010-01-12 01:08:19 UTC
Agree ("new" flex isn't really compatible with 2.5.4a).

Reading the upstream comment, it turns out that a developer
chose to require "new" flex to save 5 lines of code.

Comment 5 AD 2010-03-04 23:23:28 UTC
Keep this bug in mind also: https://bugzilla.redhat.com/show_bug.cgi?id=570661

Comment 7 RHEL Program Management 2010-08-09 19:06:46 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 8 Dominik 'Rathann' Mierzejewski 2012-11-13 13:48:49 UTC
libnl3 doesn't build with old flex, so I'd appreciate it if this could move forward. I'll talk to libnl upstream in the meantime.

Comment 9 Jeff Law 2013-03-13 04:11:20 UTC
Closing as rebasing tools is not appropriate for this stage of Red Hat Enterprise Linux 5.

FWIW, Red Hat Enterprise Linux 6 contains flex-2.5.35.

Note You need to log in before you can comment on or make changes to this bug.