Bug 55445 - php fails to rebuild
Summary: php fails to rebuild
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: autoconf
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 56475 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-31 13:04 UTC by Bernhard Rosenkraenzer
Modified: 2007-04-18 16:37 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-11-28 08:25:52 UTC


Attachments (Terms of Use)

Description Bernhard Rosenkraenzer 2001-10-31 13:04:57 UTC
Description of Problem:
./buildconf in the php source tree fails when trying to generate the
configure script.

aclocal.m4:814: error: m4_defn: undefined macro: _m4_divert_diversion
aclocal.m4:360: PHP_SUBST is expanded from...
aclocal.m4:814: the top level

The aclocal.m4 code looks ok, though, and the maintainers say it's working
with stock autoconf 2.52.

Version-Release number of selected component (if applicable):
2.52-3

How Reproducible:
100%

Steps to Reproduce:
1.  rpm --rebuild php-4.0.6-9.src.rpm

Comment 1 Jens Petersen 2001-11-01 08:56:50 UTC
Well, autoconf-2.52-1 is stock autoconf AFAIK (there are no patches applied
anyway), but I can reproduce it perfectly with 2.52-1 too.

Comment 2 Jens Petersen 2001-11-28 08:25:46 UTC
*** Bug 56475 has been marked as a duplicate of this bug. ***

Comment 3 Jens Petersen 2001-12-21 09:19:08 UTC
Can't reproduce this any longer with the current autotools (autoconf-2.52-5,
automake-1.5-1 and libtool-1.4.2-3).


Note You need to log in before you can comment on or make changes to this bug.