This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 55447 - login does not set the controlling tty for the shell
login does not set the controlling tty for the shell
Status: CLOSED DUPLICATE of bug 54960
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-31 08:43 EST by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-31 08:43:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-31 08:43:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
Shells started by login do not have a controlling tty
(ie, open of /dev/tty fails in the shell).
Problem introduced in  util-linux-2.11f-11.7.1 (not
present in util-linux-2.10s-13.7).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install pdksh (or ash) rpm
2.set your shell to ksh (or ash)
3.log in on one of the virtual consoles
4. cat /dev/tty
	

Actual Results:  cat failed saying no such device or address

Expected Results:  cat should have been able to open the device.

Additional info:

Guess at the cause: One of the patches in the latest util-linux package
(util-linux-2.11f-logingrp-revert.patch) removes code
which drops the previous controlling tty just before opening
the new tty, with the result that the open does not cause the
new tty to become the controlling tty.
Comment 1 Elliot Lee 2001-10-31 10:06:48 EST

*** This bug has been marked as a duplicate of 54960 ***
Comment 2 Need Real Name 2001-10-31 18:32:05 EST
Both bugs 54960 and this one, 55447, are marked as closed/duplicate - is
there a fix or has it fallen through a crack?
Comment 3 Elliot Lee 2001-10-31 18:37:01 EST
There's a fix in rawhide (util-linux-2.11f-15).

Note You need to log in before you can comment on or make changes to this bug.