Bug 55485 - TrueType fonts missing in Qt apps
TrueType fonts missing in Qt apps
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: qt (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
: 32131 53890 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-31 20:52 EST by jmbastia
Modified: 2007-04-18 12:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-05 10:14:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jmbastia 2001-10-31 20:52:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686)

Description of problem:
After upgrading to RedHat 7.2, many of my TrueType fonts are "missing" in
applications using the Qt libraries.  'xlsfonts' still lists all my fonts
as there, but they do not show up as available fonts to choose from in any
of KDE or its apps, nor in programs like LICQ with the Qt plugin.

However, the fonts do show up in apps that use other libraries, such as
Gtk+.  The Gimp, gedit, gnotepad+, Netscape (uses Motif?), etc, show all of
the available fonts as expected.

The TrueType versions of Times New Roman, Courier New, and Arial are much
easier on the eyes than the Adobe Type1 versions, and it's making KDE and
LICQ hard to look at.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start any Qt-based app
2. Use the app's settings to try and change the font
3. TrueType fonts are not available
	

Actual Results:  Could not choose a TrueType font

Expected Results:  TrueType fonts should be listed

Additional info:
Comment 1 Bernhard Rosenkraenzer 2001-11-05 09:31:40 EST
*** Bug 32131 has been marked as a duplicate of this bug. ***
Comment 2 Bernhard Rosenkraenzer 2001-11-05 09:59:14 EST
*** Bug 53890 has been marked as a duplicate of this bug. ***
Comment 3 Bernhard Rosenkraenzer 2001-11-05 10:01:30 EST
This is some weird locale issue (some TTFs work, others simply don't show up because their charset can't be determined). 
 
This is probably fixed in Qt 2.3.2; not closing the bug yet because I haven't had the time to verify the fix. 
Comment 4 Richard Allen 2001-11-05 10:14:21 EST
Turning off Font anti-aliasing seemed to help my situation a bit.
Comment 5 Bernhard Rosenkraenzer 2002-02-12 11:21:12 EST
 This is fixed in qt 3.x

Note You need to log in before you can comment on or make changes to this bug.