Bug 55488 - filesystem install requires rw filesystems
filesystem install requires rw filesystems
Status: CLOSED DUPLICATE of bug 52190
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Jeff Johnson
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-31 21:51 EST by Scott Hunziker
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-01 11:50:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Hunziker 2001-10-31 21:51:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.9-6 i686)

Description of problem:
When I tried to install filesystem-2.1.0-2.1, it failed because I had
/usr/local/games and /opt mounted read-only.  The message was:

error: unpacking of archive failed on file /usr/local/games: cpio: chown
failed - Read-only file system

I mounted them read-write and then it worked fine, but that doesn't
seem right.  If they're already there and already have the correct
ownership and permissions, it seems like you should just leave them alone.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.mount /usr/local/games as read-only
2.install filesystem package
3.
	

Actual Results:  error: unpacking of archive failed on file
/usr/local/games: cpio: chown failed - Read-only file system

Expected Results:  filesystem package should install without error

Additional info:
Comment 1 Bill Nottingham 2001-11-01 11:50:28 EST
This really can't be solved in the context of just the filesystem package.
Comment 2 Jeff Johnson 2001-12-02 19:09:20 EST

*** This bug has been marked as a duplicate of 52190 ***

Note You need to log in before you can comment on or make changes to this bug.