Bug 55490 - Make: assert() fails, make dumps core
Summary: Make: assert() fails, make dumps core
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: make   
(Show other bugs)
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 88846 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-01 04:58 UTC by Binand Sethumadhavan
Modified: 2007-04-18 16:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-07 07:45:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Binand Sethumadhavan 2001-11-01 04:58:25 UTC
This is the only line in a makefile:

a: CFLAGS += -DMAIN

There is a file a.c, which is irrelevant. I used a simple helloworld 
program.

Run make as:

binand@binand[~/testprogs]:(25) make CFLAGS+=-DMAIN a

This is the output:

cc -DMAIN -DMAIN    a.c   -o a
make: expand.c:489: allocated_variable_append: Assertion 
`current_variable_set_list->next != 0' failed.
Aborted (core dumped)

Comment 1 Nathan G. Grennan 2002-06-24 06:43:21 UTC
I have had this problem with make-3.79.1-8 included in RedHat 7.3. I ran into
this problem while trying to compile an rpm. I found for whatever reason that if
I compiled it outside of rpm it worked, but always have the error message on a
certain file building a rpm. I did a search and found the url below with a patch
that after modifying so it would apply it fixed the problem. I also had to
modify the make tar.gz file because of ^Ls in the text. The patch could probably
be modified so that it would deal with the ^Ls.

http://www.geocrawler.com/mail/msg.php3?msg_id=7907232&list=351

Comment 2 Guy Streeter 2002-07-08 19:07:59 UTC
This still occurs in rawhide make. and I also can't reproduce it outside of
rpmbuild.


Comment 3 Nathan G. Grennan 2002-07-25 15:10:54 UTC
Ran into this problem again while trying to build a xawtv-3.76 rpm. Again I am
building a new version of make with the patch I mentioned before. The problem is
still in make-3.79.1-14. Please fix it.

Comment 4 Alan Cox 2002-12-15 18:05:27 UTC
Confirmed still present in 8.0

touch a.c
make CFLAGS+=-DMAIN a
cc -DMAIN -DMAIN    a.c   -o a
make: expand.c:489: allocated_variable_append: Assertion
`current_variable_set_list->next != 0' failed.
Aborted


Comment 5 Tim Waugh 2004-07-28 15:23:53 UTC
*** Bug 88846 has been marked as a duplicate of this bug. ***

Comment 6 Jakub Jelinek 2004-10-07 07:45:42 UTC
Can't reproduce this with make-3.80-4.


Note You need to log in before you can comment on or make changes to this bug.