Bug 88846 - assertion `current_variable_set_list->next != 0' failed
assertion `current_variable_set_list->next != 0' failed
Status: CLOSED DUPLICATE of bug 55490
Product: Red Hat Raw Hide
Classification: Retired
Component: make (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-14 17:11 EDT by Enrico Scholz
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2003-04-14 17:11:35 EDT
Description of problem:

---
$ cat <<EOF >Makefile
foo:    CFLAGS+=a
EOF
$ touch foo.c
$ CFLAGS=a make foo
cc a a    foo.c   -o foo
make: expand.c:489: allocated_variable_append: Assertion
`current_variable_set_list->next != 0' failed.
---

(e.g. seen when building valgrind)


This is perhaps an upstream bug but because RHL ships a historic version of
make, I do not know if it happens with the recent 3.80 version also.


Version-Release number of selected component (if applicable):

make-3.79.1-17


How reproducible:
100%
Comment 1 Miloslav Trmac 2003-04-15 08:42:56 EDT
Workaround when building valgrind:
instead of just
     make
doing
     env - PATH="$PATH" make
caused this failure to go away. I haven't been able to find out which
environment variable was the culprit though.
Comment 2 Enrico Scholz 2003-04-15 09:29:56 EDT
CPATH is guilty...
Comment 3 Tim Waugh 2004-07-28 11:23:50 EDT

*** This bug has been marked as a duplicate of 55490 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:52:40 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.