Bug 55494 - make install for kernel customization and GRUB fails
make install for kernel customization and GRUB fails
Status: CLOSED DUPLICATE of bug 55141
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-01 03:32 EST by Tom Bledsoe
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-06 14:19:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Bledsoe 2001-11-01 03:32:25 EST
Description of Problem:


Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. Install Red Hat Linux 7.2 w/ GRUB
2. Follow "Official RH Customization Guide, RHL 7.2" Appendix A: Building 
a custom kernel.
3. Section A.1, building a Modularized Kernel, "make install" fails.

Actual Results:
Output at the end of "make install" before failure:

+ exec /sbin/install/kernel 2.4.7-10custom bzImage /usrsrc/linux2.4.7-
10/System.map ' '

/etc/lilo.conf: No such file or directory

make [1]: *** [install] Error 1

make [1]: Leaving directory ...

make [2]: *** [install] Error 2

<returns to prompt>

Expected Results:

The make process should realize that grub rather than lilo was used and 
act accordingly.  Instead, when it can't find /etc/lilo.conf - it fails.

Additional Information:
Comment 1 Jakub Jelinek 2001-11-06 14:19:04 EST
This has nothing to do with make.
Comment 2 Arjan van de Ven 2001-11-06 14:23:50 EST
This is a duplicate of bug 55141

*** This bug has been marked as a duplicate of 55141 ***

Note You need to log in before you can comment on or make changes to this bug.