Bug 55141 - /sbin/installkernel requires lilo
/sbin/installkernel requires lilo
Status: CLOSED DUPLICATE of bug 53557
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
: 55494 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-26 02:48 EDT by Russell Stuart
Modified: 2007-04-18 12:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-25 09:12:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Stuart 2001-10-26 02:48:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.17-14.ext3 i686)

Description of problem:
/sbin/installkernel requires lilo to be installed, or at least
/etc/lilo.conf to be present.  Now the default boot loader is grub there is
no /etc/lilo.conf.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Do a fresh install of RH 7.2.  Choose grub (the default) as your
bootloader.
2. cd /usr/src/linux-2.4 && make dep && make && make install


Actual Results:
If lilo is installed .....
+ exec /sbin/installkernel 2.4.7-10custom bzImage
/usr/src/linux-2.4.7-10/System.map ''
/etc/lilo.conf: No such file or directory

If lilo is not installed ......
+ exec /sbin/installkernel 2.4.7-10custom bzImage
/usr/src/linux-2.4.7-10/System.map ''
/sbin/installkernel: /etc/lilo/install: No such file or directory


Expected Results:  The make should of succeeded.

Additional info:
Comment 1 Arjan van de Ven 2001-10-26 04:10:41 EDT
Yes; we even wanted to fix this but there was a very nasty problem:
/sbin/installkernel was shared between ALL kernel rpms and while RPM allows
one file to be installed from several packages at the same time, it only allows
that if the files are EXACTLY the same. If we would change it upgrades would
break because of previously installed kernels.

The only thing we could do is move it to a package that gets installed only once
so that for a future version we are actually in a position to fix this.
Comment 2 Arjan van de Ven 2001-11-06 14:23:40 EST
*** Bug 55494 has been marked as a duplicate of this bug. ***
Comment 3 Kervin Pierre 2001-11-11 21:47:31 EST
I don't understand why this...

29c29,31
< if [ -x /sbin/lilo ]; then /sbin/lilo; else /etc/lilo/install; fi
---
> if [ -f /etc/lilo.conf ]; then
>       if [ -x /sbin/lilo ]; then /sbin/lilo; else /etc/lilo/install; fi;
> fi

ie, only run lilo when the person has a lilo.conf. or something in that
direction wouldn't work? maybe have a BOOTLOADER parameter or variable or switch?

not a rhetorical question or anything, you really lost me on the RPM explantion :)

If the problem is having to support both lilo and grub installation, couldn't
that be fixed by making the script a little smarter?

-Kervin
Comment 4 Yusuf Goolamabbas 2001-11-25 09:04:32 EST
Hi Arjan, You do realise that your documentation mentions the 'make install'
target. If you use grub this is currently borked

http://www.redhat.com/docs/manuals/linux/RHL-7.2-Manual/custom-guide/custom-kernel.html

How does MandrakeSoft or some other distrib which uses Grub solve this. 

Do they have another utility which peeks at the MBR and determine if grub/lilo
is installed and then does the right thing ?

Comment 5 Yusuf Goolamabbas 2001-11-25 09:12:09 EST
I just got email from Jeff Garzik of Mandrakesoft that they use a script called
'detectloader' which does the right thing. Maybe that is under GPL (I don't have
Mandrake installed) and RedHat can use the same script or base something of it

This would allow RH customers to use grub and not have to muck with
/sbin/installkernel in order to get the 'make install' target working

Comment 6 Erik Troan 2002-05-21 18:26:50 EDT

*** This bug has been marked as a duplicate of 53557 ***

Note You need to log in before you can comment on or make changes to this bug.