Bug 55500 - X-paste to gnome-terminal from nedit doesn't work
X-paste to gnome-terminal from nedit doesn't work
Status: CLOSED DUPLICATE of bug 54185
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
Depends On:
  Show dependency treegraph
Reported: 2001-11-01 08:08 EST by JLapham
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-11-01 10:00:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description JLapham 2001-11-01 08:08:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
Pasting text from "nedit" (a GPL'ed graphical text editor, see
http://wwww.nedit.org/) to gnome-terminal using the "X" method (hightlight
the text, use the middle mouse button to paste) doesn't work.  However,
copying from gnome-terminal to nedit does work.
X Copy/paste to and from gnome-terminal to any non-nedit X app works fine.

X Copy/paste to and from nedit to any non-gnome-terminal X app works fine
(including nxterm and xterm).  Why do I believe the problem is with
gnome-terminal and not with nedit?  Because with RH71 (and all older
versions) it was possible to X-paste into gnome-terminal from nedit.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.open nedit, type some text
2.highlight the text using the left mouse button
3.paste into an open gnome-terminal window using the middle mouse button

Actual Results:  nothing appears in the gnome-terminal window

Expected Results:  the highlighted text should appear

Additional info:

I've tried both v5.1.1 and v5.2 of nedit.
Comment 1 Havoc Pennington 2001-11-01 10:20:20 EST
nedit doesn't support the i18n text that gnome-terminal is requesting.
gnome-terminal needs the legacy STRING paste type added back for compat.

*** This bug has been marked as a duplicate of 54185 ***

Note You need to log in before you can comment on or make changes to this bug.