Bug 54185 - paste into gnome-terminal fails.
paste into gnome-terminal fails.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-libs (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
: 55500 55969 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-01 05:44 EDT by David Woodhouse
Modified: 2007-04-18 12:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-26 14:25:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2001-10-01 05:44:29 EDT
Description of Problem:

When attempting to paste text selected in exmh into gnome-terminal, it 
reports 'Selection retrieval failed' to stdout and fails to work.

'LD_LIBRARY_PATH=/net/redhat71box/usr/lib gnome-terminal' works - so it
seems to be the core libraries rather than gnome-terminal which are at fault.
Comment 1 Havoc Pennington 2001-10-03 18:08:21 EDT
Yeah, there is some interaction between the GTK/Zvt and Tk clipboard handling.
Comment 2 Havoc Pennington 2001-10-17 14:25:27 EDT
Investigated this, problem is that Tk offers only the STRING selection type, and
the multibyte patch to gnome-libs breaks STRING (asks only for COMPOUND_TEXT
with no STRING fallback).
Comment 3 Havoc Pennington 2001-11-01 10:20:15 EST
*** Bug 55500 has been marked as a duplicate of this bug. ***
Comment 4 JLapham 2001-11-01 11:03:27 EST
I am the reporter for the duplicate bug report (bug #55500).  Would it be
possible to change the "Product" and "Version" settings on this bug from "Red
Hat Linux Beta  RC1" to "Red Hat Linux v7.2" since it still exists in the
released OS?

The reason this would be a good idea is that many (well, me at least) people
will search for bug reports using the "Red Hat Linux v7.2" filter and will not
see this report.
Comment 5 Roderick Johnstone 2001-12-18 10:56:32 EST
We are seeing this also, in relation to nedit (duplicate #55500).

Any chance of a fix being available soon?? Thanks
Comment 6 Havoc Pennington 2002-02-23 16:25:50 EST
*** Bug 55969 has been marked as a duplicate of this bug. ***
Comment 7 Havoc Pennington 2002-03-05 17:20:50 EST
Should be fixed in gnome-libs-1.4.1.2.90-10

Note You need to log in before you can comment on or make changes to this bug.