This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 555014 - Available updates are not visible
Available updates are not visible
Status: CLOSED DUPLICATE of bug 568931
Product: Fedora
Classification: Fedora
Component: kpackagekit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
: Triaged
: 558142 (view as bug list)
Depends On:
Blocks: F13blocker-KDE
  Show dependency treegraph
 
Reported: 2010-01-13 07:39 EST by Martin Kho
Modified: 2010-02-27 10:12 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-27 10:12:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin Kho 2010-01-13 07:39:36 EST
Description of problem:
In kpackagekit - stand alone and system settings - available updates are not visible in the Updates Software window. When pressing the "Select all Updates" button install the updates.

Version-Release number of selected component (if applicable):
kpackagekit-0.6.0-0.1.20100111.fc13.x86_64
PackageKit-0.6.0-1.fc13.x86_64

How reproducible:
1. Check that there are updates available (yum check-updates)
2. Start Add and Remove Software (System Settings) or KPackagekit stand alone
3. Go to Software Updates
N.B. Refresh refreshes the list, but again available updates are not shown 
  
Actual results:
Updates are not visible in Software Updates window

Expected results:
Updates are visible in Software Updates window

Additional info:
Comment 1 Rex Dieter 2010-01-13 08:55:44 EST
I can confirm I've experienced this as well (mostly on fc12)
Comment 2 Martin Naď 2010-01-23 16:40:48 EST
*** Bug 558142 has been marked as a duplicate of this bug. ***
Comment 3 Martin Naď 2010-01-25 13:22:33 EST
new kpackagekit-0.5.4-2.fc12.x86_64 fix problem in comment 2
Comment 4 Kevin Kofler 2010-02-09 10:24:00 EST
Is this still happening on F13?
Comment 5 Martin Kho 2010-02-09 11:00:07 EST
Yes ;-( Comment 3 has to do with F12. In rawhide I still have version 0.6.0-0.1.20100111.fc13.x86_64 for kpackagekit and PackageKit version 0.6.1-1.fc13.x86_64.

Martin Kho
Comment 6 Martin Naď 2010-02-26 10:11:26 EST
with kpackagekit-0.6.0-0.5.r1095080.fc13.i686
     PackageKit-0.6.2-0.1.20100225git.fc13.i686
still this

this paste to console:
KPackageKit(20126): ""CurrencyIntroducedDate" - conversion of "" to QDate failed" " (wrong format: expected 3 items, got 1)" 
KPackageKit(20126): ""CurrencyIntroducedDate" - conversion of "" to QDate failed" " (wrong format: expected 3 items, got 1)" 
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
Object::connect: No such signal PackageKit::Transaction::package(PackageKit::Package *)
Comment 7 Kevin Kofler 2010-02-26 11:37:44 EST
PackageKit-0.6.2-0.1.20100225git.fc13.i686 need yet another new kpackagekit snapshot, r1095080 was for the previous PackageKit snapshot. PackageKit-qt 0.6 has a very unstable API.
Comment 9 Martin Naď 2010-02-27 10:07:28 EST
kpackagekit-0.6.0-0.6.20100223svn.fc13 work ok show updates/aviables packages.

[martin@localhost ~]$ kpackagekit 
KPackageKit(1934): ""CurrencyIntroducedDate" - conversion of "" to QDate failed" " (wrong format: expected 3 items, got 1)" 
KPackageKit(1934): ""CurrencyIntroducedDate" - conversion of "" to QDate failed" " (wrong format: expected 3 items, got 1)" 
[martin@localhost ~]$ Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
Error, cannot create transaction proxy
QDBusConnection: name 'org.freedesktop.PackageKit' had owner '' but we thought it was ':1.52'
enumFromString ( Info ) : converted "" to "UnknownInfo" , enum value 0 
enumFromString ( Info ) : converted "" to "UnknownInfo" , enum value 0
Comment 10 Kevin Kofler 2010-02-27 10:12:37 EST
OK, so the new KPackageKit fixes that, closing as a duplicate.

*** This bug has been marked as a duplicate of bug 568931 ***

Note You need to log in before you can comment on or make changes to this bug.