Bug 5551 - python/anaconda exception during install
python/anaconda exception during install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-04 21:58 EDT by cmcghan
Modified: 2015-01-07 18:38 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-20 14:37:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cmcghan 1999-10-04 21:58:09 EDT
When the installer goes to retrieve package information, I
get the below error.


Traceback (innermost last)
  File "/usr/bin/anaconda.real", line
225, in ?
    intf.run(todo, test = test)
  File
"/tmp/lib/python1.5/site-packages/text
.py", line 1000, in run
    rc = apply (step[1](), step[2])
  File
"/mnt/redhat/comps/install/6.1/i386/mi
sc/src/trees/hdimage/usr/lib/python1.5
/site-packages/textw/packages.py",
line 10, in __call__
Comment 1 npa 1999-10-07 16:04:59 EDT
Actually, here is the whole text of the error message...

File "/usr/bin/anaconda.real",
  line 225, in ?
  intf.run(todo, test = test)
File
  "/tmp/lib/python1.5/site-packages/te
  xt.py", line 1000, in run
  rc = apply (step[1](), step[2])
File
  "/mnt/redhat/comps/install/6.1/i386/
  misc/src/trees/hdimage/user/lib/pytho
  n1.5/site-packages/textw/packages.py
  ", line 10, in __call__
File
 "/tmp/lib/python1.5/site-packages/to
  do.py", line 90, in getHeaderList
  self.hdList =
  self.method.readHeaders()
File
  "/tmp/lib/python1.5/site-packages/ha
  rddrive.py", line 46, in readHeaders
  return HeaderList(hl)
File
  "/tmp/lib/python1.5/site-packages/co
  mps.py", line 50, in __init__
  name = h[rpm.RPMTAG_NAME]
  TypeError: unscriptable object
Comment 2 fabio 1999-10-07 21:00:59 EDT
Bug# 5551 and Bug# 5638 are the same.
It's the same problem here. It seems to be related to the fact we are
using a local hard drive (ext2) as the installation media. Am I right?
Comment 3 stevek 1999-10-07 21:15:59 EDT
I have a similar problem when doing a ftp network install.
Comment 4 kirill 1999-10-09 01:15:59 EDT
Same exact thing when installing from a DOS partition.
Comment 5 cmcghan 1999-10-09 01:24:59 EDT
this problem occurs during an FTP install. didn't try installing from
local media ... i'm back to 6.0 now. blah. :)
Comment 6 bueno 1999-10-09 11:09:59 EDT
5741,5638,5618,5691,5615,5551
all seem to be related!
This really needs to be sorted out...
(i don't want to have to burn the cd :-)


------- Additional Comments From   10/09/99 19:08 -------
I have exactly the same problem. I downloaded the redhat-6.1-tree from
a FTP-site to a ext2 partition so first I thought some files had been
corrupted but now I know it really is a bug.
Python whines about the same error in a same file.
Comment 7 Eric Hagberg 1999-10-10 23:40:59 EDT
this happens to me as well, using the iso file, unbundled to an ext2
filesystem on a different drive from the one to which I'm installing.

Not doing an upgrade, just a fresh install, but perhaps this is
related to having a FAT32 partition on one of my drives in the
machine?
Comment 8 johnlar 1999-10-12 00:50:59 EDT
no not related to the fat32, but I've only seen this bug on a fresh
install from a network. With no other partitions so I can say that
isn't the problem. BTW it worked perfectly fine from a cd burn (though
my friend burned me lorax instead of 6.1 true. ARG!!! side note.. had
this same problem trying to install from ftp for lorax too!)
Comment 9 kirill 1999-10-14 00:07:59 EDT
SOLUTION (at least for HD installs): remove all files other than
*.rpm from the RPMS directory.  If you used WS_FTP, ws_ftp.log is
probably the file you are looking for.

In the source of harddrive.py the check for the .rpm extension is
disabled to allow compatibility with ms-dos's 8.3 filesystem, so any
invalid files in that directory are loaded as rpms, thus causing the
"unsubscriptable object" exception.

Many thanks to Marvin Claitman of linux.redhat.install for catching
this one.


------- Additional Comments From   10/14/99 09:23 -------
Same problem with an upgrade from 6.0 -> 6.1 but with a Windows VFAT
partition in /dev/hda1 and ext2 Linux on /dev/hdb2.  Tried with an DOS
 HD install, Got the anaconda error.
Comment 10 dexter.fryar 1999-10-14 11:30:59 EDT
You were exactly right on the FTP log file. I am running win98 on my
laptop with the redhat tree on my fat32 partition. I tried an install
by booting from the floppy and specifing my fat32 partition as the
source containing the installation tree. I kept getting the following
error:

Traceback (innermost last):

  File "/usr/bin/anaconda.real", line 225, in ?
    intf.run (todo, test = test)

  File "/tmp/lib/python1.5/site-packages/text.py", line 1000, in run
    rc = apply (step[1](), step[2])

  File "/tmp/lib/python1.5/site-packages/text.py", line 468, in
__call__
    todo.getCompsList ()

  File "/tmp/lib/python1.5/site-packages/todo.py", line 942, in
getCompsList
    self.getHeaderList()

  File "/tmp/lib/python1.5/site-packages/todo.py", line 930, in
getHeaderList
    self.hdlist = self.meathod.readHeaders()

  File "/tmp/lib/python1.5/site-packages/harddrive.py", line 46, in
readHeaders
    return HeaderList(hl)

  File "/tmp/lib/python1.5/site-packages/comps.py", line 50, in
__init__
    name = h[rpm.RPMTAG_NAME]
TypeError: unsubscriptable object


After I rebooted to windows and deleted the log file in the RPMS
directory the install went fine. Thanks for the tip!
Comment 11 Gene Czarcinski 1999-10-17 21:53:59 EDT
This may be related to bug #6033 ... anaconda does NOT handle
misspelled package names in comps.
Comment 12 Jay Turner 1999-10-20 14:37:59 EDT
I am closing out this bug due to the fact that everything that I see
can be covered by either #5555 (NTFS and HPFS problem) or by removing
all non *.rpm files from /RedHat/RPMS directory.  I am putting in a
new bug #6159 ro address the non *.rpm file problem.

Note You need to log in before you can comment on or make changes to this bug.