Bug 5638 - Upgrade fails in Reading package info -- NO ntfs partitions on box
Upgrade fails in Reading package info -- NO ntfs partitions on box
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-06 12:00 EDT by Nadeem
Modified: 2015-01-07 18:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-20 16:12:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nadeem 1999-10-06 12:00:21 EDT
When I attempt to upgrade my RedHat 6.0 installation to 6.1,
the upgrade fails in Reading Package Information. The
installation media is a local hard drive (/dev/hdb). I
noticed there seems to be a problem with upgrading if an
ntfs partition exists, however I don't have one, but here is
my partition table anyway (just in case there is another
partion table related error)

Disk /dev/hda: 255 heads, 63 sectors, 2100 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1             1        17    136521   82  Linux swap
/dev/hda2            18        34    136552+  82  Linux swap
/dev/hda3   *        35      2100  16595145   83  Linux

Disk /dev/hdb: 16 heads, 63 sectors, 12592 cylinders
Units = cylinders of 1008 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hdb1   *         1     10592   5338336+  83  Linux
/dev/hdb2         10593     12592   1008000    5  Extended
/dev/hdb5         10594     12591   1006992   83  Linux

/dev/hda3 is /usr , /dev/hdb1 is / , and /dev/hdb5 is /usr2
and the hard drive containing the redhat install files.


Here is the python error info (hand coppied so itmight be
slightly inaccurate)

/t/l/p/sp = /tmp/lib/python1.5/site-packages/

Traceback (innermost last ):
	File "/usr/bin/anaconda.real", line 225, in ?
		intf.run(todo, test = test)
	File "/t/l/p/sp/text.py", line 1000, in run
		rc = apply(step[1](), step[2])
	File "/t/l/p/sp/text.py", line 251, in __call__
		todo.upgradeFindPackages(root)
	File "/t/l/p/sp/todo.py", line 1147, in upgradeFindPackages
		self.getCompsList()
	File "/t/l/p/sp/todo.py", line 942, in getCompsList
		self.getHeaderList()
	File "/t/l/p/sp/todo.py", line 930, in getHeaderList
		self.hdlist = self.method.readHeaders()
	File "/t/l/p/sp/Comps.py", line 50, in __init__
		name = h[rpm.RPMTAB_NAME]
	TypeError: unsubscriptable object


I'm not really familiar with python, so I'm not exactly sure
whats going on.
Comment 1 fabio 1999-10-07 20:58:59 EDT
Bug# 5551 and Bug# 5638 are the same.
It's the same problem here. It seems to be related to the fact we are
using a local hard drive (ext2) as the installation media.
Comment 2 bryan 1999-10-07 21:35:59 EDT
again, this is the same bug as 5618, but I wasn't using ext2 as
installation media, I was using FTP.
Comment 3 Nadeem 1999-10-08 17:45:59 EDT
Well, I got off my lazy ass and burned the iso to cd, everything went
smoothly therafter. So, it seems your guys hunch about the problem
being due to the installation media (e.g. ext2 partition -- perhaps
even local hd in general?) is the cause.
Comment 4 Jay Turner 1999-10-20 16:12:59 EDT
Please see bug #6159, as that describes the problem which you appear
to be having.  I am discarding this bug to prevent clutter, as details
are in that bug posting.

Note You need to log in before you can comment on or make changes to this bug.