This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 555311 - RFE: Better groups exclusion support
RFE: Better groups exclusion support
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pykickstart (Show other bugs)
5.5
All Linux
high Severity high
: beta
: ---
Assigned To: Chris Lumens
Alexander Todorov
: FutureFeature, TestBlocker
Depends On: 554717
Blocks: 558516
  Show dependency treegraph
 
Reported: 2010-01-14 07:13 EST by Alexander Todorov
Modified: 2010-03-30 04:26 EDT (History)
2 users (show)

See Also:
Fixed In Version: pykickstart-0.43.8-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 554717
: 558516 (view as bug list)
Environment:
Last Closed: 2010-03-30 04:26:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 3 Alexander Todorov 2010-01-19 13:33:13 EST
with anaconda-11.1.2.200-1 and a ks.cfg file containing:
%packages
*
-@conflicts 

there is a file conflict error on x86_64:


07:53:51 ERROR   : file conflicts: file /usr/bin/ecpg conflicts between attempted installs of postgresql-devel-8.1.18-2.el5_4.1.i386 and postgresql84-devel-8.4.2-4.el5.i386
07:53:51 ERROR   : error running transaction: file /usr/bin/ecpg conflicts between attempted installs of postgresql-devel-8.1.18-2.el5_4.1.i386 and postgresql84-devel-8.4.2-4.el5.i386
07:53:51 ERROR   : file conflicts: file /usr/bin/pg_config conflicts between attempted installs of postgresql-devel-8.1.18-2.el5_4.1.i386 and postgresql84-devel-8.4.2-4.el5.i386
07:53:51 ERROR   : error running transaction: file /usr/bin/pg_config conflicts between attempted installs of postgresql-devel-8.1.18-2.el5_4.1.i386 and postgresql84-devel-8.4.2-4.el5.i386

This conflict is reported in bug #552219
Comment 5 Pavel Holica 2010-01-25 04:00:35 EST
RHEL5.5-Client-20100117.0
anaconda-11.1.2.200-1
pykickstart-0.43.8-1
Tried with:

%packages
@Everything
-@conflicts

in kickstart. Installation failed due to dependency problems.
Comment 6 Chris Lumens 2010-01-25 09:44:13 EST
Then that would be almost certainly be an anaconda problem, not a pykickstart problem.  All pykickstart does is parse the input kickstart file and provide the results to anaconda.
Comment 10 errata-xmlrpc 2010-03-30 04:26:56 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0248.html

Note You need to log in before you can comment on or make changes to this bug.