Bug 555391 - Use --listed-incremental results in incorrect "GNU features wanted on incompatible archive format" error in RHEL-5
Summary: Use --listed-incremental results in incorrect "GNU features wanted on incompa...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tar
Version: 5.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Ondrej Vasik
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
: 589552 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-14 16:31 UTC by Orion Poplawski
Modified: 2010-05-06 13:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-18 13:34:30 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Orion Poplawski 2010-01-14 16:31:17 UTC
Description of problem:

Trying to run a newer version of amanda with the Fedora xattrs patch results in:

/bin/tar --create --file /dev/null --numeric-owner --directory /export/cora3/werne/amundsen3 --one-file-system --listed-incremental /var/lib/amanda/gnutar-lists/alexandria_export_cora3_werne_amundsen3_1.new --sparse --xattrs --ignore-failed-read --totals --exclude-from /var/log/amanda/sendsize._export_cora3_werne_amundsen3.20100113190009.exclude .
/bin/tar: GNU features wanted on incompatible archive format

tar does not complain on Fedora 12, and the info page on 5.4 does not seem to indicate that using --xattrs would be a problem on posix archives.

Version-Release number of selected component (if applicable):
tar-1.15.1-23.0.1.el5

Comment 1 Ondrej Vasik 2010-01-18 13:11:06 UTC
Thanks for report...
Difference is there:

RHEL 5.4 has:
if (volume_label_option && subcommand_option == CREATE_SUBCOMMAND)
    assert_format (FORMAT_MASK (OLDGNU_FORMAT)
		   | FORMAT_MASK (GNU_FORMAT));

if (incremental_option || multi_volume_option)
    assert_format (FORMAT_MASK (OLDGNU_FORMAT) | FORMAT_MASK (GNU_FORMAT));

if (sparse_option)
    assert_format (FORMAT_MASK (OLDGNU_FORMAT)
		   | FORMAT_MASK (GNU_FORMAT)
		   | FORMAT_MASK (POSIX_FORMAT));
F-12 has 
if ((volume_label_option && subcommand_option == CREATE_SUBCOMMAND)
      || incremental_option
      || multi_volume_option
      || sparse_option)
 assert_format (FORMAT_MASK (OLDGNU_FORMAT)
   | FORMAT_MASK (GNU_FORMAT)
   | FORMAT_MASK (POSIX_FORMAT));

It means that incremental, multivolume and volume label option (when creating archives) are not allowed for POSIX_FORMAT on RHEL-5.4. Will check why, it could be either just by accident or intentionally.

Comment 2 Ondrej Vasik 2010-01-18 13:34:30 UTC
Changing summary - this has nothing to do with xattrs patch.

I checked the changes for incremental option in upstream git and they look quite invasive for RHEL-5 . I'll close that bugzilla WONTFIX - it has nothing to do with xattrs patch, it is caused by --listed-incremental option which is not supported in RHEL-5 tar for POSIX format. This option was never supported in RHEL-5 tar for POSIX format and therefore it can't be used.

Related upstream commits:
http://git.savannah.gnu.org/cgit/tar.git/commit/?id=aea1d50da919e8649e6eb7ae849db2511e3636f1
http://git.savannah.gnu.org/cgit/tar.git/commit/?id=f6458a827ae7a2c41616490f653714068072b257
... maybe several others - haven't checked this more closely.

Comment 3 Ondrej Vasik 2010-05-06 13:45:21 UTC
*** Bug 589552 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.